Badge Not Awarded - Quatch Quest

I selected Quatch Quest from the ride menu, and started riding. I never made any attempt to deviate from the route – just kept going until I reached the top of the Alpe. The random spin wheel appeared like it usually does, but no “route completed” notification. I continued around the loop and back down the Alpe, then ended the ride. Strava found the completed route…

… but Zwift did not.

This issue is not unique. See my posts on Astoria Line 8 and The Knickerbocker.

It seems to be a lottery as to one receives an achievement badge or not.

1 Like

Same thing for me just now… and Quatch Quest you dont want to do too often… gahhhh… so frustrating…

1 Like

Quatch Quest badge is broken. Maybe will be fixed when new update show up.

1 Like

Same here. Zwift support is letting know some bagdes are broken and will be fixed in naxt update. There is no whay they can award any badges, so you have to ride the route again…and Quatch Quest isn’t the easiest one. Ride on :slight_smile:

1 Like

Same here, did it last night, no badge

1 Like

Same here. Rode it yesterday, but no badge or xp. Thankfully this route is one of the easier…

Just did the Quatch Quest route again and received the batch at the top of AdZ. Without any U-turns at the start. So working like it should.Ride-on!

Good to know!

Has anyone else had success with this one. Failing to get the route badge was Zwift’s lump of coal in my X-mas stocking. I haven’t tried the Alpe since then.

Hey Tim,
To be 100% sure to complete this badge make u turn at start, finish kom and again u turn like on pic below.

1 Like

the start finish is a bit further than that white line in the pic above.

Strava says I did it on Dec 25, 2019…no route badge was given

highline in new york also not working

Can any Zwifters verify the start for Quatch Quest is shown correctly on the latest Watopia map (v2.12 at https://zwiftinsider.com/map/ )? It shows a spawn point east of the start pens and indicates to ride toward Titans Grove. Some responses to this thread indicate that one should travel west from the spawn point to a turn-around spot (? the bridge?..? the rock arch? ).

image
image

Thanks

You need to uturn ride past the rock arch. the rock arch is the Start and finish banner for events so you need to pass that the start the route.

image

The bridge is just a graphical element

1 Like

Thanks, that must mean that the latest Watopia map is in error about the route.

No the map show where the spawn point is and how Zwift wil route you. The thing is for the badge to activate you need to pass a “START” point first.

Zwift should move the Spawn point for this route. or not require you to pass a start banner.

1 Like

I’ve just done the Quatsch Quest and have been rewarded with a badge. No U-turn, just entering after selecting the route and on top of AdZ i got my badge. I think it’s solved now.

2 Likes

Zwift has moved the spawn point east of the starting pens with latest update.
Didn’t do Quatch Quest, so I’m not sure, but I did Dust in the Wind, there was exactly the same issue.