Multiple badges still not working

my partner and I have not been receiving badges on a number of rides - is there any plan to correct this? Or at least can we have a list of ones with known issues so we can avoid them for now?

He uses both an iOS iPad or a windows based notebook, both of which have the latest update; I am on a MacBook Pro, also updated.

  • Surrey Hills - he didn’t get his (was on windows); it worked for me
  • Quatch Quest - neither of us (he was using an iPad at the time)
  • Three sisters - me
  • Watopia hilly - him (on windows); worked for me (I rode route before update)

@Stacey_Rich
We appreciate your report with notes. It’s odd that some of them worked as intended for one of you, but not the other.

First - the routes with known achievement bugs are Dust in the Wind and Out and Back Again. Those are being worked on and should be fixed in the next release.

We are not aware of issues with the ones you reported with the exception of Surrey Hills. We’ll look into all of them.

Part of the issue with Surrey Hills is the lead-in distance before the (lack of) a clear official start line. This leads folks to think they’ve completed the route when the official finish might still be a few km down the road. We know this is confusing, and the visual experience can be better. We have an ongoing conversation with our Game team to consider improving this route.

I missed out on the Dust in the Wind badge a week ago and was just now checking into if there was an issue with something I did. It appears now that it wasn’t me (I rode well past the end of the route just in case), and that it is a known issue.

@Stacey_Rich
Our QA team confirmed that Quatch Quest can be buggy under some circumstances, so that one’ll be fixed in the next release too. Thanks for bringing this to our attention!

No code issues were found on Watopia Hilly or Three Sisters. If you’re riding all the way past the orange arch in the downtown Watopia, you should should receive the route badge.

@Ted_Hohl
Yes, sorry about that, but this will be fixed in the next release.

I have also na issue with the RUN badge That’s Amore that will not unlock (after 5 tries)

You have to run a little ways beyond the finishing banner and you will be awarded it. It worked for me last week.

Ran 8km, why past the finish line :frowning:
Also did a U turn in the beginning to get behind the start line, without any luck

What happened is during my first run on this route this badge unlocked but Zwift (on my iPhone) stopped unexpectedly. When restarting Zwift it picked up my run again, but the bange was gone and I was never able to unlock the That’s Amore badge again.

Zwift support is notified via ticket but they are referring to next update and don’t mention it could be related to the crashed Zwift. I hope it will be fixed with the next update.

Hi,

Three sisters seems to be bugged, I rode the route (selected it ingame as usual) and received no badge at the arch.

Distance: 47.8km (29.7 miles), I rode 55.5km

Hi @Tim_D welcome to the Zwift forums.

Can you give me more detail so we can investigate? What day did you ride the Three Sisters?

Thanks for the fast response, sorry should have included that!

I rode yesterday 21 January at 08:30 PM (CET)

Hello I just rode sand and sequoias and did not get the badge. I rode an extra 2 miles just to make sure of the lead in. Is this a bug? I rode it today Feb 5th.

Sand and Sequoias starts and ends at the sprint arch. I think everyone spawns near the pens and you have to ride partially around the first roundabout and on to the sprint line and the final arch which starts the route and then all the way around to the same spot.

@Fez_Rockbottom is correct. Sands and Sequoias has a decent lead-in. The route officially starts under the stone arch at the end of the sprint. You go out and make a turn back before entering Titans Grove. You then go under the stone arch again, do the roundabout to head back to the sprint segment and it ends when you finish the sprint section under the stone arch. So you have to pass the arch 3 times to complete that route.

Thanks for the info. I went back to the sprint but I stopped halfway through because it said I did 14 miles. LOL If I would have gone .3 more i would have finished. I will do it again today , it was a great course.

2 posts were split to a new topic: Richmond route badges not credited

Tried Three sisters route again yesterday 22.02,2020, because I thought there might be long leadin and did 77km instead of 48km, no badge

No the Three sisters does not have a lead-in.

https://support.zwift.com/en_us/zwift-worlds-and-cycling-routes-Sy2_gxTGB

Compare your strava segment to the zwiftinsider segment.

This is my strava route, it looks the same to me as on zwiftinsider :slight_smile:

Can you double check you unlocked badges from your menu page in game for us Tim? It sounds like you may have unlocked the badge previously. If it’s definitely not there, you may want to reach out to the Support Team via email at Support@zwift.com. We won’t be able to credit the badge to you account, but if you provide us with your logs, we can investigate why the badge wasn’t given out.