Latest update - Something went wrong. Please try restarting Zwift

After upgrading to the latest version on 23-04-2021, when starting Zwift on OSX it keeps on telling me to restart:

“Something went wrong. Please try restarting Zwift.”

It will only work if I startup without Wifi, start Wifi when the Zwift login screen pops up. After logging in everything working fine as normal. But after a ride and restarting Zwift again, same issue again.

From the launcher_log.txt:

[21:43:35 2021-04-23] Patcher: Local Launcher version is “1.0.7”.
[21:43:35 2021-04-23] Patcher: Server Launcher version is “1.0.5”.
[21:43:35 2021-04-23] Patcher: Launcher URL for updating self is
[21:43:35 2021-04-23] Patcher: No update available, deleting temp files…
[21:43:35 2021-04-23] Launcher: Calling Update Launcher Check
[21:43:35 2021-04-23] Launcher: Calling Update Process Available
[21:43:35 2021-04-23] Launcher: Update Not Found.
[21:43:35 2021-04-23] Launcher: Webview loaded some URL.
[21:43:36 2021-04-23] Launcher: Webview loaded some URL.

Anyone any idea what the issue is?

This thread: Can't launch Zwift errors 400 403 404? [April 2021]

1 Like

Did some debugging and cleared safari cache/cookies a couple of times and all of a sudden no more 40X with the /launcher/?state

Had to login again and working fine now.

But when I repeat clearing cache/cookies in Safari I can always login without providing username/password and when looking at the first couple of requests cookies are being set in the outgoing request so not sure this Safari cleanup did the trick. :thinking:

2 Likes

I was using Microsoft Edge and had a similar problem. Reinstalled using Chrome. Works fine.

1 Like

What? Zwift doesn’t use Chrome at alll under ANY circumstance, on a Windows PC it uses Internet Explorer.

I have the same isssue.

1 Like

I don’t know why it worked Paul. Zwift stopped working on my PC, I tried to reinstall it using the Edge browser, it failed 3 times. I tried a reinstall using the Chrome browser and it worked and still works.

The same for me on two MacBooks. I switched from one to another after first time. Now it’s broken also on second. What a destroying my willingness of doing FTP test today. Googling instead of riding.

1 Like

turn wifi off, launch zwift, click yes to continue loading even though you’re offline then as it starts to load turn wifi back on.

2 Likes

Yes, it helped. I’ve found this in one of previous comments. But going this way I will need do this every time. And I’m afraid it will never download update which fixes this issue. That’s the problem.

I have the same problem. Could not start Zwift. Tried the tip turning off WIFI but it did not work.
Any idea?
Thanks

Clearing cookies etc on MS Edge finally solved it. I had previously tried re-installing, updating drivers, clearing cookies on chrome, etc, etc. what a pain.

1 Like

this worked for me thanks Paul, top banana

had to clean everything, but i think the kicker is cached web passwords. which could be a pain for some. once i had to log in it worked as i only cleared the other data to no avail first

So since the last update iv managed to log onto zwift once, apart from that something went wrong please try restarting zwift. cleared browser data in microsoft edge, google chrome and reinstalled still same issue.

Try these steps: Internal Server Error 400 / 403 (Clear your browser) - #184 by Dave_ZPCMR

1 Like

champion

I had this problem this morning tried all of the above with out much success.
Ended up completely removing Zwift from my laptop and all associated cookies from explorer, then full reinstall. It showed up the same but this time did a major update that took half an hour. Now seems to work.

I’ve lost patience with it so I’m not bothering to ride this morning and seriously considering dropping my Zwift account. Why is it that every time they do an update nothing works properly :exploding_head:

same issue with me… last time I was able to ride was last 3 days ago, now this popped up, I cannot log anymore… I tried the running the app when wifi is off (read on previous thread), but seems not working on my end still. I tried to reinstall the app 2-3 times i think. tried to tick on/off my firewall (just in case) but still to no avail. any other solutions?

Same issue today here. Clear Safari History and it works.

J.

1 Like