KICKR Core reports zero watts [Feb 2024] [1.58] [macOS 11] [SOLVED]

The update just applied for me, but since then although my Kickr Core (latest firmware) connects both as power source and smart resistance, no watts are received and the resistance does not change. I’m using Bluetooth connection to MacOS. In the end I rode with my Garmin Vector 3 as power source, which gave watts, but Kickr resistance still static.

Kickr paired fine on the dual band Bluetooth to the Wahoo app on my phone, and gave watts as expected.

Tried restarting Zwift, and restarting the computer, but no difference.

Hi @Thomas_Wright1
Shuji at Zwift HQ here. I’m looking through your server logs from the past few days.

I see you logged in several times today. Did what you are describing happen on your first session today on Champs-Élysées? If yes - I can confirm that you had your Garmin Vector 3 chosen as the power source and the KICKR Core set as the Resistance/Controllable signal. I can also see that your CORE is on the latest firmware. Thanks for checking that on your end.

It’s important to pair the trainer’s Power signal first. Once the trainer’s Power signal is bonded to Zwift - the trainer’s Resistance signal will take another 10 - 15 seconds before it broadcasts and becomes visible to Zwift. This lag is expected if you’re pairing over Bluetooth (BLE). Then choose your Core as the Resistance source. Please make sure this pairing sequence is working as described?

If you’ve ever paired your Garmin Vector 3 pedals to Zwift before - the game will remember them and it’s possible that it will pair with the pedals before it pairs to the trainer. Please be mindful of this and check which source is auto-pairing first.

There are Zwifters who intentionally want to pair to a second power source on the bike itself (i.e. pedal / crank / hub power meter). In this case you’ll still need to pair to the trainer’s Power signal, then its resistance signal. After that - deselect the trainer’s Power signal and connect instead to the second power signal. I understand this is not what you want to do intentionally - but putting it out there for anyone reading along with symptoms similar to yours.

Does any of this help clear up the resistance issues for you? Please let us know either way.

Kind of a tangent…does editing knowndevices make any changes to auto-pair behavior now? It’s been quite a while since I’ve played with it but now that I think about it, it’s been a while since Zwift automatically grabbed the wrong trainer. All the right devices and none of the wrong ones have auto-paired lately.

Thanks for gettIng back to me so quickly. I’ve just tried again, with exactly the same results. Although the Kickr Core pairs automatically as normal for both power and resistance, it doesn’t pick up any power data and stays at 0W. The resistance issue is secondary. Of course the avatar doesn’t then move in the game.

Note I normally use the Kickr for power, but used the Garmins for yesterday’s ZRL, hence the state things started in today.

Thanks for looping back promptly!

There may be something in your environment hijacking your trainer’s signal. The server logs on my end will not indicate anything that Zwift can’t “see” is happening on your end, so we’ll need you to check on things below and get back to us.

You mentioned you cross-checked with the Wahoo app on your phone. As you have the Vector 3 pedals - might you also have the Garmin Connect app installed on your phone or laptop? If so - please uninstall it for the sake of troubleshooting. I have personally experienced power signal dropouts because GC was running in the background and hijacking my trainer’s BLE signal. Once I uninstalled it - no more dropped power signals.

The Wahoo ELEMNT app is less problematic in my experience, but it might be worth uninstalling that too just to be thorough. What about other cycling hardware apps? Please scroll through your phone for possible candidates.

The other thing to check for is a cycling computer (the type on your handlebars) that might be powered on or charging.

Oh hey - unrelated to signals getting hijacked - but if you unpair from the power / resistance signals and re-bond to them manually - how long are you waiting in the Pairing Screen for a signal to reappear? The 10-15 seconds if you’re pairing over Bluetooh is expected and normal. Maybe give it a full 60 seconds - 2 minutes for shiggles, and let us know if there’s a longer-than-normal delay in signal visibility?

To avoid any confusion, I’ve turned off Bluetooth on my phone, and not woken the pedals. Kickr and computer started from being powered down. No Garmin Connect or Headunit involved.

Zwift automatically connects to the Kickr as both power source and resistance, only a few seconds delay, just like normal.

Waited 2 mins before turning cranks. Power still 0W. Dropped in to the game so you can see the connection (New York) but still no watts.

Re-enabled Bluetooth on my phone, and Wahoo app can see watts from the Kickr over the 2nd Bluetooth connection.

Thanks for investigating.

I split this tangent from its original post into its own topic. We’re looking into it. Thanks for the prompt and detailed help in troubleshooting with us.

If other KICKR Core (or other model) owners are running into similar zero watts / avatar not moving symptoms, please raise your hand, and let us know what computer you’re using (model and OS version), and which firmware version is loaded on your Wahoo trainer. Thank you.

1 Like

Raising hand with same symptoms.
MacBook Pro 11.7.3
Wahoo firmware: 1.3.17

Zero power registering in Zwift even though bluetooth connection is solid. Tried several times including unplugging KICKR Core as well. Power registers correctly in Wahoo app. Everything was working well on Zwift yesterday after Wahoo firmware update. Thank you.

1 Like

Hi @Aaron_Underwood welcome to Zwift forums.

It might be nothing, but you and @Thomas_Wright1 are both running Zwift on macOS 11 Big Sur machines.

What’s the odds that either of you have a Mac running a newer OS version that you can try?

Or is the one you have able to upgrade to a newer version? If you upgrade the OS, the per-app permissions might get reset to default (more restrictive) security settings, and you might need to do the things on this support article to get Bluetooth pairing to work properly.

I’m on a fairly old iMac - 27” 2014 Retina model, Intel, Big Sur is the latest OS that can be installed, so unfortunately no option to upgrade.

Chiming in. Exactly same as Aaron and Thomas.

iMac 10.15.7 (latest mine will go)
Wahoo Core latest update 1.3.17

Connects fine through BT but shows 0 watts or cadence.

Switch to ANT and works fine. (Not my preferred option as I run too many fans in a very hot location).

Working perfect for years until last update.

Connects fine and displays power / cadence as expected on other cycling apps on same computer through BT

Edit: just tried Zwift iOS (iPad) and it works fine as well with BT. Feels like it’s Zwift’s MacOSX code in the last update.


Since your OS is supported by Zwift you should not need to do this, but if you want to do an unsupported (by Apple) update to something newer than Big Sur, you can use OpenCore Legacy Patcher. I would be interested to know if it helps. If it’s something related to the Bluetooth hardware in the affected machines then it might not, but it would get your machine on an OS version that still receives security updates and bug fixes. Big Sur end of life was last September.


Thanks for this link. I’ve been vaguely aware of this, and wondering how long I can put it off for. I’d rather not go down this route for now - hopefully a fix can be put in place :slightly_smiling_face:

Just to round off the testing, I have been able to try an M1 MacBook Pro running Ventura, and confirm that works fine with everything else in the setup the same. So the issue is definitely isolated to older MacOS and/or older hardware. Given this has worked fine for years, I hope a fix will be possible :crossed_fingers:


Welcome @Daniel_Carson to the chat and thank you also for helping us troubleshoot.

Good news: our engineers are confident they’ve found the fix and we’re working on releasing a patch as soon as we’ve verified it. We’re shooting for end of this week / early next. Thanks for your patience, we really appreciate all of you chiming in and helping us to troubleshoot with your quality feedback.

Couple of notes:

Pairing over ANT+ works to solve the immediate problem of zero watts - but if you want to use the virtual shifting feature enabled last week for KICKR Core via firmware update - virtual shifting only works over Bluetooth.

As noted upstream - Zwift does support macOS Big Sur, but Apple has end-of-lifed their support for it. At some point, Zwift will too. Eventually. Not today or next week - but someday. The last time we deprecated support for old macOS versions was because computers that originally shipped with macOS 10.14.4 or older are physically incapable of supporting the Apple Metal graphics API. At some point, our beloved older devices will reach the end of their useful lifetime for running 3D games as the technologies used to create and run them marches forward.


Thanks for the update :slightly_smiling_face:

Exact same issue with me. Running Zwift on Late 2013 Macbook Pro with MacOS 10.15.7. I zwifted yesterday without any problems. Today, the update hit. Power and cadence was showing zeros. Tried it out with the Wahoo app, values were shown okay. So my Kickr is still working. I checked the supported OS is shown as Microsoft® Windows 10 64bit or higher, or macOS® 10.14.4. Has there been any changes to this?

1 Like

Hello @Mert_Esgi thank you for weighing in.

Please see two posts above yours.

Thanks for the prompt answer @shooj Looks like we were typing at the same time :smile: