KICKR Bike Powerup and U turn buttons don't work [1.34] [April 2023]

@Rowdy so this evening I tested it again on 1.39. Started a free ride with D Bernie as a warm up. Steering and power up buttons working on Kickr Bike V1. Joined the Herd Saturday Doughnut Ride and steering disabled (expected) but was finally able to use the power up button to active power ups during the ride. After the ride ended and selected “stay here” steering worked again as well as power up button.

Hoping this isn’t a fluke and 1.39 fixed whatever 1.34 broke. Will let you know if it shows up again

Is it possible the issue is workout related - Lats night i completed the race work out and after the workout (as i joined straight to the Workout) it left me on the Map (at the village i believe) while the work out ended the ERG enforcement did not stop and my buttons stopped working. SO basically, i finished the race WO4 stayed on for the cool down but once it finished i was limited to the cool down ERG and buttons stopped.
Anybody else see the same?

Did the steering was disabled during the group workout?

No - work out steering was active, no issues to report only broke post completion

Interesting! Something new then maybe…

I noticed that if I end my workout on a flat road (Tempus Fugit to name it) the resistance will be stuck at the one required by the workout… until the road start to go up or down. Like being stuck in erg mode.
But I’m not sure that it’s a recent issue neither that it’s a Zwift (and not a KB) issue.

I have the same issue.

On initial log in and on free ride all buttons work as the should.

On joining a group ride/event the power up and steering buttons stop working.

This includes robo pacer rides.

On finishing the group ride the buttons still do not work despite exiting the map and starting a new route. Only by rebooting zwift Will the buttons begin to work again.

Using kickr V1 and PC.

Same issue here with a Kickr Bike v1. I’ve done two Chasing Tour | Chasing Pink-races this week, and steering was not working in any of them. (Luckily I was placed in the middle of the road so I mostly stayed in the draft anyway.)

Same problem last week. I verified that steering and PU button worked during free-ride, but as the (steering-enabled) race started I was placed firmly at the right side of the road without any means to steer into the draft. Problem remained as I exited the event (neither steering, PU button, nor U-turn button worked). Unpairing or changing world didn’t help, only restart of Zwift did.

Just want to mention I’m getting the exact same issue. Using Apple TV (latest version) and kickr bike v1. I thought it was related to the latest release of Zwift which caused this, but looks like it’s from April (I’ve had some time away from the game)

I was just following a simple course for the badge, so nothing special like joining an event.

Gears worked fine, but was not able to activate power up, or do a u-turn.

Steering did work for a little bit, but also noticed this stopped working mid way through the course…

Can Zwift get this sorted asap please - this is clearly a frustrating issue for kickr bike users.

Riding Kickr Bike V1. Windows PC
Raced the Morning HISP race today and noticed steering was turned off.
Received an aero PU at first passage of Start/Finish banner that I saved for the final sprint so I didn’t attempt activating PU until at the end.
Being caught up in the sprint I presses the PU button on the Kickr bike and thought that it activated. I wasn’t looking to see if it actually did as I was winning the sprint. It was actually only after passing the finish line I noticed I still had an aero PU. I tried pressing the Kickr bike PU button and nothing happened. So it seems I won the sprint without my Pu. Presses the spacebar on my keyboard and the PU activated.
Exited the race and went into a free ride where steering was on. Got a PU and pressed the PU button on the Kickr bike and it activated.
So it seems when steering is disabled the action buttons on the kickr bike are also disabled.

I did not have any issues in the race with being pushed to the right. This only seems to happen with steering on.

@DavidP I know that you guys are working on it, so this was written to try and help you troubleshoot.



Same issue today
Can’t use PU
Can’t U turn
Steering locked enable, so can’t turn and keeped right side in Stage 3 crit club.
Gradient simulation worked
Using KickrBike V2 WiFi connect, last firmware update
Zwift on AppleTV, last update

Had this issue back when i had kickr18 and one time with my kickrbike
Just unplug and replug kickr when you are in the pen

A post was merged into an existing topic: No steering After Coffee Break (Kickr Bike)

Kickr bike v1/Apple TV

TTT this morning - steering showed ON but buttons inactive and I could NOT steer.
Avatar was often pushed to the right out of the draft with “close the gap” message (I DID steer in TTT last week with a different set of challenges)

Hood buttons for PU and Uturns now inactive
Steering buttons inactive even in free ride despite display bar showing steering ON

Dear all,

Bringing my inputs as well on this topic with the following buttons not working:

  • Right up: it pops up the control bar in Zwift (should action the PU)
  • Right down: nothing actioned
  • Centered button (steering) doesn’t action anything, so I have to disable steering (otherwise my avatar is not centered and lose the draft)

The left up and right buttons do action correctly the gradient %

I thought my new Kickr Bike Wifi was at fault, but seems not when looking at the previous messages (Zwift & Bike firmwares up to date). Tried several times with Robot pacers and free rides.

Hopefully this gets resolved soon as very annoying.

Hi all here same issue , had a new V1 kickr bike delivered yesterday (it was a replacement of my former one who has a noice issue ) nothing is working in a group ride. I tried to connect the bike in the ride with steering function, but it dropped me strongly (avatar was not moving anymore and steering was not activated :frowning: . The right upper button is not active to start the powerups. If i understood , the groupride can disactivate steering but with my other bike powerups was still ok. I want to know if this is a zwift bug or is my new bike impacted and has a technical problem?

Have you paired the new Kickr Bike as a “steering device” on the device screen? It’s required since it’s a new one.

And have you tried using the PU/Uturn buttons on a free ride; with the steering icon displayed at the top center of your screen?

I can only approve of you being careful enough to wonder if it’s a Zwift issue or an issue with the new KB!

Have you updated the firmware on the bike ?
And when you have the Wahoo open, you can check that the power reported from the bike is similar to what you normally see.

If this doesn’t help, I suggest you open a new thread since your issues are beyond a steering issue.
Remember to post what platform you’re on too.


Quick follow-up with today’s Zwift update:

Buttons are still not actioning anything, with a small change to my previous feedback: the right up one popped up the control bar in Zwift and now doesn’t do anything like the down one.

@shooj Is there a developer on that one?

1 Like

Zwift v 1.44 addresses this issue. We’ve started a phased rollout over the next few days starting with PC / macOS / Android devices. Please update the game app when it’s available to you.

My Kickr Bike buttons for PU and U Turn have randomly stopped working. checked all connections. seems to be since last update.