Power up, U-turn and steering buttons on Kickr bike stop working mid ride

Over the last few weeks, I been experiencing regular loss of function of the right hand hood buttons (power-up/ U-turn) and left/ right steering on my Kickr bike (v1) while using Zwift. Gear shifters and elevation buttons (on LH hood) are not affected.

It only (so far) appears to happen on Apple TV 4K. I have tried the following scenarios:
Evening with 2 rides, one after the other:

  • The lack of steering and RHS hood buttons happened during the first ride. There were working at the start of the ride.
    After the first ride ended:
  • I power cycled the Kickr bike, reconnected all devices (via Apple TV, not the Zwift app) and tried starting a new ride, the controls were still not working.
  • I tried power cycling the Kickr bike, swapping the cables while powered off, tried launching a new ride in Zwift - no change.
  • Lastly, I quit Zwift on Apple TV then re-launched, connected etc and started another ride - now the controls were working again.

Then two days later, 2 more back to back rides:

  • During the first ride the issue materialised again, so at the end of the ride I swapped to a second Apple TV, running a freshly loaded Zwift instance. The lack of controls remained.
  • Only after the second ride finished, I power cycled the Kickr bike and re-established sensor communications in Zwift. There was no change - controls still did not work.
  • Then I quit Zwift and re-loaded and re-established sensors again, this time all buttons/ steering was good again.

I have since re-installed Zwift on both Apple TV’s, but this has made no difference; I still get lack of function of those buttons/ steering mid way through a ride.

I have also been testing using Zwift on my laptop, connecting all sensors via Bluetooth. I have not experienced any issues using my laptop (except that it gets extremely hot!).

I have a ticket open with Wahoo already, they have suggested reaching out here too. It is not clear if this is a Wahoo, Zwift or Apple TV issue.

Any thoughts here? Anyone else having this issue? What can I check to narrow down the source of the problem?

Many thanks,


Seems a bit different but since you mentioned you are doing back to back rides in each case, are you a leader or sweeper in the first ride (or on a potential list to be either)? There is this current known bug that steering may not work post the first event without quitting.

I’m on KICKR Bike v1 and steering and buttons have been good for me on MacOS and AppleTV (although I predominately use MacOS).

Hi Jeff,

Thanks for the reply. I have recently started leading/ sweeping or being backup, so it could be related.

However, my issue does not only happen after the first ride is complete, it tends to happen during the first ride.

I’ll have to do some more rides when not lead/ sweep or backup and see if there is a correlation.

Many thanks,


I posted another thread but my kickr bike all steering and other buttons that don’t control the bike (i.e. not tilt or gear buttons) have stopped working on the Windows version of the app. Pairing my bike to an ipad with the latest zwift they work fine, going then back to windows and they fail.

When you pair to the PC is it through BLE or Ant+? Just curious because if IIRC steering, power up, and u-turn buttons only work over BLE

Hi D,

BLE is what I typically use, on Apple TV.

With PC I did faff with trying out ANT+ via a dongle, but then realised that steering was BLE only, so gave up on that experiment!

I definitely think that this is related to being on the list of leads or sweeps, as on my two back to back rides last night, I was backup lead on both. Steering and buttons were non-functional from the start of the first ride.

This evening, I have no lead or sweep responsibilities, so will see what happens :slight_smile:

The steering controls in the pairing screen “Controls” are paired BTLE, however the resistance unit at the time was paired ANT+ (Cadence and Power were also BTLE, only Heart Rate and Resistance were ANT) swapping the resistance unit to BTLE fixed my issue. A little hard to comprehend since the controls are paired separately but now that I know: I know.