KICKR Bike Powerup and U turn buttons don't work [1.34] [April 2023]

Received my upgrade today. My xp’s returned. Yay!
However, the handlebar buttons on my KICKR Bike stopped working. Not so Yay.

Hi @Jerry_King welcome to Zwift forums.

Can you give more context about the handlebar buttons? Do you mean the shifting doesn’t work / resistance doesn’t change, or the steering doesn’t work, or something else?

The shifting works fine. It’s the buttons that can release power ups or u-turns. I always turn the steering buttons off at startup so I don’t know if they work or not.
All I know is that they have been working fine then I get the upgrade and now they don’t work.

Thanks for getting back to us promptly with that detail. We’re investigating.

I split off your report from its original location to start this dedicated thread.

Can you give us a little more information about your bike:

  1. Do you have the KICKR Bike version 1 or 2? This is the firmware release note info.

  2. Which version of the firmware is it using? Here are Wahoo’s instructions for their apps on iOS and Android.

We have had several testers try to reproduce this on different KICKR Bikes we have at Zwift HQ and have not been able to. A bit more detail about the bike you have will help us to validate that our bikes match yours.

  1. I have KICKR Bike version 1

  2. I checked and have the latest firmware.

Just got back from a outdoor ride a little while ago but hooked things up to give it a check. Left the power on to the turning buttons as well.

It appears for now that it was much ado about nothing. After a fresh restart of the PC and of Zwift all the buttons work as they should. I did three rides yesterday, without restarting Zwift, and the problem persisted the entire time. Let’s hope it was a fluke.

Thank you for your prompt attention. I am sorry to have caused an uproar for nothing.


Phew, glad that’s working again for you!

And we do appreciate you looping back. We can settle back to DEFCON 5.

@shooj I just got the 1.34 update and on my group ride tonight my Kickr Bike buttons weren’t working to active a power up. After the group ride was completed and steering was enabled again the steering buttons wouldn’t do anything even though the steering icon was showing as activated.

Another buddy who I ride with also has a Kickr Bike and he advised his weren’t working either.

1 Like

Please put it back to DEFCON 1.5 :smiling_face:

I’m having the same issue :cry:

Here are my observations so far :

  • after updating Zwift to 1.34 I did only free rides for a few days without issue, the handlebar buttons on my up to date Kickr Bike v1 were doing great as always (power-up, u-turn and left/right lane)
  • then on Tuesday 18th I join a Cobble Crusher race in which steering was disabled, but when I tried to activate my PUs with the handlebar button, no effect; I had to use Companion
  • once the race had ended, I stayed on the course and the steering icon appeared again on the screen but without effect, the buttons were not working (PU, U-turn and steering)
  • I ended the activity and started a new one in free ride without quitting Zwift, same result, the handlebar buttons were not working
  • I also tried disconnecting every device on the pairing screen with no effect, the buttons were not working
  • I stopped Zwift, started it again, launched an activity in free ride and the buttons were working again
  • On the following days I only did free rides and the buttons were working
  • Then today I joined a Cobble Crusher race and same as last Tuesday, impossible to activate a PU with the handlebar button
  • Once the race had ended, the steering icon was back but the buttons were not working

My guess is that, once someone with a Kickr Bike joins an activity where steering is disabled, it basically breaks all the Kickr Bike’s buttons for the current Zwift process (not activity).
The only way to get them back is to quit Zwift completely and start it again.

Hopefully those information will help the devs finding the source of the issue and we’ll have a fix soon. With the Crit series starting next week, the Power-Up button is crucial!


Same issues here also with NO PU and UTURN controls after last update…however does work on free ride and robopacers on fresh ride starts.


Just so you know, the issue is still there. Exact same steps as last week; same result.

The issue will remain here until Zwift releases another game release to fix the bugs. Nothing will change before then.

:+1: and I don’t think there has been any sign that this will be fixed in the upcoming release planned for this week. The last word was that the bug hasn’t been replicated. Hope for the best but don’t expect an immediate fix unless someone from Zwift says it’s in the next update.

Since we haven’t received news from ZHQ, I just want to be sure that this thread doesn’t fall too far below other issues and get no attention from the people who could fix this :slight_smile:

@shooj or @Rowdy is there any update to the issue with Kickr Bike power up and u-turn buttons not working and issues with steering button during free ride after a group ride where steering was disabled?

Hello - i received the update today. Mac OS Kickr Bike V1. Steering and buttons all failed to be recognized.

I check all the latest firmware. MACOS is updated to the latest version. And Kick Bike is also update.
I restarted Bike and Mac multiple times.

I have also connected my bike to Apple TV and this works Great - but it has not received the update.
Anyboyd else using MAc OS or Windows ?

@shooj or @Rowdy
Update on the above - i did some testing and basically there are two issues
#1 there is a GUI interface issue - Ie the Zwift game shows Steering etc. is amber not connected but if you continue through this and start a ride the button start working about 1 min into a ride. IS Gui is still amber saying it’s not connected but it’s working.

#2 Unfortunately this leads to the second issue. You can’t turn off Steering - we all know what happens if you have steering on during an event or a pace ride you end up on the left, then the right then in a wall then in the river - anywhere except in the draft.


See post above.

Yes we are several having the same (new…) issue since the latest update.

See : Game Update 1.39 [May 2023] - #74 by Verde_Espada

Same issue here with 1.39 (MacOS).
Kickr bike v1 latest firmware.