Garmin HRM no signal [SOLVED]

I’ve never had the ‘No signal’ issue with an HRM but I have with the a Speed Sensor 2. I tried with a spare sensor and it worked fine; I’m starting to wonder if my original sensor is borked…

So this is my setup.
Apple TV running Zwift
iPhone 8 running companion
Kickr for power
stage power meter for cadence
Garmin Dual HRM

If I connect my Kickr and Garmin HRM to the Apple TV, no cadence or companion activated.
Everything works fine

As soon as I active the Zwift Companion on my iphone as a bridge so I can ride an event the HRM then shows “No Signal” although it still shows connected to the companion app.

The issue seems to be with the companion app and not the Zwift App.

I finally fixed the problem. Didn’t post on here straight away, just in case it failed again but it’s been good for a few weeks now. Here’s what I did and what did and didn’t work:
I’d tried uninstalling apps, disconnecting Bluetooth, testing everything during nothing worked.
Knowing someone above had reset their iPad to fix the issue, I backed up my iPad and did a factory reset. No one seems to have tested if restore from backup worked so I then reinstalled my iPad from the backup. The problem returned Immediately.
I reset the iPad again but this time didn’t restore from the backup. I downloaded Zwift, Strava and other apps from new again. All has worked fine since. It seems, if you have this issue and are using an iPad then only a full factory rest and download the apps again works.
I’ve taken the extra precaution of not adding the garmin app to my iPad or the Zwift companion app - leaving them just on my phone.
It was a bit of a pain to do but not as bad as I expected and so far, so good.

4 Likes

I have the same issue with an iphone 11, but I refuse to factory reset it as it will cause me more hassle. No problem at all with iphone 7.
Zwift has to fix this bug. It is not acceptable that a big platform like zwift does not do anything about this.

Can someone from zwift help me here?

Hello all! I have been dealing with the same issue HRM Garmin Bluetooth no signal or 0 heart rate on PC with Zwift. The device worked fine with my Garmin Watch and the PC Roveey app. Zwift recommended a lot of the solutions above and nothing worked for me. Today after fighting with it again I decided to place the chest strap in the sink and soak it with water. What do you know it is working now in Zwift PC. I am not sure if this will help you but it might be worth a try I have had this problem for over a month and the device had been fine before that. Good luck.

Hi @Luke_H

Welcome to the forum.

Yes it is good practice to always wet the strap before putting it on. I pour some of my water from my bottle on the pads before putting it on.

I do that after every ride. Works perfectly when connected to the Apple TV as soon as I switch on the companion app to bridge the “NO Signal” returns :face_with_symbols_over_mouth:

If this post ist about making the chest strap wet - it is better to do it BEFORE, not after the ride :grinning:

1 Like

Honestly, is this really working? My chest wrap gets soaked after 20mn riding and still… no signal. Also, why did it work perfectly fine for the first 4 or 5 rides and then nothing?
Guys from Zwift, are you on it or…?

only one person who has commented is actually from zwift. Have you tried all the things suggested throughout the entire thread and the other threads on the same topic?

Someone has said what works for their iPad (full factory reset without using a back up to restore) and someone else has mentioned getting a solution with windows (installing some missing file/exe). Not sure if there have been people claiming a solution for other operating systems (other than the standard/obvious Bluetooth or HRM issues)

Have an office in LB and Torrance. Happy to stop by and show you the problem. From safe distance.
You have a super product and it’s a lot of fun but the interface is not working well
I have an I pad that I watch a movie on…not linked to the phones
I have an iPhone 11pro
A Garmin HRM duel
A Garmin fenix 5+
It sees the device but gets no signal

I have a similar issue. Garmin HRM Dual will connect instantly to iPad and my wife’s iPhone 8 and show a perfect reading but not my iPhone 11. Worked fine for the first few days of getting the HRM pod. I do not think it is a Zwift specific problem as other apps on the iPhone 11 also have the same problem (eg Elite HRV)

The apps are able to discover and connect to the HRM but will not display a reading so the HRM is transmitting and the phone and apps can see and talk to it but cannot get a reading. The issue is with this specific phone. Like others I’ve tried all sorts of uninstall/reinstall turn off/on.

Other Bluetooth devices and HRM pods connect without a problem to the phone so whatever the problem it is specific to this pod and iPhone only.

Pulling my hair out with this.

1 Like

It’s exactly the same for me.

Maybe could be related to the IOS software on iPhone, I’ve read that the last update, 13.5.1, has some Bluetooth issues, even if I’ve the same in IPad and it works perfectly.

What’s your IOS on iPhone?

Could be IOS also running 13.5.1

Fabrizio yes my phone is 13.5.1. Same version for the iPad but that works fine.

I’m tempted to to wipe out the phone and start from scratch.

I’ve emailed Garmin but not holding my breath.

I think it’s not worth it; I hope in 13.5.2

Same problem here. Garmin Dual HRM worked fine for several months, first paired via Zwift Companion App to Zwift running on a very old Macbook Pro, then via ZCA to Zwift running on a brand new Lenovo running Windows 10. ZCA running on an iPhone 6s. The problem might have started with updating to iOS 13.5.1, but I’m not certain on the timing. Regardless, it’s not a matter of too many bluetooth pairings, new BT pairings, interference, dirty straps, dry straps, dead batteries, or anything else mentioned here. Simply, the system worked, then it stopped working, possibly coinciding with iOS update. I get that software updates can break things. Then it’s up to Zwift to fix their bug for their next update. It’s not up to me or anyone else in this thread to try crazy solutions. I hope they manage to do it soon. Wipe my phone? Not gonna happen.

1 Like

I can confirm the solution of using a full factory reset to get a Garmin Dual HRM to connect properly. In my case I’m using an iPad pro 10.5 inch from 2017, running 13.5.1 before and after the reset. At the moment I’ve installed Zwift as the only additional app apart from the general Apple pre-loads and the Garmin dual HRM is now happily showing heart rate again.

I’ll start adding apps back on the iPad and give an update if I find one that kills the connection.

1 Like

I connect with my Apple Tv and I have never been able to connect the HR and I only have it connected to the Garmin 1030

1 Like

3 or 4 zwift session later and the ipad is still keeping the connection to the Garmin dual HRM. Factory resetting the ipad wasn’t that painful with only a couple of apps needing data to be saved via itunes and then copied back. The alternative was buying a new HRM from another brand and hoping that would connect - glad to have chosen the reset ipad option.