Garmin HRM no signal [SOLVED]

Hi there. I have recently had exactly the same screen as above. My (brand new) Garmin Dual HRM worked perfectly before, but suddenly it says ‘no signal’ - it knows its there, but no signal. I run Zwift off my Iphone 11 and mirror onto TV through Apple TV. Is there a way I can fix this without doing a factory reset of my phone?
Thanks,
Emlyn

1 Like

Hi! As noticed that not only Zwift, but all my app that use HRM stoped receiving data from my HRM Dual in my iPhone X, I concluded that the problem wasn’t no zwift e sim de alguma autorização de acesso revogada após uma atualização do iOS. What I did for solving the problem was going into the configurations and disallow an after that autorizate all my apps to access health data.
Zwift is working fine now!

I agree 100%. For 2 months I had no issues and now NO Signal. I do not need to reset any device back to factory settings to fix a problem that Zwift QA should fix quick. This problem exists with my AppleTV. My HR Bluetooth Garmin worked before fine and works with my iMac and my iPhone. I have BLE and Ant and both working. Just not with the Apple TV. I enjoy Zwift more having a 55" screen in front of my face and not a phone or iMac that I would have to move near my bike and trainer. This is taking too long and 100s of posts all having different issues.

1 Like

My Garmin Dual also appears to have suddenly stopped working with my Apple TV, also. It isn’t even recognized in the pairing screen. I checked the battery and it is good. I am doing a deep-clean on the strap today, just in case, but if anyone has any insight as to why the ATV isn’t seeing my HRM I would appreciate it.

On a side note: for a couple of days prior to today, Zwift has picked up the Dual HRM and showed a heart rate even when I am not wearing it. Very odd, indeed.

1 Like

Zwift ghost bots at work afterall. Spooky :grimacing:

I have exactly the same issue. Brand new Garmin HRM, and it displays the ‘no signal’ message on the screen. Tried everything. I am using Zwift on an Apple TV. Any advice? The HRM works fine- so that is not the issue.

When this happens to me on ATV I generally exit Zwift, force quit the app (which you should really do after every ride, anyway), turn off the ATV (not unplug, just shut down), and then start over again. It has always found the HRM after this process.

1 Like

Update to my earlier comment about my HRM Dual not working: It turns out my battery needed replacing. When I removed it to check I didn’t note that the tester was on the 1.5V setting, instead of 3V, so it looked like it had plenty of life left. :flushed: When I checked it again using the correct setting, though, not so much. New battery installed and everything looks good now. (I sure wish I had figured this out before this morning’s Specialized ride, though, as it would have been ‘great’ to see my HR going through the roof on the Ventoux climb! :rofl:

Thanks- I will try it.

Hi, I just bought the band, but I have the same problem as all, and no solution. Works fine in Garmin edge 830, but in Iphone XS Max, connects but not signal. I tried with another Iphone, I tried with a I5S, and works fine. Apparently the problem is in the last IOS devices. Also I can confirm the signal is not working in other APP, as an example Wahoo. Let’s see how to solve it because is very annoying.
Regards,
JA

Did anything work for you? I’ve been off Zwift for a few weeks. Just did a session and HRM still displaying no signal. Tried shutting everything down etc. Nothing. Battery fine as works with my Garmin. Really annoying!!

1 Like

To be honest I got pretty fed up so decided to pause my Zwift membership and just use my Garmin 530 for indoor workouts on my tacx. It’s worked really nicely actually as I can catch up on Netflix series as I train!! I might go back to zwift in winter and then use my Apple Watch for pulse ‘cos that does connect. Good luck!

1 Like

Did anyone find a solution to this problem?
As many of you I also have the same problem. Everything was working fine untill a few weeks ago when my iPhone XS all of a sudden would not show any value when connected to the trainer app (it says it is connected but even if I climb 10000 feet my HRM is still 0…). Same thing with other training apps (Rouvy, Fulgaz, Kinomap…).
The HRM works fine because it connects immediately to my Garmin S60 watch and displays the right data. I also have two older iPhones which have older iOS software and it also work fine with them and with all the training apps.
I dont know what caused the iPhone XS to stop displaying the HRM value, maybe it was the last software update which I did around the time it stopped working…I am not just sure about it…it’s just that it is annoying and thankfully I have another iPhone till next software update

Sorry i didn’t get a notification on this thread. Yes I have used the Scoshe Rythym but only after not being able to get a signal from my Garmin HR2. The Garmin HRM 2 will connect over Bluetooth and transmit HR over Apple TV. However if I want more than 2 sensors I have to use the Companion App on my phone and that’s when it will show connected in the pairing screen but “No Signal”. I can’t remove the battery in the Rythym. I can turn them off and I have removed them from the garage where I Zwift but it makes no difference. Apple TV = connection and signal; Companion App on IPhone = connection but no signal. All my other Apps/Bike computers can connect and receive heart rate data and show it without a problem. Heart Rate on Companion App on IOS doesn’t work on Zwift.

Same here.
Although I could do a factory reset this is a software glitch. The HRM Dual connects to the ipad but as you all have said it shows ‘no signal’ within the app. I have changed a lot of settings but not working. Connects to other devices fine. Frustrating as the hassle of sending back a perfectly functioning HRM to change to another brand when it is a simple software glitch is frustrating. My wife has been trying all day to connect - please help as I am taking one for the team here but otherwise will have to let her loose on the zwift coders and that will not end well! Please try and sort this glitch out. Thanks

I hoped that with the new ios version it would start working but nothing. Very annoyed about this because it stopped to work all of a sudden. I am quite sure it must be something with the BT settings so a reset of the phone would probably make it work again but fortunately I have an older iphone which works fine.