"Free ride" sections of workouts don't disengage ERG mode on Wattbike Atom

Strangely, I think they have partly fixed this.

During the Road baseline ride, It did disengage for me on my Atom & worked great - I use ATV & Bluetooth. But in a erg based workout, it wont disengage.

The other really annoying one is if you do a workout with ERG on, when the ride finishes & you return to gear mode, you are stuck in gear 6 until you power cycle the Atom & re-pair the device. That one is really annoying.

I think this one is on TrainerRoad - I have spoken with their support a few times and they simply couldnt grasp you might want to switch between resistance\gear\erg mode in the same ride.

Last I heard, they were trying to get Wattbike to give them an Atom (they wont buy one) to then test & potentially support some changes - Issue being, as Wattbike & the Atom specifically is fairly small fry in America I dont think they see a huge benefit to making the change without some customer pressure.

I have had this issue FOREVER since i started on Zwift many years ago… Raised the issue and still no resolution… I had heard all the excuse… So Zz, why not simply admit that its either beyond your skill set or you have no interest in resolving :thinking:

Hi @Ray_Brown_Pack

Welcome to the forum.

What trainer are you using. Did you increase the resistance using the onscreen menu bar or the companion app incline button?

Ok experienced the identical issue today on Atom, iPad 5/6 (not sure) and first run through erg normal on relevant segments, then freeride no resistance spin out, no response from gears whether companion set to erg or ramp. End of workout erg off gear no appears but unresponsive to buttons. Tried to re-pair sensors no change.
Powered Wattbike down then on and pair again, restart same workout and all ok, freeride now responding to gears no intervention required to switch from erg segment to freeride or back through 2 cycles. Hope this helps others…

1 Like

Hi. Still having this problem with ATV & Wattbike - the Zwift app on ATV doesn’t let go of ERG mode, either when you get to a free ride section of an ERG workout, or when you finish the workout & want to ride on for a bit.

I tried the Atom with Zwift on my iPad, and it worked fine - so there’s definitely something in the ATV implementation.

It’s a pain. Is there any timeline on a fix, or anything I can do to help figure it out?

Many thanks

1 Like

Have zwift sorted this I’m using ATV and can’t do the zwift academy workouts due to the free ride sections on my Wattbike atom no matter what I do it stays in ERG mode and won’t let me use the gears unless I disconnect the pairing and reconnect which is daft.

1 Like

I’ve just experienced the same issue on Zwift Academy Workout 1 using ATV and Wattbike Atom (with and without beta firmware enabled). ERG mode is fine and then free ride segments switch to Gear 6 but no response from the gear changers.
I was spinning away like a mad hamster at 1.5W/kg and 120+rpm, so I did get a workout at least (even if everyone else was flying past me!).
Please can we have an update on whether this is still being looked at as a known issue?

2 Likes

16/11/2023 Exact same issue Paul. Gear 6 in Free Ride sections that wouldn’t change. Explosive hamster power! Clearly, Zwift are unable to fix the issue or they would have done it long ago. I’ll try using an iPad next time there’s Free Ride sections instead of the Apple TV.

2 Likes

Or you could try turning manually knocking ERG off a minute or so before the free ride interval.

If that doesn’t work, you could always do the whole workout non-ERG. It’s good.for you as well. :wink:

1 Like

That doesnt work on the Atom presently - That is the problem. you cant disengage ERG mode.

This was meant to be fixed and it was at some point as I tested it and worked great - But come the ZA academy it has been broken at some point in the middle.

I raised it with support post the first academy being released & as advised it is a known issue - No fix date etc

2 Likes

Oh great. Just tried the FTP test on my new Atom. Stuck spinning in gear 6 when ERG is meant to be disengaged. I can see there isn’t much prospect of this being fixed. Atom next gen and ATV 4th HD. Should be the perfect combination right? My old Kickr Snap handled it ok but I thought this Wattbike would be a massive upgrade. It’s been poor for workouts generally. So I need to revert to using an old iPad for workouts I guess?

1 Like

Some progress with a work round, sharing in case it helps. I’m running Zwift on ATV, Wattbike generation 1, ZC on iPhone. All current OS / versions / firmware.

Symptoms: ERG mode doesn’t auto disengage at the end of a workout, or for the free ride sections of workouts. And the ERG button in ZC does nothing.

I’ve dealt with this to date by stopping, going to the pairing screen, and unpairing / repairing the Wattbike as a resistance source. That’s viable but annoying after a workout. No good during.

Revelation this week was that if I do that unpair / repair trick after selecting the workout but before I start pedalling, the ERG release button in ZC then works. Better still, it released ERG automatically at the end of the workout.

Haven’t yet tried a workout with a free ride section. Will do that tomorrow and update.

Free ride section worked properly.