Erg mode not working in workout mode

Hi All,

I just tried to do a workout and the wattage on the screen and through the pedals is way off. I was warming up and the wattage didn’t seem to change with what was recommended. It was a ramp up from 80-180 over 10 mins and it didn’t give that feedback through the pedals. I then waited for the first leg prep and it asked for 280 and still just stayed at 220 but jumping erratically within 20 watts either side. This is assumed meant the erg mode, although on in the menu, was not working.

Please can someone help?

Best,

H

Hi @Harry_Waterton
How familiar are you with Workouts generally and riding in ERG mode specifically? If you’re new to ERG mode, it can feel odd compared to free-ride or SIM mode, which simulates hills and changes your resistance accordingly.

In ERG mode, the workout gives you a target wattage number to hit, and your one job is to increase / decrease your pedaling RPM’s to hit that number. You don’t change gears on the bike, you just pedal faster if you need to hit a higher number, and the trainer will lower your pedaling resistance as you increase cadence. Is this what you were feeling?

More information on how ERG mode works here.

I have the same experience. During a workout ERG mode doesn’t work. Before I have never problems with ERG mode and worked very well. Not today.

Device: Appletv 4K
Trainer: Wahoo Kickr Core

Hi Shuji,

I have done a number of workouts already on ERG mode, into week 5 of build me up plan, so not my first.

I though it would be that, as previously I would increase my cadence and it would read that and reduce the resistance accordingly, but as i pedaled more the same resistance would be applied and when the workout says, 280 watts at 85rpm i would increase my rpm to hit that 85 number but the watts would then go up to say 400 and then my legs…well fall apart

1 Like

Hi @Harry_Waterton

What device do you use for Zwift? Have you noticed if the resistance during free ride when you go up?

I assume you use Bluetooth?

Hi Gerrie,

I use the Tacx Flux 2, and linked directly to my phone. I haven’t had many issue with that but as of late it has been a nightmare. The real issue is when i bridge using the companion app.

In free ride the wattage/resistance is jumpy…like in a single pedal stroke go from 230-280 then back to 250 then up to 300, all in a matter of 2 or 3 seconds. The steeper the incline the great the deviation in resistance/wattage

There is a Bluetooth bug for some trainers on Android.

I have only apple products…that’s what i am frustrated with.

My housemate has an Elite trainer and connects his older macbook to his no issue

I have a tacx flux s and sometimes it gets stuck.

For example today I was doing the requested 190 watts for my workout and when it changed to 355 watts the trainer did not adjust.

Taking it out of erg mode and reconnecting didn’t help.

I’m using FCE or whatever it’s called to connect and windows. I have both Bluetooth and ant+ available to use. Same thing happens with them.

Fortunately for this specific workout I was able to finish it while doing 190 watts without any issues but that very rarely the case.

I am having a similar problem with my trainer. I have a Tacx Flux 2, and recently (the last two weeks ish) ERG mode hasn’t worked. It doesn’t adjust the Watts at all. I am pairing it to my Macbook air via bluetooth. So far I’ve updated the firmware for my trainer, turned Ant+ off, deleted and reinstalled the Zwift app from my computer. And no luck yet. I’ve also tried connecting to the Zwift app on my phone, same problem persists.

Does anyone have ideas what is going on?

Similar problem for both me and my wife yesterday around 17:00 GMT. We use a Tacx neo 2 and Taxc Neo 2 T. We were both in workout mode riding New York park. I could tell right from the off something was up as the Neo felt like like the back wheel was buckled and not symmetrical. As you pedaled the resistance would vary with each RPM. Then after a few mins is was ok, then it would start playing up again. I saw someone else posting comments saying they were having problems with cad and the brake unit, so realizing it was not just me so just pushed on. Towards the end of a 75min session I had to reduce the power to drop out of erg mode as it was so bad I could not pedal properly and cooled down at a much lower wattage than I would av preferred. So approx 20min of the 70min session was problematic and about 10mins for my wife.

Got a race later today though and am anxious this problem could happen again. Very experienced in using erg mode have been training and used it for about 8 years now and have never experienced these problems before, but relativity new to Zwift.

all firmware is up to date

Hi,
I’m having a similar problem with my Wattbike Atom, tried all the advice about fixing Ant+ and BT disconnecting on both Windows and Mac - still not resolved. Have you heard anything from Zwift support? It seems like a lot of people are having ERG issues but Zwift support seems quiet on the subject.

I phoned Tacx/Garmin today to troubleshoot the problem. We were able to pinpoint the problem to the trainer rather than Zwift, they’re sending me a replacement part under warranty.

I switched to a MacBook Pro and Bluetooth and it worked fine, sticking with the old Mac for now.

Hi Ed,

You wouldn’t happen to have the Tacx number by chance?? I have tried a one but to no avail.

Many thanks,

H

Hi Martin

Any reply from Zwift for you yet on this issue? I am having similar problems with a wattbike and ERG in Zwift (only when on bluetooth). I too have gone back to my laptop/desktop with ANT+. The Zwift support is next to zero at the moment. They seem to take around 6 weeks to respond to an email! Joe

Hi Joe,

Nothing since the last email I had a couple of weeks ago which suggested changing the battery in my Ant+ HR strap, I did that but it made no difference at all. I replied to let support know but I haven’t heard anything. The Mac Book is working fine with Bluetooth but Windows is a complete non starter for Bluetooth and Ant+ I’m lucky I have an old Mac Book but it’s annoying that I can’t use my Windows laptop.

Martin

Are you sure the HR strap is not still paired to the Mac when you try to use the windows PC. Bluetooth can only be paired to one thing at a time.

Yes for sure, the Mac Book was switched off and this started before the Mac went anywhere near the Atom.

Martin