Erg mode not working in workout mode

I have similar issue. Using MacBook Pro and original kicker. ERG works with iPad, iPhone 10, but not with MacBook Pro, It initially did work with MacBook Pro. stopped about one month ago. deleted Zwift and reinstalled. no Luck any suggestions?

I have had the same a couple of times this week with a Kickr 2018 and Apple Tv / bluetooth. I have had to restart the workout after realising it was not adjusting (bit pointless doing strength training with no strength required). Any solutions as to why it is doing it please?

1 Like

I experienced problems for the first time last week too. I’m using Tacx Neo2 and iMac/Bluetooth. ERG seemed to have it’s own mind and wasn’t getting anywhere near the Watts I should have been putting out in the Build me up Workout (wk5), yet I was still receiving a full star for completing the segment. Beginning to wonder if there is a fault with the actual workout programming as opposed to equipment issues?

Hi @Amanda_Williams

Welcome to the forum.

Was it this workout?

That workout has a 10min free ride block where ERG is off, so you need to control it with the companion app (incline) or keyboard ± or just your gears.

I’m having the same issue with Apple TV app and Kickr 16 - its been happening during structured workouts during the 1st couple of wattage changes - example today was 10 min at 100 watts, then 3 min @ 120, then 3 min at 140, then 3 min at 160 - I never made it tho because once I completed the 3 min @ 140 - It would not increase resistance to 160 - I kept seeing “increase power”- so I would spin faster to no avail - I shut it down & Restarted using iPhone app which did work - this has been going on for 2 weeks now - along with structured TrainingPeaks workouts not syncing thru reliably. Please help

3 Likes

I’m getting the same drama.
Did you find a fix for this?

There’s no way my wattage is as low as it’s telling me🧐

Same problem for me with a flux s.

It has the latest firmware and I did a calibration run.

When using a macbook pro, erg doesnt get close to the wattage needed.

1 Like

Hi Annette, i have the same issue. ERG mode don’t increase résistance and i spin faster and faster with no effect on the Power. Have you got a solution ?

1 Like

Since the most recent update, ERG mode has not been automatically adjusting the tension to the prescribed wattage. It treats ERG workouts as ‘free ride’ and keeps the watts steady regardless of road gradients or interval power targets and I have to manually adjust the tension via the up/down arrows in the companion app.

Riding an Elite Direto to a Macbook Air via BLE connection.

1 Like

…regardless of road gradients

Workouts (ERG or not) always treat routes as though there is no slope (i.e. do not adjust tension for slopes).

Anyway, we (in our house) have done numerous workouts with ERG mode since the update, and everything has worked perfectly. Neo2T + ATV4k.

I fully understand how ERG mode works…

But when the workout goes from, say, Z1 to Z3, the trainer is supposed to automatically adjust tension until you’re within the wattage range. Since the update, this is not happening. The tension is staying flat, regardless of interval zone, which is similar to how ‘free ride’ mode works.

In speaking with other riders, I am not the only one.

3 Likes

Hi All – same exact issue. Brand new Elite Suito in workout mode. tried ios on BLE, and macbook with ANT+. Basically workout mode is like freeride (the resistance gets harder, but it’s not holding the resistance steady). Had an Elite WheelOn (Qubo Digital B+) trainer for years and never had an issue.

Any ideas would be great. Cannot imagine i got a lemon from Elite if there are this many complaints across multiple trainers.

I rode my brand new TACX 2T yesterday. I updated the software before I rode. First thing I did was the FTP test on Zwift that required ERG. Zwift said ERG was activated, but it wasn’t. First wattage goal on test is 100 watts. I could ride at 50 watts or 300 watts. Not activated. I spent hours on the phone with Garmin. First guy said no one else had this problem and it must be Zwift. Second guy said they had seen this problem many times. He offered to send me a new 2T. In December. I still can’t figure out if the problem is the 2T or the ant+ connection between trainer and Zwift or something else. :cry:

In the workout menu page in Zwift is the circle beside ERG mode clicked? Should have a dot in the middle.

It is clicked and it’s marked as “on” during the workout. I heard back from Elite and they claim it’s their highly precise sensor that is accurate. I tried pushing back that one can feel the resistance is not steady but they weren’t having it. While I appreciated their follow ups and responses not having someone in the US that you can talk to live is a bit frustrating. Considering returning it at this point which Is unfortunate given the value.

Is it a Tacx product or Elite one? Sometimes with Zwift the signal can be affected by errant noise coming from other electronic devices and I read someone on here saying their microwave disrupted their ERG workout. Also, try using your smart trainer software to confirm that ERG mode works at all. Then we can look at other problems.

This is the elite suito. Tried on both BLE and ANT connections.

I totally got you mixed up with the other guy posting about his Neo. Have you tried Elite’s software to see if ERG mode is totally broken or just on Zwift? Perhaps there is a Bluetooth problem in Zwift that I am not aware of but others in a different thread may be?

So I’ve tried both ble and ant. Haven’t tried elites sw since I runny have paid account but I can trial it and potentially also TR.

You shouldn’t have to pay for the software. With the Neo there is the Tacx app that allows you to update the firmware and test whether the device works. I am assuming that Elite has something similar.