ERG Mode - not working?! Some advice needed

Hi fellas,

i would need some help with Zwift, my Tacx Flux (belt driven) and ERG Mode. Over the past weeks i started to doubt whether my trainer is working as intended.
(Both my trainers firmware and Zwift are up to date!)

ERG mode: i understand that ERG mode is only activated during workouts and aims for a target wattage (personal FTP score) regardless of my cadence, am i right? So when my cadence is higher the resistance should drop and when my cadence is lower the trainer puts up the resistance to meet the target wattage.

I chose a random workout with ERG mode ON and tried to keep my cadence at ~70 rpm. As you can see on the screenshot the wattage always stays the same:

Then, in the same session, i disabled ERG, restarted the workout and again hit ~70 rpm. Still no change:

Even as i fiddled around with “Incline” on the companion app, i could not feel any change in resistance.

So what am i missing here? Could it be that my trainer is defective and simply not working with ERG mode?

Hi @Claudio_Costantino, how are you pairing the trainer to your device? Bluetooth or ANT+? If using ant+ make sure it is the FE-C option, as that is the protocol that controls the resistance on the trainer.


Well, on the pairing screen it looks like i’m using FE-C, i have an “Onlyesh Zwift ANT+” USB Transmitter:

Look like you did the paring correct.

check if your trainer is on the latest firmware version.

Yes it is, Zwift + Firmware on the latest Version.
I’m wondering if the Tacx Flux T2900 is simply not capable of doing ERG mode? Looking for detailed tech info about this trainer to confirm this…

Does your trainer simulate the hills in free ride mode?

it is possible some older trainers did not support ERG like my Elite Realaxiom usb.

That’s the issue, i don’t feel any change in resistance whatever mode i choose.

Looking up this directory “Brand: Tacx”, i don’t see the Tacx Flux, only the S Smart + 2 Smart version.

Installed Tacx Training Software today, configured everything and successfully connected via BT.
There are 2 standard workouts: Power + Slope.
Cranked up the wattage to 500. Nothing.
Set slope to max 20%. Nothing.

No change in resistance at any time. So yeah, i guess the trainer’s ERG mode is broken :roll_eyes:.

Hey Claudio,

just wondering did you find a fix to this? I am experiencing the same issues.

Thanks for asking! Well, unfortunately there is no fix. :unamused:
Tried a few more things just to confirm that my T2900 is definitely broken regarding ERG Mode. The warranty has expired and i do not see why I should spend more money on it sending in the device and probably waiting for several weeks.

On the other hand, do i really need it? Since performance / wattage indication still works i have no need to replace it anytime soon. When riding on the street i also have to shift to different gears, so yeah, i accepted it (for now).

I’m eyeing the Tacx Neo 2T though, but i’ll postpone this investment into the future.

Thanks for letting me know.

Hang in there for the Neo 2, there will be plenty going on sale 2nd hand after the global lockdown!!

Neo are’s great. Apparently they measure wattage a little low as compared to outdoors but they are consistent and have the added benefit of no calibration.My original Neo will be 4 years old this October and I see no need to ever replace it unless is simply breaks. If I can get 10 years out of it (it works out to about $215 Canadian per year + electricity and Zwift) I will be extremely happy. Taking into account the overall value which includes entertainment, fitness, etc., I think I would break even after 5 years for the amount of use everything gets.

I’m curious, do you also experience an unusual higher base resistance with the T2900 compared to a road bike?
For a normal road feeling i have to be on the small chainring with the middle sprocket.

Mine feels normal Claudio. Big ring, middle cog for flat sections.