Tacx Flux S ERG mode


Sorry if it’s not directly Zwift-related but has anyone had problems with the ERG mode of the Tacx Flux S? I tried the ramp-up-test with ERG mode on but I noticed no attempt of the trainer to regulate the power, it appeared to be all manual. Is there any trick to setting it up, I thought it was OOTB.

I used my Stages for power source but the ERG is just used in the FE-C direction, right?

Thanks in advance,

Just to check, you say your are using your stages for power but have you still paired your trainer in the controllable selection?

make sure you have erg mode switched on.

maybe try connecting the trainer as the power source as well to see if it changes then.

I have the original flux and have done workouts using a different power meter and it all works fine (windows and android) so it is likely something slightly off in your set up.

Yes, the trainer is the “controllable”. I have ticked the ERG mode in the test or did you mean I have to use some Tacx utility to enable ERG on some lower level?

I’ll try taking the power from the trainer also but one would think that ERG mode wouldn’t care where the power readings are coming from, it would just control the trainer based on what it gets.

gear selection is also quite important, it is best to keep it in the little ring up front and somewhere in the middle at the back as there is a minimum power the trainer can produce for given cadences


For example in this gear selection (39 - 19) if you are spinning at about 90 rpm then the power output will be around 150 watts even with the trainer at it’s lowest resistance. this will be higher for bigger gearing selections.

Yes, but in this case I would claim that there was no ERG whatsoever since I was on the 400W minute and got a warning that power was dropping so I just increased the cadence and suddenly I was at 450W and then I eased off (too much) and it dipped again. I tried to keep cadence around 90 the whole test

For erg mode to work you are meant to keep your cadence steady and let the trainer adjust.

does erg mode work in the tacx app? if it does make sure your trainer isn’t paired to anything else that may be trying to set the wattage or resistance (other apps or garmin devices)

make sure everything is paired to zwift correctly (not showing “no signal” in the pairing screen)

does it change resistance in sim mode when going up or down gradients?

what system are you using to run zwift? windows/adroid/iOS/mac? bluetooth or ant+?

I’m on Win10 with an ANT+ dongle. And the trainer reacts to route gradients so that’s essentially FE-C. I haven’t tried with the Tacx app yet. Perhaps I have just overestimated ERG and need to reevaluate my expectations. I assumed it was “just pedal enough and you’ll never go over”

Hi Nicklas, did you actually solve the Problem. I have the same issue. When I’m searching thru the Forum, i can see that a lot of people have the very similar Problem.
The only similarity is they all using the Tacx Flux S together with Zwift. And the Taxc is alway working fine with other Software.

I’m very interested in your solution i case you have one.

1 Like

I haven’t really used the ERG mode that much since but I do think it is reacting.

I tried the ramp-up test and focused on keeping the cadence constant (I recall picking the smaller cog and middle of the cassette, trying to force the trainer in giving me solid resistance from the start) and it did react. You might want to see if you can replicate the result.