Tacx Flux S ERG is not limiting watts

Hi! I just bought a new Flux S. I had aTacx Vortex and was working fine. Vortex was connected to Zwift in Windows 10 with Giant cadence sensor and Tacx heart rate monitor. All connected via bluetooth. No issue.

The Flux S not so much. In normal ridding mode, it’s fine. But In training mode, ERG doesn’t work at all. It’s like ERG is off all the time. New firmware. Reinstalled Zwift. Nothing works. Zwift cannot lock wattage.

I don’t have an ANT+ dongle. So no chance to try with ANT+.

Any clue?

I bought an ANT dongle. Same issue. ERG is not working.

Hi JF,

i have the exact same failure. Have you fixed it?


1 Like

Hi Roman,

what setup do you use? PC, trainer, connection…ect

Hi Gerrie,

I use a new Tacx Flux S with PC and ANT+. Sometime i use also the HandyApp and my PC at the same time. When i ride “normal” it works.
I did a ramp test, because the watts should be limited in erg mode, i.e. 160, 180, 200 etc., but it doesn’t work.


when you pair your devices do you use the ANT+ FE-C option for power and controllable.

Do you have the latest firmware on your trainer?

Hi Gerrie,

i use ANT+, i do an update 3 weeks ago.



But ANT+ should give you 2 options ANT+ or FE-C, you need to pic FE-C to make Zwift control your trainer.

Ok, thats new for me. Where can i choose FE-C?
I will try it today and give you an update.

Thanks for your super support, thats pretty cool!


When you click search under power or controllable you should see more than one device pick the FE-C one.


1 Like

Hi Gerrie,

ok, thats i will do, thanks, hopefully it works. Thanks a lot for the moment.

i drive home from work and try it.

have a good time and many thanks from “Krems in the Wachau”,


Good luck, Please let us know if it worked.


So far I removed my Giant cadence sensor and use only the Tacx for power, resistance and cadence in Bluetooth. The ERG mode works partially. See examples:

ERG 140W, If I pushed hard (175W), trainer won’t adjust resistance, it can’t

-ERG 140W, If I slow down smaller cassette ring(125W), trainer will adjust resistance to maintain 140W

-ERG 200W, If I pushed hard (245W), trainer will adjust resistance to maintain 200W

-ERG 200W, If I slow down (175W), trainer will adjust resistance to maintain 200W

All this testing been done with only power and resistance in bluetooth from Tacx trainer.

No other device connected.


Have you tried using ERG in different Gears to see if you get the same results?

Good Morning Gerrie,

now i am connected with FE-C. Yesterday i have done an Workout with 1 minute 120W and 20sek 240W. I used the same gear without shifting and it works. So i think thats it.
You have help me so much, many many thanks.
One Question - Team ODZ?

Gerrie, a good time on your bike, many thanks and “ride on”


I am so happy that it worked.

TeamODZ is the virtual team I race with in Zwift. There are many teams on Zwift, I am also part of TeamZF a nice beginner group, they are on facebook.

Watopia_Wayfinder is what we call site moderators, we have been on zwift for many years and we read every post on the site or at least most of them.

Having the same issue and I hope that pairing with FE-C is going to work.
Placed the order for and ANT+ USB dongle yesterday.

Hello, I am having the same issue. I have the Flux S and on Zwift it says that the power source and Controllable are connected to bluetooth but watts stays on 0. Please help.

I have the original issue. Tacx flux S, MacBook air, connecting with fe-c or any other option including bt does not engage erg. Simulates normal rides ok. Any ideas? Latest fw on trainer. I’ll try with iPhone today but that is not ideal in the long run

Hi All - I’m have a similar issue with ERG Mode…
Relative newbie…Recently bought a TacX Flux S and have been able to connect ok (using bluetooth to my windows 10 laptop).
Power, cadence, controller seem fine for the most part (apart from occasional drop outs), but when I use Zwift Training with ERG Mode On the resistance control seems to repeatedly fail.

This leads to being told I’m spinning too fast if i try to match the prescribed power, or to reduce power if I try to match the prescribed cadence.
I thought the beauty of ERG Mode is that you can just concentrate on the work, and not the shifting etc.
It has worked occasionally, but for no apparent reason seems to fail lots.

I’ve tried disconnecting, restarting everything (laptop, trainer, Zwift etc…), and switching ERG off and back on again during the training session, but no dice…
…vvery frustrating

On a side note I cant seem to perform a spindown through Zwift either… works fine with the Tacx App, but with zwift fails to connect…

1 Like