Tacx Flux S ERG is not limiting watts

I have a different issue. I feel my Flux is not giving enough resistance in for the wattage required. ERG is on, Bluetooth connected, paired trainer with zwift and all my personal data correct. Yesterday I did a nother ramp test. I’ll post a picture of the graph and you’ll see how eratic it is. For the warm up, I couldn’t even go down to 100 watts even with 50rpm on a big cassette ring. Going up Aloe I seem to be blowing by everyone. Trainer also has a weird knocking noise. Hope i get some feedback on my issues. Thanks guys. inbound8770529583878764873|398x500

Hi Podge, I have the same problem, could you fix it?

Same issue on a Neo 2 T 12hrs ago when training with erg. Strange knocking noise at times, resistance variable on every pedal stroke, then it would be ok for a while then start again. Never happened before until yesterdays session. Others were posting comments to say they were experiencing the same issue on the RH menu

Hi mate - well it seems for me at least it was partially human error :flushed:…partially.

It seems for me that ERG mode works much better when you keep your bike in a middle to low gear.

I believe I was starting in a high(ish) gear and when zwift was asking for high cadence (e.g.100rpm) the trainer doesn’t seem to have the range to regulate resistance back, so I was continuously getting feedback that I either wasn’t spinning fast enough or that I had too much power.

I’m finding a middle to low gear work well. Don’t have to touch the gears when I’m in training mode etc…

Seems obvious in hindsight, but I haven’t read it anywhere…

Hope that helps


Thanks Podge Nolan, I have use erg for quiet a few years so no to leave it on the small chain ring and middle of cassette and let the turbo do the rest. It reduces chain wear not having the chain twisted and saves the teeth on my big chain ring I use out on the road.

1 Like

Same here: ERG was not working on Tacx Flux S when chain on the big ring, but after changing to small ring, all works fine!

Hey i am working the same rollers tacx flux S on the apple tv zwift app and i also have the same problem in erg mode, can you help me out please

This seems to be a general issue if you are using the Tacx Flux S together with zwift.
I have the same issue. There a lot of different topics in this forum which are dealing all with the same issue.

Unfortunately it seems that zwift is kindly ignoring the problem. :rage:

Currently I’ve tried iPhone, iPad ( ant+ and BT) and windows 10 (bt and ant +). Erg doesn’t work with any. All options will control the trainer for normal Zwift rides but erg mode not working.
I used FE-C on the laptop which made no difference.
Gut tells me it’s a Zwift thing, can somebody please help?