Erg Mode not working in workouts


(Chris Holton) #1

Sorry me again!

I was able to make a custom workout using a Bluetooth mouse and dragging the blocks to the correct watts/time.

It loaded fine but erg mode didn’t work, I tried it on my phone (honor view 10) and tablet (asus z500m) and neither worked, they had both worked before.

 


(Pedro Chiang) #2

Last evening I experienced the same issue: ERG mode didn’t work. Used a custom workout, Pixel 2 running Android 8.1.0, Chromecast for mirroring, and a Wahoo KICKR. 

 


(Pedro Chiang) #3

Everything else worked just like the one I run on the Mac. 


(Chris Holton) #4

yeah, everything else worked fine for me too (except the heart rate monitor issues I’ve already mentioned). I restarted and just rode zwift and hills increased resistance as expected


(Vincent W.) #5

Pedro is ERG still not working for you? And the last time it didn’t work, was that the first time you experienced issues with ERG mode on Android? 


(Pedro Chiang) #6

Hello Vincent, I switched back to OSX because of this issue. In fact, this morning while on OSX I noticed that during warm-up at 110 watts, ERG wasn’t always keeping the upper limit, it would let me go over.

Anyway, I will try ERG mode both Android Beta and OSX tomorrow morning. 

 


(Vincent W.) #7

Hmm ok, keep me posted! 


(Eduardo Sugai) #8

just tried it here on Smart Neo, ERG seems ok now


(Alexander Neumann) #9

Tried one of the workouts on the Academy yesterday, i was locked at around 145W (50%) of my FTP. Tried to end the ride and start it again, same problem.

I’m using a Wahoo Kickr with the newest firmware.

Anyway I can see what app is sending to the trainer?

 

To check if it was not phone related I opened up Trainerroad and ERG mode was working fine here.

 


(Vincent W.) #10

Hey Alexander, were you doing a group ZA workout or non-group? 


(Alexander Neumann) #11

Hi Vincent,

I tried both, I was still locked at the same wattage.

Tried another workout today, still the same result.


(Vincent W.) #12

I see. Are you locked into that wattage only in ERG mode? Do you have similar issues in free ride? 

Just a heads up, Zwift doesn’t send any information to your trainer, rather your trainer sends info to Zwift. Zwift only reads the data sent and displays it to you. So if there are any issues with speed, wattage, etc it is due to an interruption of data being sent to Zwift. 

 


(Alexander Neumann) #13

Only in ERG mode, did the Norseman challenge last saturday and that worked perfectly.

How does the trainer know when to ramp up if the app isn’t sending any information on setpoints to the trainer?

I’ve submitted a ticket to the system to the Zwift team.