Erg mode not working in workout mode

Hi, I had the same problem and for me the solution was to shut down everything (including apps, tablet, antenna, ant +, tacx, laptop and restart only swift and my tacx, hoping that helps a few people.

I’ve had the same problem with my Suito after installing the Elite App on my cellphone ( am using PC/ win 10 and ant+ dongle). I tried several things for a week or so before i chanced to uninstall the elite app on my phone. That fixed the problem. My guess would be that the Elite app “stole” the signal instead.

In my case the “Use ERG Mode” in the workout menu was missing also.

My wife has had quite a few problems with the workouts, ERG mode doesn’t seem to engage and even in a low gear it requires 200W+ to spin at 85rpm when the warmup is asking for 85W, so frustrating, I took a video of it and Wahoo are really helpful, my fear is it’s a Zwift problem though.

Today to resolve it I did the same thing as Julien. Close the app on Apple TV, then unplug the Kickr V5, then restart both and the problem seemed to go away (until it comes back next time).

It would be nice if someone from Zwift could come up with a solution to this problem, we all have checked ERG mode button as on and double check by re-cycling on the Zwift companion app but seem to have the same problems.

Have the same issue with Erg that most others seem to have described. Have a 2017 KICKR and use Apple TV 4K and Zwift Companion App. The ERG mode again didn’t work when attempting to do FTP test, or previously some of the workouts if the wattage indicated was too low and then doesn’t shift between intervals.

Has anyone had their issue resolved?

Hi,
I’m zwifting with a Wahoo Kickr V5 and using a Macbook Pro since October.
Since this week the ERG mode does not work reliable anymore.

Anybody solved the ERG issues?

Have you updated the Kickr firmware? Because others have reported that a recent Kickr firmware update has messed things up.

YES! You are right!
So probably it’s a bug in the firmware.
Is there a way to downgrade (I did not found s.th.)

Yes, you can downgrade the firmware. I don’t know the exact procedure.

Search in forums, it is something with 10x click, I believe (not a Kickr user).

Hi, I have the same problem. Tried resolving last night and everything works perfectly on: RGT and Rouvy on my laptop, also Zwift mobile works correctly.

The free rides on Zwift on my laptop made the kickr go crazy also.

Here is the downgrade link.

1 Like

This fixed my issue; once I went to the previous firmware, it started working again.

1 Like

I have this issue. Apple tv, companion app, kickr 2020. All versions of everything current. Erg mode which used to work no longer works. Power all over the place.

I’ve tried using erg mode in the wahoo app and it’s perfect.

Where is the link to revert to previous firmware on Wahoo?

Milan already gave you the link to the procedure in his post that you replied to.

1 Like

I am having the same issue

I just reverted firmware on the Kickr. Made no difference I’m afraid. :frowning:

I’m now back on Kickr 2020 4.1.2 … Same same no erg.

i’m getting the issue on my tacx neo 2 during workouts. it was fine all week inc Friday was the last day but today its pants. lots of spkkes sending power over zone and cadence all over the place. normally i can hit every interval with erg by just riding to cadence and the neo2 sorts the power out. not today. seems ok on other apps. whats happened?

1 Like

Same problem for me. Friday my Tacx Neo 2T worked fine. My Zwift companion app kept wanting me to pair a Forerunner735XT, but I don’t own one, so maybe a neighbour of mine got one. It had not done this before. I tried to cancel, but it kept popping up again and again. When starting up I was doing 2000 (max) watts (not pedaling) until I cancelled the pairing again, and had to restart, and then it was fine. I completed the workout (erg mode) + continued into some extra distance (normal mode) without problems, even though the pairing popup came up over and over again.
Today (Sunday) It will not match the resistance in erg mode, like you all describe, and it is a bit slow at reading my rpm. My rpm indicator glows red when I’m not within 5 of the designated number, but no warnings for too high or low watts, like it usually does. I tried several times on two different PCs, running the companion app on both an iPad and an iPhone. Same problem. The 735XT pairing request still occurs every time I open the app, and I cannot see the 735XT on my devices in any other way.
Very frustrating. Any help is appreciated.

i tried it on my partners mac after i was having problems with my pc and it worked fine. so then i was thinking its a pc fault, workout fault or zwift issue. tonight i did a full workout on erg with no problems. so now i just think the erg info on the previous workout has a few bugs in it. i’m just guessing. sorry to hear you are having problems. do you have another computer to you can try it on?