Erg mode not working in workout mode

Check to make sure that ERG mode is on. When it happened to me, it was because something with the update switched it to ‘off.’ It’s been perfect since I realized it and turned it back on.

The companion app was updated monday, and I haven’t had the problem since. And no Forerunner 735XT that wants to pair…
I got an ANT+ receiver before getting home so now I use that option, but I checked the old connections as well. Everything works again.
I think it was the app-update that did it… So thanks Zwift and the rest of you for your help and advice <3

I had this issue during a BMU workout earlier this week. Zwift on the iPad, companion running my iPhone.

In my case, the lack of erg control happened in the middle of my workout. As I sat there trying to figure out what was different from the last 30 sessions, I realized that I had turned my Apple TV on. It’s never on while I ride. Turned it off, quit out of zwift, and when I loaded zwift again on the iPad, everything was working

Interestingly, when I restarted zwift, it asked me if I wanted to resume my activity and when I said “yes” it bright me right back to where I had left off. I didn’t have to skip 11 blocks in the workout like I’ve had to do in the past. Hopefully that’s a big they FIXED in this last release.

Thank you!! Yeah, ERG mode has been working flawlessly until the updates. I did check and it was on.

1 Like

So, I have updated to the latest companion app version. This has fixed the comical dropouts. Everything connects and stays connected.

HOWEVER ERG mode in structured workouts does not work. This is really annoying me as the structured workouts is a big part of why I pay for zwift and it just doesn’t work. It makes the erg sound, says it’s engaging (and ERG on in the companion app) but it’s just like normal… power jumping everywhere according to what you are doing.

FTR I’m using Apple TV and companion app. Current versions of everything. Kickr V5 with the firmware downgraded. Nothing helps.

I’ve emailed Zwift support and have only had crickets so far. Help!

I’m having the same problem, with Tacx Neo 2T and Apple TV.
Everything has been working fine for years / months, then last night noticed that ERG was not working in a workout in Zwift (it was doing something but not enough to come anywhere close to hitting target watts automatically).
I’ve tested the turbo and it works perfectly in ERG mode on the Tacx app.
I have the latest software and firmware, not sure how to resolve the issue.


I have the same issue - Kickr Core and Windows app via BT. just wanted an easy recovery ride, so chose Foundation 1 from the Increase FTP plan.

No problem keeping the cadences, but the power settings were off: multiple times it dropped to 50% of FTP when I should have been doing 75% or vice versa, leading to messages of ‘More Power’ or ‘Less Powerk, but with no way of actually changing the power

In the 10 minute warmdown, the app told me it was going to gradually wind down to 40% of FTP, but instead stayed at the 75% level for 8 minutes, despite the screen reading that it should have been decreasing (interestingly I didn’t get any ‘Less Power’ messages in the warmdown

I’ve tried three workouts in Zwift in the last week, and all have been similar, the power doesn’t change in line with the programme. Including in a ramp test, where it just wouldn’t increase the resistance to allow me to increase power.

Has anyone found a solution, or had confirmation that there is a fix coming?

1 Like

I’m having same issues. Same setup. Sometimes works fine. Sometimes not. Driving me nuts. And I updated Zwift on my Apple TV today too

1 Like

I have another thread in these forums. I had the same problem. I found for me that not getting bluetooth through zwift companion app fixed the problem. You have to use the apple TV BT and it works perfectly. You can still use companion app though, just not for BT. Give it a try and report back.

1 Like

Update on my experience with Windows Zwift & BT in ERG mode - I’ve done four workouts, the third one worked perfectly, the others haven’t worked.

The last one has made me wonder if the problem is simpler than I had thought, as the program simply didn’t meet the description.

I noticed at the end that it was supposed to be a five minute warm down on the schedule on the left, but the text in screen said it was 10 minutes… this was the “week 1 day 3 - foundation” workout from the 6wk Beginner FTP Builder programme for reference.

So is it as simple as the workouts aren’t programmed correctly? Maybe it’s not a case of the ERG mode not connecting, but it’s just entered wrong at Zwift?

Has anyone done the same workout where it has worked perfectly one time and ERG didn’t seem to work another?

I have same issue. Macbook pro and Flux 2 (BT).

I tried today with companion app, and directly connected to Mac. I still have problem.
I started to having this problem around two weeks ago. Tiil then everything was fine. Maybe last zwift update ?


Tried it again after the latest update and power cycling the turbo, seems to work fine now.

I haven’t tried it (been using the workaround). Will give it a go tomorrow. Thanks for the update.

I agree. It worked for me again. Cool!

Same here. This is frustrating! It only started happening this week. :-/ :frowning:

1 Like

And bluetooth disconnected in the middle of my ride. Started last week.

Same issue here. Zwift is running on Windows 10, connected to a Kickr (2014) via a USB ANT+ dongle.

When I start a workout, the Kickr does not go into ERG mode even though Zwift displays that ERG mode is on. Switching back and forth between ERG and incline does nothing.

Restarting both the computer and the Kickr 2014 will occassionally fix this issue, but I often have to do it multiple times which, because Zwift literally takes minutes to start up, log in, and begin a workout, is increadibly frustrating.

1 Like

This has been happening to me recently. I’ve been using Zwift for a few years without issues.

Do you think it’s mainly affecting people (like me) who use the companion app to control the turbo, or laptops with dongle?

1 Like

I’m having similar workout weirdness in the last week or so.

Zwift on iPad Pro (iPadOS 14.5), iPhone (iOS 14.5 and before that betas), M1 MacBook Pro (latest OSX) via ANT+ stick with a Wahoo KICKR 2018. (last firmware from 2020)

The likely common factor is Zwift as the Kickr has not received any updates in the last months.

the workout resistance for erg mode doesn’t make any sense - like the original poster - under power reported - but you can never reach the power band. This is painful when the intervals are at 80%+ Threshold.

I’m a level 50 on zwift and done rather a lot of workouts. this is rather annoying
… I thought it was me!

1 Like