Erg mode not engaging

Problem started when i noticed on a couple of sprint’s that i could hardly get above 450 watts on the flat!
I have an elite direto and i use the zwift companion app to connect it to my apple tv along with my pm and hr. It has no bother connecting.
If i go up inclines i can feel the resistance change so why am i suddenly spinning out on the flats? Even if i change to a harder gear then the same happens.
I have updated the trainers firmware and been on the elite my training app and i can feel the resistance gradually coming on when i go up tge levels from 1 to 16.
I rarely use erg mode but this week i tried a workout. It shows i am in erg mode and can toggle it on and off on screen. However when its showing on it isnt working at all.
Ive borrowed my sons laptop, fired up zwift and connected with ant+ and its tge same issues.

Ive tried reinstalling both zwift and the companion app.

Anybody got any troubleshooting steps?

Does it happen if you connect your trainer directly to the ATV and not via Companion?

It’s probably ZC being weird. It’s not a reliable way to connect.

Yes it does.
Its the first time ive had an issue with ble.
I have used ant+ on my sons laptop and its the same