Not enough resistance in erg mode

On my new Direto XR, no matter what gear I’m in, it won’t provide the correct resistance for the target power. Zwift will constantly say “increase power” but the trainer just doesn’t compensate enough so I’ll be outputting too low of a power for that interval.

I’ve tried ant+ and Bluetooth and different power smoothing settings aswell as updating to the latest firmware. It’s incredibly infuriating as my old wheel on trainer would compensate to achieve the desired power no matter what gear I was in.

Is it possible my unit is faulty or is something else going on?

I have had this same problem with my Kickr and after ruling out all possible causes that folks/tech could think of, I was advised to uninstall and reinstall Zwift, which I just did and will try erg again (training/workout) later this morning.

I hadn’t considered that, I’ve done the same but won’t try it until tomorrow. Let me know if that solved it

Unfortunately the uninstall-reinstall was no help – it remains nonfunctional as to erg.

I reinstalled zwift and the issue seems to have been resolved. I started in the small chainring and the 5th sprocket largest sprocket on my 11-32 ten speed and it seemed to work fine. It was a bit slow to respond when there was a large increase in power but it worked. Not sure what else you can try though

Thanks — no luck for me so far. I thought running both HRM and Kickr through ANT FE-C would do something but no help with that either.

Do you use any other training programs that you could use to test your trainer on? Maybe trainer road or Rouvy? I believe Rouvy has a free version that could be downloaded. I’d test the trainer outside of zwift and see if you get the same results. At that point you know if your dealing with the trainer or with zwift.