Anyone having Erg issues the passed week or so?

I’ve raised a support ticket for the below, but wondering if anyone else is suddenly having issues?

Hi, I’ve had perfectly stable Zwift on Windows 10 PC, KICKR18 with Climb and Apple iPhone 7 and all devices connected via Bluetooth via companion app for almost 9 weeks, up until last week, then:-

Workout “Circus” on June 9th – Everything paired via the app as usual, but then no erg mode active once started. I powered everything off and on and all good, erg back again. Workout went fine.

Workout “Malevolent” on June 10th – Everything paired up via the app on start up as usual, but no erg mode again, no amount of restarts could get it to work this time so I resorted to doing the whole workout just on the iPhone 7 running the Zwift app and paired direct to the trainer.

Workout “Mosaic” on June 11th – Everything paired up via the app on start up as usual, but no erg mode again and wasted an hour trying restarts etc. Ended up putting the zwift app onto an Apple TV 4k box. Paired the trainer direct to the Apple TV as the companion app wouldn’t connect at all. Erg fine through the Apple TV but cadence erratic.

Workout “Melange” on June 14th - Game did an update on start up to 1.5 but then could not connect “controller”, no amount of restarts would let the companion find it. Turned off every other blutooth device in the house and unpaired the Kicker from the Wahoo app in case it was hijacked, then updated the KICKR firmware, restarted EVREYHING and still no controller pairing. Power and cadence would pair, but not controller. Went back to the Apple TV. This time, the Apple TV found the companion app (after I’d already direct paired the trainer to the Apple TV though). So I had power with erg through the apple TV and erratic cadence again and the companion app just showing the workout.

June 15th – I found a forum post about a bug in companion app 3.15.0 not finding the controller, so I updated the app to 3.15.1 thinking that would likely solve the issues……

Workout “Baffling Beau” June 15th – Fired up the PC Zwift and newly updated 3.15.1 companion app on the phone, everything paired straight away (including controller), got into game – NO ERG MODE STILL!!! Uninstalled and re-installed Zwift on the PC, still no erg mode. Fired up the Apple TV again, this time the companion app paired properly and all devices paired to Apple TV via the companion app version 3.15.1, but now no erg mode on the Apple TV, so I figured it had to be a companion app issue? I turned the companion app paring off and paired the trainer direct to the Apple TV, perfect erg power (but erratic cadence), at least it’s a work around that lets me to the workouts.

So I figured it must be an issue in the companion apps from 3.15.0 and 3.15.1 so I found an old iPhone 5 with an old iOS and the app store installed version 3.11 of the companion app. I went back and tried to pair the app to both the PC and Apple TV and both times got the same problem, all devise pair though the app but no erg in game (even though it says on the workout screen “erg mode activated”.

It’s not just that the erg isn’t working, but also the power is super erratic too. If I try and hold a steady power the power numbers on screen swing wildly all over the place.

TLDR:- In summary, since June 9th after months of zero issues with Win 10 PC & companion app iPhone 7, KCIKR18 all devices paired via companion app, then from June 9th:-

Win 10 PC & companion app iPhone 7, KCIKR18 all devices paired via companion app – No erg mode (app version 3.11 or 3.15.1)

Apple TV Paired through companion app version 3.11 & 3.15.1 – all devices pair, but no erg mode and erratic power readings

Apple TV direct paired to KIKCR18 - power & erg perfect, cadence erratic.

…I’ve also tried the companion app 3.15.1 on an iPhone XS and exact same issue, all devices pair but erg mode not working in game workouts (I also tried several different workouts on each of the above scenarios to ensure it want just glitch in one particular workout).

I’m having the exact same issue. Suddenly, I don’t have ERG mode for any of the workouts. Rouvy and Zwift rides are good so I know it’s not the trainer. Somethings up with Zwift. Looking forward to reading what it takes to fix it.

Well, Zwift support responded last night, with a cut & paste copy of the Bluetooth connection troubleshooting faq and the suggestion to update the KICKR firmware and install the latest app versions (which had all already been done had they actually read the submitted ticket) so no help what so ever.

I didn’t even bother trying the PC last night, I just robbed the APple TV for the living room, forgoed the HR and Blutoothed the trainer direct to the Apple TV again just to get through the workout,.

Out of curiosity after I finished I fired up the PC and the companion app to see if a magic fix had occurred, NOPE, same issue, everything connected but erratic, uncontrolled ERG mode in game.

I found another old iPhone in a drawer last night, a version 6 this time. I figured I’d charge it and put the companion app on to test just for the heck of it.

Would you believe it worked!!! Paired up the trainer, HR & Cadence, got into the game work out and rock solid ERG mode.

Restarted, tried the original iPhone 7 and companion app again that’s worked for months and NO ERG mode.

Interestingly, when I fired up the Apple TV and direct connected to it the cadence was rock solid last night.

I’ll find out tonight whether the “new” old iPhone works again, or if that was a freak one off.

So, if it works, I’m happy again BUT that’s the 3rd phone it’s taken to get working and not everyone would have the luxury of a draw full of old iPhone’s to test.

I’ve gone back to Zwift support again and asked for further investigation.

So, to update the summary:-

TLDR:- In summary , since June 9th after months of zero issues with Win 10 PC & companion app iPhone 7, KCIKR18 all devices paired via companion app, then from June 9th:-

Win 10 PC & companion app iPhone 7, KCIKR18 all devices paired via companion app – No erg mode (app version 3.11 or 3.15.1)

Apple TV Paired through companion app version 3.11 & 3.15.1 – all devices pair, but no erg mode and erratic power readings, same iPhone 7.

Apple TV direct paired to KIKCR18 - power & erg perfect, cadence erratic.

Win 10 PC & companion app version 3.15.1 on iPhone XS, same issue, all pairs up but no ERG mode in workouts.

Win 10 PC & companion app version 3.15.1 on iPhone 6 - WORKING! (at least it did last night, will update the thread after tonights workout).

Like I say, ERG mode comes “on” but it’s juts doesn’t do anything, it’s not controlling the trainer.

1 Like

…So, as I said above, the iPhone 6 I tested work flawlessly. I turned everything off, went to bed thinking I had a solution.

Fired it up last night (after changing absolutely nothing form the working set up the night before), got into game, into workout - NO ERG MODE!!!

Pulling my hair out.

When I say no erg, I mean the game says it’s on, the app says it’s on but it will not hold me to power. It swings wildly all over the place.

When I got into the erg mode workout the game screen above the wattage & cadence bar flashes up ”erg mode activated”, but it isn’t, it will not hold the trainer to the required power. If I stopped pedaling it flashes up “erg mode disabled”. If I pedal again it’s flashes up “pedal steady to activate erg mode” then “erg mode activated”, but it isn’t, it will not hold the trainer to the power.

I stopped pedaling about 3 times last night to where it will say “erg model disabled”, on about the 4th slow and steady pedal back up it dd the “pedal steady to activate erg”, then “erg mode activated” and then it actually did hold power, although at about 3-5w under target in each zone (used to be rock solid and hold exactly the required power).

I finished an hours workout, erg held almost correct power each time (within 3-5 watts).

So, I thought I’d found a workaround by starting the workout, stopping pedaling and slowly pedaling back up to auto-toggle erg and and off in game so thought I’d try it with my original phone that’s worked flawlessly for months. Restarted everything, fired Zwift back up, paired the original phone & app, no ERG mode. Went through the same drill, stop pedaling, pedal slowly, nope… tried about ten times and could not get erg mode to hold wattage even though it’s telling me erg is on.

This is driving me nuts. It;s the same with the Apple TV, so that’s two platform and three phones across 3 different versions of the companion app that will not hold erg power when connected via the app, so It has to be something to do with the communication between app & game.

I have changed nothing and the system has worked flawlessly for months up to June 9th, since which I have not been able to use my system properly and had to resort to direct pairing the trainer to an Apple TV box.

Updated support ticket again this morning, waiting for some suggestions.

Super frustrating.

Everytime you update the support ticket you get put to the bottom of the pile. It will take about 2 weeks.

In the meantime erg isn’t everything. I think it’s important to learn/practice to ride to a power without erg. There are others that agree.

Sure, but I use Zwift purely for the workouts so I like it to hold me at the required wattage.

Besides, as I said above, the power is completely erratic. It’s not just not holding it in erg, if I pedal at (what I think is steady) the numbers swing wildly +/- 50-100w

For me, one of the main reasons I went for a Zwift & Smart Trainer set up was for it to hold me at required watts in training.

With the wild wattage swings I can’t even use it for free rides or races.

I used Zwift + Kickr Snap+ ANT+ sensors (cadence, heart rate, by Garmin) and everything was ok… I completed ftp biulder training plan ( 6 weeks, 25 sessions) and also OK… but after last update of the Zwft software on my notebook ( Windows 10), I started to have many troubles: one side with dropouts of sensors and samrt trainer connection and during workout, the ERG mode seems to be not active because the power is flicking always… I´m getting crazy !! … I used the smart trainer and sensors with garmin edge 1030 and everything is ok… this could mean that the problem is around notebook… (Zwift program and/or ANT+ stick)

Happened to me this morning. My workaround was to load the wahoo app up on my iphone (im on a kickr core), switch to erg mode in that app, adjust the wattage a bit in the app and then close it. Zwift then continued my workout in erg mode.

I’ll give that a try today @Mark_Angel-Trueman

Just so I know to try the same thing, did you connect via companion app first, then get into game/workout then flip to the Wahoo App on the same phone you had the companion app open on?

Then, set a power in the Wahoo app, close the Wahoo app fully? (like swipe it off the screen), then leave flick back into companion app on the same phone?

I’ll try same today and let you know if it also works for me.

Thanks.

Yeah, thats exactly what i did :slight_smile: Make sure you select erg mode in the wahoo app of course, i think its doing that which makes the difference. Good luck, hope it works for you.

Tried it last night.

I’d taken the Wahoo app off the phone before as part of trouble shooting, so I put it back on, paired the KICKR18, started a workout in the Wahoo app and set it to ERG and hold 200w. Rock solid, no issues.

Fired up Zwift & connected everything via the Companion App, got into game, into workout and the usual issue, no ERG mode power holding (if you stop pedaling Zwift flashes up ERG mode switched off, then start pedaling and get “hold steady to activate ERG”, then “ERG activated” but doesn’t hold wattage).

So, flicked back to the Wahoo App but it wouldn’t pair, it spun for a few minutes searching, so I flicked back to Zwift, pedaled up, stopped, sow peddled and get “ERG activated”, but no power as usual. Did this about 3 times, on the third time it started holding power but at about 20w under what the game was requiring (this was all in inside the 10 minute workout warm up). Each time the warm up wattage increased, the ERG wattage also increased and caught up slightly more, so maybe say 20w behind at 90w, then 15w behind at 98 watts etc. By the time the warm up seance got to 140w the Erg on the Kcikr had caught up and every interval for the next 90 minutes was rock solid at the correct wattage.

So strange.

Will try the same thing again tonight.