ERG Mode NOT working after latest Update [1.41] [3.47] [June 2023] [SOLVED]


After lastest update ERG mode is just dead.

I’ve tried everything:
Reinstallening swift on PC
Reinstalling Swift Companion App
Reconnecting everything from scratch
Turining on/off Bluetooth

Nothing works. This is so frustrating and there’s nowhere to ask for help.

My set up is

Windows PC
Wahoo Kickr Snap - Firmware was checked
Connection thru Companion App with BT

Everything was working perfect yesterday. Today, was the update and ERG is just dead. I tried different workouts and in all of them, the app says ERG is “on”, but no resistance us generated an wattage is “free” to what I pedal.

Any ideas?

First thing to try would be to calibrate the trainer in the Wahoo app, test ERG mode in the Wahoo app, kill or remove the Wahoo app and retry in Zwift to ensure that nothing else is controlling the trainer. If ERG mode is busted in the Wahoo app with Zwift not running, contact Wahoo support.


Is just tried in the Wahoo App, and it worked perfectly.

I then killed the app, connected to swift and same thing: It says ERG is on, but wattage is not adjusted.

Here is a pic, in case it helps.

Any other ideas?

1 Like

Did you pair as Power and controllable.

why do you use the companion app to connect. Don’t’ you have a Bluetooth or ant+ dongle for the PC, it is much more stable.

1 Like

Hi. Yes. It is comected as power and controllable.

I use the app cause it helps me to keep everything on the companion. The computer does have BT.

Im going to try to connect directly tje three devices (cadence, heart rate and the kickr), to see if it works. It stopped working after the update, though, and it bugs me.

I’ll get back to you.

Hi. Following up on this. Kickr Snap does not allow to connect “directly” to the Bluetooth of the computer (now I remember why I didn’t set it up like that). As you can see on the official webpage:

More over, I tried again, the Kickr is recognized and controllable by the app, but ERG just won’t work:

Does anybody have any ideas? Maybe an administrator?

This is so frustrating. Everything was working perfectly on Wednesday and after the update, ERG just does not kick in. I use Swift mainly for training, so if this does not work, it is just useless to me…

Thanks for the help.

That is different, that is a warning not to pair the kickr to the computer or phone but to only link it with the kickr app or in this case the Zwift app.

It is the same for Zwift, you should not pair a bluetooth trainer to the PC or Phone, and only use the Zwift game app to link the trainer.

Bluetooth cant connect to more than one device at a time.

Have the exact same problem as of most recent update, except with a Kickr Core. Windows PC, also connected through companion app (I get fewer dropouts using the app than with direct connection).

ERG mode will not engage. Tried to do a workout last night, and while everything was set as normal with ERG mode on, the trainer would not stay in the target zones. Tried restarting zwift, restarting computer, power cycling the trainer, reinstalling, etc. Eventually just did a pacer ride instead. Sim mode worked fine in zwift, and ERG mode works on other apps (wahoo, trainerroad, etc.).


Got it.

I just connected thru the bluetooth in the swift app game, and same thing. It registers my wattage, but ERG just won’t kick in.

Any other ideas? I’m still positive it has to do with the update since before it, everything was working great.

Thanks for the help and patience.

Welcome to y world.

I’ve been dealing with this for 2 days already and no progress. I’ve tried everything possible.

Hope we find a way to work around it soon; otherwise, Swift is useless to me.


Thanks all. I’ve flagged with our team.


Same issue here with a Saris H3.


Can you give more information, I have a H3 no issues.

Not much to add, its identical to the issue described above. Everything is paired correctly, workout starts with erg mode enabled but resistance doesnt change. Also, switching to “Incline” and trying to adjust there has no impact. Have tried on several different days, restarting everything, etc etc etc.
Worked last week before I got the update. Pretty clear this is an issue on Zwift’s end.


Completely agree on that.

Any ideas from swift administrators?


Yep same issue with stages bike. Erg is all over the place and not provided enough resistance. Can’t hit targets during workout.

1 Like

@Anders_Swanson , @Diego_Torres1 and @5.Gary_Joyce_ABR

Please give us more information see: this link

1 Like

Can’t get that link to open. Anyway short version. Got the sb20 at the start of the month but haven’t used it due to injury. Finally gave it a bit of stab today. I use xert and would normally set up giving my Garmin control and run xert through that. Couldn’t get that working at all today, tried a few different ways of connecting. Eventually gave up and downloaded the workout into the custom folder and connected as normal. Erg mode would not engage. No where near the targets for the intervals and it wouldnt ramp up. Even tried.connecting through the xert ECB app. No idea wots going on?


In relation to this request and the post. Let me provide the requested information:

  • Latest versions of Zwift and Companion App Installed: Checked
  • Operating System on PC is up to date.
  • Zwift official troubleshooting guides read (that was the first thing I did on June 1st)
  • Know issues discuss ERG, but nothing fixed the one I´m experiencing.
  • All equipment is BT connected.

Devices I´m running Swift on:

  • Computer
    • Acer Nitro 5 -AN515-54
    • CPU: Icore i7-975H
    • GPU: Nvidia GForce RXT 2060
    • SSD: 240GB
    • WiFi connected to house internet
    • Operating System: Windows 11 Home 64-bit Version 22H2
    • 16GB RAM
  • Cellphone
    • Samsung A73 5G
    • Updated
  • Trainer
    • Kickr Snap 27CA
    • Firmware Version: 2.3.63 (latest version)
  • Sensors:
    • Wahoo Cadence CB45
    • Firmware Version: 2.0.19 (latest version)
  • Network environment
    • WiFi
    • ISP – Local
    • No adblocking, no firewall software
  • Region
    • Costa Rica, Central América.

Some more pointers:

  • All this started last Thursday just after the latest update on swift game
  • Before that everything was working great
  • All functions seem to be working except ERG (topic discussed here)
  • I reinstalled everything, Swift Game, Swift Companion App, reset the trainer, rebooted phone, tried directed connection with BT to the Trainer, and thru phone as a bridge: result is the same. ERG is dead. No resistance whatsoever in during my regular training.
  • I even redid a train I took on Wednesday (when everything was working fine), and now ERG is dead.

Finally, I just tried everything again today, and the results are the same except for one thing: ERG continues to be dead (it does not adapt the resistance to what the game says), but when I stop pedaling the ERG gets disabled (as it is supposed to) and the trainer goes to SIM mode. Then, when I resume pedaling, the ERG kicks in again, but the resistance gets super hard (I might calculate 300-400 watts), when on screen it should be 75wts (for example).

Hope this helps some way….

Does ERG work on other apps?