ERG Mode NOT working after latest Update [1.41] [3.47] [June 2023] [SOLVED]

It does.

Just tried on native Wahoo App, and it works perfectly.

I actually tried it and uninstalled the wahoo app, to make sure it was not interfering with SCApp, and same result.

Do you have a ant+ dongle to try.

I´m afraid I don´t have one.

1 Like


Does the trainer change resistance on a free ride.

I just did.

I tried a free ride on Hilly Route to make sure there were hills and gradient, but no change. Pretty much my wattage is still the same, but the speed decreased a lot (as expected). So I guess that´s working fine, since the trainer recognizes my change of power and adjusts the wattage and speed. The resistance would need to be created by switching gears.

Two pictures seconds apart:

First one at 75 watts

Then second one at 123 watts (notice the change in KPH). 30 seconds difference with the first one.

One more of the in-game

What do you think?

That is not right, when you approach a hill it should get harder especially on a 7% incline.

Sorry more questions.

Can you check that the trainer is not connected to the phone or Pc’s bluetooth, if you see it in the bluetooth devices you need to let the device forget it. Bluetooth can be very tricky.

Thanks for the screenshots. Do you have one of the pairing screen.

Hmmm I might think that when the route gets steeper, if I don´t increase wattage, then the speed should decrease… :thinking:

The trainer is definitely not connected to any other device. I even erased the Wahoo app to make sure of that. I checked the computer and cellphone and it is not directly connected to them, it only connects thru the SC app.

If you mean, the pairing screen in Swift Game, here it is:

I already tried connecting thru Bluetooth from PC and it´s the same thing.

Here´s a pic of how it looks on the app:


1 Like

Wow :flushed:.

I am running out of ideas :bulb: :flushed::sob:

Let me sleep on it :zzz:

1 Like

Thanks for all the help. I´m this close :pinching_hand: to just give up… I tried everything.

I even contacted official Swift Support and they gave me a procedure to uninstall the Game altogether and reinstall it. Just did it… no success. I just don´t know, and I swear, none of this was happening last Wednesday before the update.

Thanks again for your patient assitance.

Two things should happen - speed decreasing is one of them but the other thing is the resistance the trainer is providing should noticeably increase. E.g. if you close your eyes and ride just before a hill, you should feel the hill just the same as in real life, and the pedals should be much harder to turn. This second aspect is what the other user was asking about - to try and see if it was just workouts or also free riding affecting resistance.

Have you updated your trainer firmware?
After the last upgrade, Zwift stopped sending gradients to my trainer and I needed to update the firmware in the Wahoo app (have a Kickr Core).

Hi. Gotcha!

I’m afraid, accitfing yo the free ride I did in hilly route, resistance doesn’t change, so I guess that’s not working as well.

Thanks for the clarification

Thanks for your help.

That’s one of the first things I checked when I started all this troubleshooting. MyWahoo Fitness App says the firmware version is 2.3.63, and that’s exactly what the official website says for this trainer.

Picture of the website:

Picture of my app:

Bottom line, it’s up to date.

If any other suggestions, they are welcome.

Thank you.

Hello @Diego_Torres1, I’m sure this is frustrating for you. Please hang in there. We are working to get you ERG mode (and Sim mode) again.

To help diagnose the issue, I’ve enabled additional logging that will be captured when you perform an activity with Zwift.

From your posts, I see you tried to connect the trainer without using Zwift Companion. Even though you’ve already done that, I’d like to ask you to do it again, but following these steps:

  1. Please find and rename this file on your machine, Documents\Zwift\prefs.xml, to backup-prefs.xml.
  2. Please find and delete this file on your machine: Documents\Zwift\knowndevices.xml.
  3. Do not launch Zwift Companion at any time during your Zwift session (I apologize for the inconvenience, just want to simplify the set up, so we can figure out the real issue, then you can go back to using ZC).
  4. Check your phone to ensure Zwift Companion is not running in the background.
  5. If ZC is suspended (running the background) on your phone, force close it by swiping it away.
  6. Launch Zwift
  7. At the Paired Devices screen, ensure the icon in the upper right shows the normal Bluetooth (as opposed to the rectangular ZC icon from your previously supplied screenshot).
  8. Select the devices you want to use, then advance to the Home screen.
  9. Proceed with an activity of your choosing and determine if ERG mode or Sim mode are working again. It would be great if you could try a workout and a free ride Hilly Route.
  10. Once the activity is completed, exit Zwift. It is important you do this before step11.
  11. If you backed up your prefs.xml file by renaming it to backup-prefs.xml, please delete the newer prefs.xml that was created in its place, then rename backup-prefs.xml back to prefs.xml.
  12. Please post the results of your test as to whether ERG mode is working again or not…

What we’re really doing here is to simplify the testing so you start fresh and clean and without complications. Good luck, looking forward to hearing that this fixed things for you! If you have questions about any steps, feel free to post them in a reply.

1 Like

Hello Mike.
Thanks so much for your patience, help, and detailed troubleshooting process.
Let me tell you what I did and the results. I’m good at following procedures so you can rest assured I’m doing it correctly. Here we go:

  1. Done

  2. Done

  3. Made sure SC App is not running. I force-stopped it and turned off the cellphone.

  4. Done. Closed it, force-stopped it, and turned off cell phone.

  5. Done in 3 and 4.

  6. Done

  7. Confirmed. Here’s a screenshot:

  8. Done. The first time it didn’t want to connect to the trainer or sensors. So I exit the game, switched off the trainer, the BT, and turned everything back on again. Screenshot:

  9. Did several tests on the workout I’m on, Hilly Route, and even created a custom workout with drastic changes in resistance, and IT WORKED! ERG IS FINALLY WORKING! Some pics:

This is the custome work out I created and ERG kicked in!

  1. Done
  2. Done. Deleted new file, renamed old file to “prefers.xml”

Now, big question: Can I still connect everything thru the SC App? Or is it a better idea to have it all connected thru the BT of the Game. If so, Can I open the SC App and use it during the game (when connected thru game BT), as normal?

Something else. By erasing the “new” prefers and going back to the old one, won´t the problem persist?

I guess we´re getting close! Yey! :partying_face: :partying_face: :partying_face:

1 Like

Really happy to hear the ERG mode feature in Zwift is working for you over “native” Bluetooth on PC, @Diego_Torres1 .

I know my detailed steps can be… verbose. I apologize for that, but also want to make sure that you renamed “backup-prefs.xml” to “prefs.xml” and not “prefers.xml”.

Yes, you are correct that using ZC or restoring the backup-prefs.xml to prefs.xml might cause the problem to return. However, this test proves we can make this work on PC through native Bluetooth.

Let’s try to get you working with ZC again. We can try another, simplified test (but with detailed steps).

  1. Ensure ZC is not running or suspended in the background.
  2. Turn off the Bluetooth support on the PC (we’ll turn it back on afterwards)
  3. Delete the knowndevices.xml file (and only that one file)
  4. Launch Zwift
  5. When you get to the Paired Devices screen, switch over to using Bluetooth ZC – but DO NOT launch ZC.
  6. You should get a ZC disabled icon and no “radio waves” emanating outward from the icon, but whether you do or don’t, “Skip” the pairing screen and proceed to Home screen.
  7. Exit Zwift (sorry to have you keep launching and exiting).
  8. Re-Launch Zwift
  9. This time, when you get to the Pairing Screen, you should see the same behavior as before: “disabled ZC” icon and no “radio waves” coming out.
  10. Now you can launch ZC, and attempt to connect your devices
  11. At the Home screen, choose an activity (like your new custom workout) and verify that you have ERG mode.
  12. When you have the time, please try these steps, and please post the results whether this works or not. Too often, some users go off happy without confirming the issue was resolved.
  13. When you’re all done, you can turn BT back on for your PC.

If you are able to use ERG mode with ZC does, it means Zwift is confusing devices used with native Bluetooth and devices used with ZC and that confusion is causing an issue with the communication to the trainer. This is something we’ve seen with Android ZC and are working on, but just as it’s frustrating for you to have a feature that is not behaving correctly, it’s difficult for us to find an issue when the feature is behaving. Your test result will help us to determine if the issue is with

  • knowndevices.xml (containing the wrong IDs)
  • Conflict with native and ZC Bluetooth events
  • All of the above
  • None of the above

Thanks Mike!
No problem with the wordiness. I´m super talkative too and tend to use a lot more words than expected. I´m also used to detailed walkthroughs since I´m a teacher.
In relation to the first question, my bad I typed it wrong, but I named the file “prefs.xml” (I basically copied it from what you wrote on the previous post).
Let me go thru with the second process:

  1. Done

  2. Done. BT is off on PC

  3. Done. Erased the file for good.

  4. Done.

  5. Done. ZC is NOT Running on Cell phone

  6. I indeed get the ZC icon with no waves. I skipped and got Homescreen. Here´s a screenshot:

  7. Done. Don´t worry. I´ve exit Swift like a million times during the last 3 days.

  8. Done

  9. Correct. Same behavior, no waves.

  10. Done. Devices get connected. Here´s a screenshot:

  11. No success. :expressionless: :expressionless: :roll_eyes: :roll_eyes: :sob: :sob:ERG did not kick in. Here are some screenshots from the app:

  12. Did not work.

  13. BT is back on PC.

Any other ideas? It seems to be something related to the communication when the app is working as a bridge.

Take into account that the “knowndevices” file was autogenerated and is again the Swift folder

Thank you,


Quick update. I just did a workout using the Swift Game BT connection as done two posts ago. It all worked fine and I was able to finish the workout with ERG mode enabled

Then I shut down everthing and went to have dinner. Since I’m so traumatized with this thing, I went back like 2 hrs later to try again, and unfortunately it didn’t work anymore.

I did the whole process again (erasing files, restarting everything, etc) and it kicked in again. Then I exit the game, app, and companion and configuration was lost again.

Apparently the Swift Game (and I might guess the app) is incapable of remebering the devices connected to it.

This is getting ridiculous already since I spent countless hrs troubleshooting and 0 on the bike pedaling.

Thanks for the support.

I know how frustrating this has been for you, @Diego_Torres1 and I’m sure you have better things to do with your time than jumping through a bunch of hoops. I want you to know the solution is not going to involve you having to go in and do a bunch of operations before each and every session.

My goal with all of those steps was to create a clean, simple test, and once we found the cause of the issue, there might be a temporary workaround (like using native BLE) until the issue is resolved completely.

Let’s talk about that knowndevices.xml file. As you have seen, the game saves that file out after every session. The reason I’ve been asking you to delete it is with some suspicion that it is not remembering the devices (and connection) correctly. This is a separate, ongoing issue we are currently researching.

But you don’t have to delete it before every session, I was just suggesting deleting the file when you switch back and forth between using Bluetooth connections through ZC or through native Bluetooth on the PC. I’m not entirely sure this is even necessary, but it cleans the slate. (Once the issue is resolved, you shouldn’t have to delete it at all).

It looks like one difference in your subsequent PC Bluetooth test was using Zwift Companion. I don’t blame you for that, as it’s the perfect workout display/remote, but if Zwift is confusing devices connected through Bluetooth via ZC and via PC, then having Zwift Companion open could add to the confusion. Would you consider, for the time being, as a temporary solution, using “native” Bluetooth connection from PC and using ZC (but with Bluetooth turned off on phone while Zwift Companion is running)?

I think with this setup (after deleting knowndevices.xml again, hopefully for the last time), you could continue to use the PC Bluetooth connection without having to take any additional steps while we work on restoring the ERG mode functionality when using the Bluetooth connection through Zwift Companion, and you’ll still be able to use all of the other useful features of ZC.

Hello Mike,

Once again, thank you very much for your helpful advice and guidance.

Unfortunately, problems persist. I erased the “knowndevices” files, and connected directly with the PC BT, and not only it takes ages to get find and connect the devices (like 8-10 minutes, which is an eternity just looking at a screen), but the connection is super unstable with the other sensors (cadence and HR). I´m not gonna lie, once it connects to the trainer, the connection is stable and ERG is solid, but the other sensors fluctuate a lot and they say “no signal”. I move them, wake them up, turn them off and on, and they reconnect for a few seconds and then “no signal”. Screenshot for illustration purposes:

I disconnected everything, rebooted the PC, turned off BT on my cellphone (not even got to open SC App), I even erased all other BT devices connected to the computer to make sure they are not interfering with the signal, and it continues to erratic and random. They connect, disconnect, connect disconnect… The only one which is stable is the trainer, though.

One more day with no training.