"Free ride" sections of workouts don't disengage ERG mode on Wattbike Atom

Hi all,

By way of background info, I’m using an Apple TV (will be adding a feature request to “un-end” a workout on that note shortly!) and a Wattbike Atom. I’ve got the companion app on iPhone, and in general all is good - Zwift picks up the bike for cadence & power and heart rate from my Apple Watch (via the companion app). So far so good.

When I do an organised workout - e.g. Zone Benchmarking or Pedalling Drills in the Build Me Up plan - which has “free ride” sections, the ERG does not disconnect. It doesn’t seem to matter whether I try using the action button on the right shifter or the ERG/Incline toggle in the companion app… the bike stubbornly attempts to hold whatever power setting was last used on ERG.

This is annoying on the zone benchmarking, because what’s meant to be a 1 minute interval at a set power becomes 1 minute plus the next free ride interval at the same power and that makes the results less meaningful than they should be. On the pedalling drills one, however, it’s a nightmare. I’m sure there are many cyclists better than me who are capable of unclipping a foot and continuing a cadence unchanged… but I’m not. I unclip one foot, my cadence slows a bit, the resistance goes up to keep the power output constant, and then I’m dead in the water as my (one-legged) cadence slows further.

ERG itself seems to work fine, and “non-ERG” rides are also fine - if I set off on a group ride or whatever and use it in gear mode all is ok… it just seems to be the switch from ERG to not (NB, the power “segment” on the companion app disappears to show that it’s not intentionally controlling it) that doesn’t actually do anything and can’t be overridden on the bike itself. Gear shifters do work, so you can drop the resistance to get pedalling again… but as soon as you stop pressing the button you’re fighting the bike as it tries to get back to the previously set power.

Any suggestions? is this a bug, or am I doing something wrong?

Kev

Just done a similar training session on my new Atom and have the same issue - ended up resorting to coasting down to a standstill instead of free ride. Erg mode also stuck on at the end of the session requiring atom power off and on again.

I wonder if this is an Atom issue or a zwift issue

Andy

I’ve just had exactly the same issue on the benchmark test. I’ve only done either freeride or ERG training so far so hadn’t experienced it. Any luck sorting it?

No luck fixing it my side - I’ve just been avoiding rides that include free ride sections. Also annoying at the end of a workout when it does the same… not so terrible if the workout finishes at 70-90% of FTB, but annoying if it’s a cooldown and ends at 23W!

Exactly same issue for me. Cannot see anyway to solve. Has anyone had any luck with it?

I get exactly the same behaviour. I did report it to Wattbike but they don’t seem to believe me despite me giving them my configurations/devices etc. I wish either wattbike or zwift would take it seriously. It’s defo something to do with the AppleTV and how it connects as it works fine when I use my iPad. And like you trying to switch ERG mode off on the companion device also has no effect. Very frustrating when you try and do the FTP test on zwift, you get to the freeride bit and it doesn’t turn off. My guess (as a software engineer) is that it has to do with the AppleTV zwift app… so please Zwift will you fix it, thanks

Just done some more investigation. I created a test workout that had 1min erg then 1 min free ride, 1 min erg, 1 min free ride and so on.

I then tried this using

  1. iPad Pro, Samsung S10+ (companion app) and Wattbike - worked fine goes in and out of erg mode
  2. iPad Pro, iPhone 8 (companion app) and Wattbike - worked fine goes in and out of erg mode
  3. AppleTV, Samsung S10+ (companion app) and Wattbike - doesn’t work, stays in erg mode
  4. AppleTV, iPhone 8 (companion app) and Wattbike - doesn’t work, stays in erg mode

No matter how many buttons you press on the companion app, the wattbike or the AppleTV it wont come out of erg mode and let you use the gears

If it helps I;ve also tried it with the beta versions of both the AppleTV iOS and Wattbike firmware

So my theory of it being the AppleTV Zwift App holds true I believe.

Zwift could you please fix it now the users have done some simple testing for you

Thanks