Windows Bluetooth Controllable not setting Wattbikes' resistance in ERG mode

Setup: Wattbike Atom (firmware version 1.02.1), Windows 10 version 1909, connection via Bluetooth

Good: Pairing is all fine via Bluetooth to my Atom for Power Source, Cadence and Controllable.

Not Good: When using a workout in ERG mode, even though the Zwift app in windows states I am in ERG mode (by stopping to peddle I get the ERG mode temporarily deactivating and then reactivates when I start peddling again so Zwift thinks all is fine). However, there are no resistance changes while peddling. I can change gear on the Atom which I would not expect when in ERG mode.

Note, if I use the companion app instead of Bluetooth from the windows machine or even use the Android app, everything works as expected, i.e. resistance changes to keep to the power target and changing gear on the Atom has no effect.

This appears to be a bug in the Windows App for Bluetooth only and specifically for controlling the resistance.

Is this a bug? Is there a workaround or a fix? Any help will be very much appreciated.

Hi @Wayne_Robinson_PACK welcome to Zwift forums.

Just wanting a little clarification on this - are you saying that if you use the Zwift Companion app’s Bluetooth bridge to connect the Wattbike, then everthing works as it should?

Recently, another Wattbike Atom owner contacted us reporting a similar issue. The common threads beside the Wattbike are: 1) Windows10, recently patched and 2) Bluetooth connection.

This other person did some meticulous troubleshooting on his end, and provided us some valuable feedback to help the long-term resolution. He tried an ANT+ dongle for the Wattbike, and this issue didn’t occur. He also had an iPad to run the Zwift app, and on iOS - the issue doesn’t occur. If either of these workarounds are viable options for you, we suggest you try them.

On the Zwift end, the QA team has been alerted. To me, this feels like we need Wattbike’s help to resolve. I’ve heard that you can ask Wattbike to join a firmware beta group but don’t know if the current beta firmware fixes this issue over Bluetooth or not. Please report back if it does?

That is correct, if I use the Zwift companion app’s Bluetooth bridge to connect to the Wattbike, it works perfectly fine.

I didn’t used to get this problem but it is quite likely that a Windows update triggered this. It was not version 1909 that caused it because I upgraded to 1909 to see if that fixed the problem. I was at version 1903 prior to that.

I cant test with an Apple device because I don’t have access to any.

I have just tried with the Wattbike Atom beta firmware version 6.00.32 and the problem still persists.

For now I will use the companion app to act as a bridge, which is far from ideal because I have had connectivity issues using it before I used native Bluetooth, which prior to this issue has been faultless. If that becomes troublesome I will use the android app (not companion but the actual Zwift app) on my tablet which again is not as good as using my 46" TV :frowning:

If there is anything else I can do to provide more diagnostics please feel free to give me a shout.

Thanks for reporting back with more details. We appreciate you adding more information.

Today the same thing happened to me. Win 10, BLE, WattBike Atom, ERG just wasn’t ramping up as expected. I’ll try the ANT+ dongle.

Glad to know that I’m not going crazy!

Using ANT+ is not ideal as I suffer from drop outs (micro disconnects) when using ANT+

I have just got a wattbike atom and am having similar connection problems. I am running Zwift on windows 10 on a laptop with bluetooth and using the companion app on an android phone. Everything seems to be pairing but on just ride mode I am getting no feedback on gradients. When I get to an uphill I stay in the same gear, pedal the same cadence, and produce the same power, but don’t feel anything except seeing my speed drop. To go faster I have to change up the gears. Going down the resistance doesn’t drop off so if I want to ease off I have to change down the gears. From what I understand this is similar to a non smart trainer. I have tried connecting through the companion app but that seems to produce some pretty random data. Any help would be great, as I am really enjoying both Zwift and the feel of the wattbike, but climbing and descending are very counter intuitive at the moment.

Hey all,

Am curious if any of you are using an ANT+ dongle to solve this issue on the Windows machine? Please let us know which one you chose and your results.

We’ve seen many reports that using a USB cable extension to bring the dongle into a better line-of-sight with the trainer also helps.

I’ve got one coming tomorrow with an extension. I’ll let you know how it goes. I’m going to try using an ipad later to see if that works.

I have just ordered one and will try it out tomorrow. I will feedback with details and results once tested.

I have just tried a ANT+ dongle from Anself (see and the problem does not appear. I also retested with BLE both before and after testing with ANT+ and the problem still exists. So to conclude: BLE still does NOT change resistance when in ERG mode, ANT+ does change resistance when in ERG mode.

I did not use a USB extension cable, the distance between my wattbike and the windows machine is less than 2 meters and has a clear line of sight so it should have a very good ANT+ connection without the need for an active USB extension.

Would still be great to use BLE if and when the issue is resolved but ANT+ does seem to provide another working alternative.

I’ve tried my ANT+ dongle. The control problem is resolved and now hills feel like hills. However, now when I change gear there seems to be a bit of a delay, and there is no visual indication on the screen of the change or which gear you are in, so no idea when you’re about to run out of gears. More of a problem is that setting off, either at the start of your ride or if you have stopped the resistance is really high and remains so until you have picked up a fair bit of speed. Changing down makes no difference, and it happens even going downhill with trainer difficulty on minimum. Once you get going all is fine. If I swap the controllable source back to Bluetooth the gear and setting off problems are solved but back to no control.

I’m curious to know if Wayne has tried just ride and, if so what his experience is.

My dongle is a Coospo with extension from Amazon.

Good to hear that you’ve made progress. You might try uploading your log files to to look at network connectivity, ANT+ signal quality and other things that can help you troubleshoot further.

Here is where to find your log files.

@Ian_Unsworth, I cant say when trying a ‘Just Ride’ I have noticed any difference between ANT+ and BLE. Having said that, I did only try it for a short while. The issues you raise I have with ANT+ and BLE regarding a gear change delay but nothing too much. I do recall a Wattbike firmware update addressing this, maybe worth checking that you are up to date.

Regarding the gear change visual indication, I recall that is a Zwift limitation of ANT+ and yes, I do have that issue for ANT+, BLE is fine.

Hope this helps.

I have had same issue. Message exchange with Zwift wasbvery helpful. Basically it has occured following a windows update. The option I have found is to link the wattbike to the companion app and not the laptop. ON the start up screen on the computer where it links with the wattbike. If you disconnect the wattbike. Then in the top corner is a cog. Click on theis and it asks if you want to pair using the computer or the app. Click the app.
I suppose the other option is to undo the windows update which is not tricky. Hope this helps. I’ve just linked my wattbike to the companion app and ERG is working

Thanks for all the helpful suggestions. Have just had a ride that worked well, good gear connection and no starting off issues, but still no gear visuals although thus isn’t really a big issue. I ended the ride then restarted Zwift for another ride and back to feeling like I’m towing a truck uphill when I set off until I manage to get a bit of speed up. Next time I’m going to try the same but reboot the wattbike between sessions. I have tried connecting through the companion app with random data effects, but a hadn’t thought to unpair the connections first so I’ll try that as well.

I connected via the app instead of my laptop yesterday. Had a very brief 2 min test and it seemed ERG was working (have not tested the resistance and gradients). My response from Zwift was that I would have to but an ANT+ dongle. I’d suggest trying to connect via the companion app first.

Shuji, I am one of the people who had this problem like everyone else. Ant+ is fine, but I would really like to see the gear changes. Same with companion app, I don’t see the gear changes in the top left area. the only way I see them is when I use Blue tooth, but like everyone else then there is no elevation changes, up or down, if I don’t change gears my power and resistance is the same, the avatar does slow down going up and speed up on downs, but power and resistance the same with blue tooth. so I have been dealing, but would like the nice advantage of knowing the gear did changes, sometimes I think I pushed it, but not sure…so the visual would be great. thanks and by the way I love Zwift and how motivated and entertaining it is, compared to indoor trainer looking at a wall.

John, I was having the same problem as you as posted above. I now have a set up I’m happy with. I run zwift on a laptop with Ant+ dongle. I have the companion app running on my partners phone and run the wattbike hub app on my phone to show which gear I’m in. I always start a just ride on the hub before starting the zwift ride because it seems to work better. I have found that it is possible to run both apps simultaneously on the same phone and toggle between them as required but easier if you have access to two phones. Both phones are Android. Hope this helps.

Ian, sorry just seeing this. Are you able to get your wattbike to hook into 2 systems? I can only get it to either connect with Zwift or connect with wattbike hub app, but not both at the same time.

John, are you connecting through Bluetooth or ant+. I use an ant+ stick in the laptop and Bluetooth on the wattbike app. I haven’t tried Bluetooth for both on zwift, but have recently tried rgt which worked better on Bluetooth but wouldn’t let me connect to the wattbike app. I wonder if the wattbike will only connect to one device at a time on Bluetooth. Hope this helps, if it makes any sense.