Zwift App can't control my Wattbike Atom after Zwift update

Hi,

Updated my android Zwift app this morning. After that everything went south!
After the update the Zwift app can no longer control my Wattbike Atom.
When I start the app it finds and connect to the bike (bluetooth) and everything looks great. I start a workout in ergomode and starts to pedal. I can see my cadence and my corrent power output but nothing happens to the power it never retches the target watt it is the same all the time. When I start a race I can change gears so it becomes heavier but when I retches a climb or a descent nothing happen to the resistance. Everything worked like a charm before the update. I tested Wattbikes own app “Hub”. and there everything works fine.

I’m using a Huawei Mediapad M5 with android 9. I also tested with my phone, android 10, both the same problem. I did a little screen recording of the problem screen recording

1 Like

I have the exact same problem the ERG mode is completely switched off. Everything is connected but resistance isn’t adapting to the Watts for the relevant segment when ERG mode is on.

My setup is: Google Pixel 3a, Wattbike Atom and running the latest Zwift update released on the 7th February.

My wife is running the old version of Zwift and it’s running perfectly in ERG mode.

So I’m not alone then.
I have been in contact with Zwift support but nothing good have come of that yet. Only the standard bullshit answers. Have ju the latest wattbike firmware and please re-install the zwift app. Everything tested of course without success.

Worse at my end have heard zero from them and last time I had an issue I was over a small period of time contacted by 4 different people all asking for screenshot with me sending the same to them 4 times seems their CRM system has not history :joy:

I did send them some screenshots and screen recordings today. I also mentioned that there was other experience the same problem.

I have chased them as well presume there must be others having the exact same issue seriously annoying.

1 Like

Just ran Zwift via my laptop and then used the phone for the Companion App and runs smooth as silk so obviously an Android issue I would have thought.

Did you use bluetooth connection between the bike and the laptop?

Indeed Bluetooth via the laptop and worked well.

I’m sorry to say that I have the same problem on my laptop.
What version of Zwift do you have on your laptop?
I have 1.0.45663 on all units and I have the same problem on all.

That’s the exact same version I’m running Tomas that’s seriously odd. Irrespective of that the Android issue persists.

Same problem here, running BLE on a Galaxy Note 10.

Please contact Zwift support and tell them about the problem. We all need to tel them so the take it seriously.

Hi Tomas sorry have been busy but are you running Zwift via your laptop and then using / pairing with the Companion App so the Wattbike runs via the phone ? This is the setup that works sweetly for me whilst the other android issue is rumbling on.

I’m only using my android tablet running zwift. Not using companion app. Only hooked up my laptop now after the problem too test.

Hi Guys I seem to be having the same problem have you had any solution

You can add me to the list

I am having the same issue following the update, using Google pixel 4.

Hi - new to zwift, trying to use erg mode and it doesn’t seem to activate for love or money with my wattbike. I notice the suggestion of using the companion app on the phone connected with the laptop via bluetooth. Stupid question, is that the wattbike hub app or the zwift companion app that I should use, or indeed the zwift app on the phone!

Same problem here with the latest zwift update. I mainly use my phone Samsung S6 active. Luckily my MacBook air still works, and I have updated it as well.