Erg mode not working in workout mode

I had this same issue last week. Seems to be fixed now. What I tried:

  • unpaired Wahoo both kickr and controllable. Then repaired them.
  • Started a new training program. On the bottom, it says ‘Erg Mode’ with a option to turn on or off. Mine was set to ‘On’. I unticked this - then turned it on again.
    All started working again after that.

Not sure if it will work for you…or if you have tried already. But worth a shot.

I have the same problem
Erg mode doesn’t work in workout, I did a update on wahoo firmware and spin down even went to old version on wahoo, very fustrating
Using apple tv
Kickr 18

Encountering the workout erg-mode gremlins as well.

Kickr Core + iMac + iPhone companion app. Latest versions of Zwift and latest firmware for Kickr Core.

Background: When working out (and not in erg-mode) I sometimes experienced delayed feedback, sometimes substantial, between the wattage applied to the pedals and what the Zwift app registers (wattage, cadence). The best solution in my case was to register bluetooth devices via the companion app, which reduce the lag to around 1 - 2s.

Problem: When attempting to do a structured Zwift workout, there is a lag of around a minute or more between changes in target wattages and the erg-mode wattage simulated on the Kickr Core, i.e. it is completely impossible to do a workout because the the disconnect in values means the app will do things like increase the resistance even if you’re already over the target on the screen. (This happens even if the lag between pedal wattage and Zwift is minimal, so it is not bluetooth related.)

I’ve not had erg-sync problems in RGT cycling or Sufferfest, so I’m inclined to think the problem is on the Zwift end.

It’s definitely a zwift issue - erg mode with other sources don’t get these issues.

@shooj / @xflintx is there any update on this?

Putting tickets in from an end user perspective is a waste of time as no feedback comes back to the user so you have no idea if this is an issue, is being looked at or is something that zwift simply won’t fix…

To repeat your own phrase… do you hear us?

2 Likes

@xflintx according to your post this was a known issue on Aug 12th, we are now over a month down the line and no communication(sounds familiar tbf) and no fix…

The respectable/professional/competent thing to do would be to communicate an update with those pesky paying customers, even if only to say this is still being looked at… but radio silence seems to be the default comms method…

So erg mode stopped working for me yesterday via the Zwift companion app version 3.28.0

It’s important to note that

  1. If I run Zwift without the companion on my iPhone then ERG mode works.
  2. If I connect via Bluetooth to AppleTV and my trainer then ERG mode works.

ERG mode does NOT work if you connect the trainer (Wahoo Kickr) via the Zwift companion app. So I think the latest push of the companion app has a problem with ERG mode.

  • I have updated the firmware on my Wahoo kicker.
  • I have updated zwift on my Apple TV.
  • I have uninstalled and reinstalled Zwift companion.
  • I have rebooted everything and repaired everything.

Let me know if there’s a known issue with Zwift companion app version 3.28.0 and ERG mode and what the fix is. I can use Bluetooth as a workaround but took several hours of troubleshooting / updates and installs to identify where the problem was.

Does anyone else have this issue? I’m going to see if I can downgrade Zwift companion app version 3.28.0 to Zwift companion app version 3.27.0 and block auto updates as this might fix ZC. Will post back.

Cheers

Greg

1 Like

I was out of town all last week, so not ignoring you.

For the release that just went out today, we don’t have those fixes in place. I know they’re still being investigated, as they’re more complex than initially thought.

With luck, we’ll have them sorted out soon and pushed out to everyone as soon as we can.

Something something “we hear you, we promise…” Something something “Zoon ™” :wink:

2 Likes

Same for me, ERG mode stopped working mid-workout on 9/15/2021. Isn’t working today. Saris H3 hooked up to desktop via Ant+.

1 Like

Same issues here…it is definitely the companion app…Apple TV and Kickr bike…when I pair directly to the Apple TV everything works…if I go through the companion app the trainer is dead as a door nail!

1 Like

Yes I agree, when I cut out the companion app everything’s works fine but of course I lose a BT connection if I go ATV direct…….NB Using mk 2 Kickr, not possible to roll back firmware.

This problem has been going on for months now.

Apple TV, no companion app connections - Issue with ERG mode & has been for a good while.

Any chance people can stop conflating issues?

How do you suggest doing that? Does Zwift have unique bugs that we can see?

Thread title = [Erg mode not working in workout mode] So this is my exact issue and the best hit on the forum

1 Like

People (specifically couple of posts above) are making statements that is definitely this or that and post the same thing repeatedly in multiple threads like it is fact…

they don’t know this and are conflating issues which might confuse other users.

I am having the exact issue when connected to my ATV4K with the companion app and a Wahoo Kickr snap that appears to have started after the 1.17/3.28.0 update. Worked up until my ride on Sep 15. Stopped working on 15 Sep.

1 Like

I have a similar issue using ATV and a KickrSnap. Erg mode works if I use Zwift on my iPhone, but I’ve had intermittent problems when using the companion app. (I haven’t tried direct to ATV because I’d lose either heart rate or cadence.)

1 Like

I was able to resolve my problem. It turns out that for some reason the update turned off ERG mode…

I turned it back on using the following:

How do I enable ERG mode in Zwift?

You can turn ERG mode back on by bringing the bottom menu back up and tapping the ERG OFF button to enable ERG mode. Using a Computer: Press the arrow up button bring up the bottom menu and press the ERG ON button and Zwift will disable ERG mode

A few days ago, I had the same issue with ERG mode being off, and simply turning it on worked. But I’ve had erg problems since then that I could not fix so easily. And today I had problems just riding in regular mode. I felt very little resistance and couldn’t generate enough watts to keep up with the “D” bot. I tried to calibrate twice, which required massive effort to hit 23 mph, but the calibrations failed. I was using Kicker Snap, ATV, and the companion app. Ultimately, after a few attempts to restart after unplugging the trainer and forced exits of the programs, I gave up on Zwift and did an erg workout using the wahoo app.

I now have the same issue in that irrespective of whether you are paired via Bluetooth or ZC erg mode doesn’t modulate the trainer. In my case I felt no resistance in the pedals. The wahoo app shows the trainer is fine.

Are you connecting bluetooth to the Apple TV? I switched over to connecting directly to Zwift via BT on my iPad as a test and ERG worked fine.

Haven’t tested BT directly to the ATV…