Erg mode not working in workout mode

Yep. Direct to Apple TV. Zwift on iPhone works but the screen is too small.

Can you run zwift on iPad for the ERG and Apple TV for display?

Possibly via airplay.

Same here, Apple TV 4K , erg mode on workout ( custom workout) the cadence not reading correctly nor the wattage. Couldn’t leave the easier gear and start going down to zero . Cannot turn off the erg mode as it becomes worst. When trying a new ride closing off Zwift and launching it again the erg mode still on on free ride ???

1 Like

I’m having the same issues, basically in erg mode and out never had these many problems before. It’s either no resistance too much resistance. I have now tried twice to complete a ZA workout but it’s impossible. I’m running Apple 4K and wahoo kikr core both of which are fully updated.

1 Like

I started having these problems last week after updating my kickr on the wahoo app. I’m currently on wahoo v4.2.3 and 1.17.0 on Mac. Erg is turned on in app but doesn’t do anything in my workouts.

1 Like

Tried via airplay from phone to AppleTV - works but the graphics are awful…

Odd, I tried mine with iPhone as well (also 1.17.0) and same issue. Erg mode works fine through the wahoo app however.

Hi there - I have the same problem here. Kickr Core, Apple TV and Companion App.
All up to date (problem started at last update).
It’s pretty much impossible to do a workout as it stands as the power is up and down.
Works OK in Wahoo App.
Works OK with Zwift on phone.
Does not work with Apple TV / Companion app.

Okay so here is what I had to do in order to use Zwift again as it was impossible to enjoy any form of riding within the app.
I’m lucky I have a friend who is knowledgeable with tech. I had combinations of the wahoo app on phone and Zwift on Apple TV. He deleted kikr off wahoo, deleted the Zwift app and companion app reinstalled this seems to work (fingers crossed) I also found out that Apple BLE can be a bit sensitive so I put my phone in aeroplane mode. I also now run an antsig cat 6 cable from my modem direct to the back of Apple TV to ensure there’s no lag or issues with receptivity of internet. In future unless I have no other choice I’m not going to update. It seems like we who are using Apple TV for Zwift are being left to fend for ourselves it would be nice to have someone from Zwift/wahoo investigate.
Hope this helps

Here’s some photo documentation for you: also please see thread which states issues. If you look on my Zwift account you can also see I have logged the two times attempted to complete a ZA workout and attempts to check resistance to gradient. I hope this helps to resolve everyone’s problems.






I have this also with wahoo kickr bike, zwift companion app, Apple tv 4k (all updated). I just did a wahoo app workout in erg mode and it works perfectly well. It seems zwift has forgotton about us.
Simon

Thanks for everyone’s comments. My ERG was not working correctly with Zwift. I thought this was a Wahoo issue (have the Kickr Core) but per notes above, I used the Zwift app on my iPhone and not my iPad and it worked perfectly. This is not ideal as the screen is so small but will have to use until Zwift software can resolve.

For ATV users that need the extra Bluetooth connection to get both heart rate and cadence, one option to consider is the NPE CABLE. It combines signals from several ANT+ devices into a single Bluetooth signal. I bought one last time I had problems with the companion app, and I’m using it again now. Of course, it’s an added cost, so using airplay is the more economical solution.

Elite Direto XR, Zwift on PC, Companion on Samsung S20.
I can’t find the ERG on/off toggle in the Companion app/work out mode? It used to be next to the bias +/- control.
The ERG doesn’t seem to work at all, very frustrating.

Edit, I can’t find any ERG button on the bottom menu either only 2 pairs of up/down arrows.

Reply to myself. Paired the trainer again and the ERG mode is working again.
I wish there was an ERG mode test to be done at the pairing prompt. The only way (that I know) now is to start a workout pause and re-pair it.

1 Like

Any news on whether this issue is improved with the new Wahoo 1.1.3 firmware update?

I do not have the issue any more. I am not sure whether the updates are pushed or not. Will post back the version of wahoo kickr firmware; companion; Zwift client and Apple TV I am doing presently.

I also had this issue with ERG mode yesterday: Kickr Core, Zwift for Mac, Companion app on iPhone.

When I connected Kickr Core directly to Mac, then ERG mode was working. But in this case I experience connection drop-outs, which in turn don’t happen when connected through Companion app.