ERG Mode issues w/ Saris H3

6 posts were split to a new topic: Tacx ERG mode not working on iOS

Hi - ERG mode has stopped working completely for me with my H3. I have updated the firmware and calibrated via the Saris App. I’ve tried ANT+ and Bluetooth. I’m using Mac OS 10.13.6
I am beginning to think my H3 is faulty. Anyone got any tips?

Hi @James_Picking1

When you use ANT+ doe you connect as ANT+ FE-C for both power and controllable?

Hi Gerrie

Yes.

I just tried the old trick of turning it off waiting 10 secs and on again (after the firmware update).

It started working after that … ERG hadn’t been working on the Saris App either, but now is. So I am hoping that’s sorted it.

Thanks for checking in

James

An update: Unfortunately the problem has returned. Twice tonight. I have to conclude the unit is faulty. Shame. I was just getting into Zwift and really enjoying it.

Sorry to hijack the post, but I’ve got exactly the same problem albeit with a Saris M2 Trainer… are these linked or is this a separate issue?

Essentially ERG Mode does not work correctly and there is no resistance change when riding in sim mode when cycling ‘up hill’

Running latest firmware on Saris, calibrated through Saris app, connected via Bluetooth to IOS on iPad.

Any help would be greatly appreciated.

Tom.

My wife is having ERG mode issues with a Saris H3 similar to the post here. In the menu ERG is selected but when the workout starts the trainer does not adjust resistance. So the workout must be ended then when she selects the same workout again it works fine. Very odd. ATV and H3 connected through ATV bluetooth. Only other device is wahoo tickr. No companion app used. Anyone else experience this?

One thing that can happen if you pedal to slow and the trainer can’t meet the watt requirement it will turn off ERG and only turn it back on in the next block or when the pedaling speed pick up.

Similar problems here. Using a Saris H3, latest firmware, and an iPad running the last version of Zwift.

Last night I started a freeride up the Alpe, so SIM mode. The resistance of the gradient didn’t kick in until after turn 1.
I then started a short workout in ERG mode, and couldn’t hit the target watts because of this massive delay.
The trainer doesn’t respond to changes in resistance fast enough. Doing intervals is impossible like this.

Reading through the forums I see a lot of people having similar problems for quite some time now, but no solution so far. Can we get some support on this?

Hi @Dirk welcome to Zwift forums.

Shuji at Zwift HQ here. Looking at your session logs on our server, I see some instances where you have multiple simultaneous logins. This will cause the symptom you’re describing.

End your Zwift session either by 1) saving & uploading ones you want to keep or 2) trashcanning ones you don’t. Swiping the app into the background isn’t the same thing as logging out.

1 Like

Hi @shooj and thanks for your reply! I’m unaware of multiple sessions, but I’ll try your suggestion next time when I’m on the trainer. Too hot here to be cycling indoors now :wink: will let you know if it helps, thanks!

@shooj I am having a terrible time hitting workouts in ERG on the H3. I’m using an Apple TV. Power goes way above and the down. I’ve never had this problem with my 2017 wahoo kicker. Everything is up to date. I calibrate through Roovey and the saris app. I tried to calibrate via Zwift once and nearly killed myself due to the amount of time it was taking to calibrate. I just quit and did my workout in the Xert workout player. Any idea on when this will be fixed? I understand you can’t give a dead line but this is rather frustrating. I my as well stop my Zwift subscription and do my workout win the Xert workout play or sell my brand new H3 for the new wahoo.

1 Like

Hi all. Sorry for my English. I had just bought a Saris H3 and when I ride on “normal” ride there is no problème. When I try workout, with erg mode on, there is no response on Apple TV. But it appears on my devices menu… I really don’t understand.

thank you for your help

Hi all - adding to this thread, I encountered a similar (but perhaps not the same) issue today.
I’m using a Saris H3 connected via BT to my Macbook running the latest Zwift release (1.0.58982). I also have the companion app running on my iPhone. The Saris is new equipment for me as of this week, so I don’t have any historical experience to compare it to.

I’ve done a few structured workouts this week without problems but today erg mode frequently failed to adjust according to the workout settings. I tried switching to incline mode but that was unresponsive. It would occasionally correct itself and then cut out again a few minutes later. After the workout completed and I continued in Sim mode, the trainer behaved as if it was still in erg mode and did not adjust to the gradient of the route.

Not sure if this is indicative of a one-time issue or a deeper problem. I’ll follow up if it continues to happen.

Same issues, working in ERG mode with saris h3. I udpated everything, try to calibrate, i was never able to run at the right watt.

I’m having the same issues as the previous two posters. Had the H3 for over a year and no problems until recently. Running current version of Zwift on a MacBook w. Catalina, up to date firmware on the trainer, companion on an iPhone. Losing ERG mode/wattage calibration mid workout. Have tried recalibrating with both the Saris app and Zwift when the trainer is both cold and warmed up. Help!

Hello, I have a Saris H3 and am using the latest Zwift app with a new iPad, connected via Bluetooth. My issue sounds similar to the above user issues. ERG mode continuously cuts out and at points, the trainer tries to catch itself up by adding too much or too little resistance so then it is not following the workout correctly. I have calibrated with the Saris app multiple times. This is my first trainer and first time training on Zwift so I am hopeful that it’s a quick fix so I can enjoy the experience! Looking forward to any help.

Same issue here with Macbook Pro and Saris H3 over Bluetooth, super frustrating.

Wanted to share my experience with a weird waffling resistance in ERG mode on my H3.

I solved it by uninstalling the Garmin Connect app on my smartphone. When I was pairing my trainer via Bluetooth to the Zwift app running on Windows, somehow the GC app on my Android was interfering with the BLE signal.

Once I uninstalled it - ERG worked correctly, and the random BLE drops from the H3 went away.

This is not to smear Garmin in any way - I suspect that other fitness apps (Wahoo / Saris’s own utility, etc) running on a smartphone stay active even when backgrounded, and seek out a Bluetooth signal to bond to.

If you want to troubleshoot this theory for yourself, I’d recommend uninstalling rather than just closing the app, because “closing” may not terminate the app.

I’m Mac/iOS here and I have the Connect app on my iPhone. Before I uninstall the Garmin app from my phone, I’m wondering if any of the other posters here have a similar config and use the Garmin Connect as well?