Effort on downhills Saris H3

Zwift newbie here and I have a question about downhills. I searched the forum but didn’t quite find an answer. Apologies if my search skills failed me.

On a recent downhill of -8%, I had to put out quite a bit of power to turn the pedals (like 125% of FTP). I expected there to be no resistance at all (or just a tiny bit?).

Is this expected? Thanks in advance for tips.

Hi @Seth_Mason7326, welcome to the forums.

No you shouldn’t have that much resistance on a downhill. What is your setup, trainer, device, etc… were you doing a free ride or a workout in ERG mode?

Hi @Mike_Rowe_PBR. Thanks for the reply.

I have a Saris H3 (with latest firmware) with Zwift running on an AppleTV. Was doing a group ride this morning when I found myself standing to pedal on the downhill.

@Gerrie_Delport has a H3 too, maybe he has an idea why this happened. Looks like you were doing a ToW stage heading down the volcano, is this when it happened?

Yeah, if you look at my power file, you can see the huge jump in power when I was on the other side of the climb.

Trust me, I didn’t want to put out that much power at that point in time.

Few things,

Are you pairing as ANT+ Fe-C for both controller and Powersource.

Set your trainer difficulty to 50%.

He is on ATV so only bluetooth available

Good point Mike,

O not, i missed that, no FE-C on Bluetooth. So Ignore that one.

I was on my bike when writing that. :sunglasses:

I’m on a Saris H3 on Android now and started having the same problem after the update. App does not control the trainer at all. Everything is connected in blue at start up.

1 Like

Also had the same issue with Saris H3 using Samsung S5e Android tablet: constant resistance, just go slower on the hills and faster on the descents, but that’s it. I wonder if the April Fool prank included stuff like this? Today was the first time it ever happened. Restarted tablet, unplugged/plugged trainer, even uninstalled and reinstalled Zwift - all to no avail…maybe tomorrow everything will work again.

Of note: apparently flashing blue on the Saris means “Bluetooth device connected but not controlling trainer,” which suggests to me the problem is with the app, not the trainer…

2 Likes

Saris h3, same here, have been on Rouvy and works fine. Failed after loading last Zwift update so definitely problem with game app. Have notified support but no reply. Pleased that I am not only one getting problems,come on zwift sort it out or you’ll lose clients to other platforms.

2 Likes

Please check your firmware.
https://www.saris.com/support/firmware

All up-to-date and calibrated in Saris and Rouvy. Still not working - works in Rouvy.

Thanks @Kevin_Tomlinson

Can you post your paring screen.

I use Windows and Ant+ so I did not test Bluetooth. I may test some things using my Android phone.

Hi, I use Pixel 2XL running android 10. Connect via bluetooth. Wil send a copy of pairing screen but interestingly I do not get the spanner icon appearing to do a calibration on Zwift.

1 Like

I didn’t even think about the possibility of this being an Aprils Fool’s prank. That’s especially cruel if it is.

1 Like

No it is no joke.

So Gerrie is someone looking at this and how long do you think it’s going to take to get a fix?

Not a joke. Resistance still not changing. Bug in the app. Fly in the ointment. Also when I tab “Settings” in-ride the banner at the top says “PAUSED.” Flashing blue on trainer. App isn’t sending a signal. I’m switching over to Rouvy now.