Effort on downhills Saris H3

Same issue here. Using Android with my Saris H3, latest firmware. Tried a workout tonight and the normal ramp up starts at 65watts, however a normal cadence was showing triple watts. Tried on a climb as well no change in resistance by elevation. Verified through the Saris app that it wasn’t an issue with the trainer itself.

Let me know any info I can provide to help resolve this quickly.

Josh C.

1 Like

They are looking into the Bluetooth issue.

But note you can still use the trainer, even if it is not controllable.

The trainer will act like a fluid trainer with a power meter, with the same accuracy as before.


Thanks Gerrie. I’ve been having similar problems past two or three days. Saris H3, Samsung Galaxy 10e. Blinking blue light. Everything connects but no change in resistance on hills.

That’s not what we are paying for!

1 Like

I agree @Kevin_Tomlinson.

That is just a workaround until there is a fix.

That is how hundreds of people used Zwift in the beginning, with fluid trainers an powertap wheels.

1 Like

Do you have any idea when the problem will be resolved? Are your techies looking at the problem now? How high on your list of priorities is it?

Zwift did not give a time line, you know it may be just one line of code that need to be fixed or a whole library that need to be rewritten. Sorry I wish I could give you more info, also I am a site admin (wayfinder) no a Zwift emploiee. Just a happy Zwifter.

And I have a H3 and it is awesome.

Here is some more info on the H3 when it is not controllable.

From the Saris website.
The H3 in Headless mode (powered on, not paired to any apps) lets you ride with a progressive resistance curve that matches the Fluid2.

Any updates on this? I’ve contacted Zwift a few days ago and received no response.

I also contacted Zwift with no response. Don’t know if the bug’s been fixed yet - been riding outside. Anyone know?

quite new to Zwift, I’m having the same problem, no resistance control on the trainer, while it works flawlessy on Rouvy.
This morning was even more weird, tried to do a short FTP test but in the middle of the 20’ test suddenly the power display on zwift goes to 0 and the test stops, while I am still working hard on the pedals. Checked paring, seems ok, started back to pedal and it went for maybe 20 seconds more and then back to 0 watts.

I gave up and switched to Rouvy for now, waiting for the bug to get fixed.

While I was on trial, the trainer did work perfectly, now that I subscribed, it stopped…

I have the same problem. Flash blue light, no controlable. I need fast support !! :smiley::smiley::smiley:

1 Like

@Seth_Mason7326 @Roger_Long @Kevin_Tomlinson @Josh_Connor @Andrew_Scott2 @Alessandro_Praduroux @Mathieu_MARCEAU and others reading along:

Our QA team has been informed, and they are working on it. My Zwift HQ colleagues are all working from home, so we need more time than usual to perform bug testing. We appreciate your patience, and will get back to you as soon as we can.

Do you have more info ? Update is done but i have not controlable. 15 days without controlable !!

This is getting stupid now. 2 app updates since this problem started and still not fixed. Gonna have to cancel subscription til it gets fixed and just use Rouvy that controls the trainer perfectly.

Just rode today, and resistance still not changing. This has been ongoing since at least 4/1. I don’t understand why this isn’t fixed yet. I would think a bug like this would get high priority. I work from home too, and my work team hasn’t been less productive because of it, at least not after the first couple weeks of getting used to it.

??? 24 days ???

We’re working on it still.


My wife and I both have the H3 and she has been having this issue. The problem makes racing and group rides really challenging. Last night she was in granny gear putting out 250 watts on a decline. Then her avatar just stopped while she was still pedaling. My other question is does this problem effect erg mode? Her workouts have been extremely hard at watts that she can normally ride.

1 Like

Continuing the discussion from Effort on downhills Saris H3:

I just bought an H3 and am running into the same issue while using my samsung S9+. It feels like erg mode is active while free riding. Just upgraded from the H2 which
had no issues. Hoping this is resolved very soon! Thank you Zwift support!

Hi @Joe_Petrilli

Can you provide more information on your setup? What device and how you connect to the trainer?