ERG Mode issues w/ Saris H3

First attempt to do a workout in ERG mode on my H3. When the w/kg went to 400, there was no way to continue pedaling-resistance was waaaayy too high. I must be doing something wrong. Anyone else with this issue?

Calibrated last night, firmware update, too.

I know someone with an H3 who might be able to help you @Gerrie_Delport

1 Like

Hi Chris, welcome to the cool kids table LOL

I assume you wanted to say 400w (400w/kg will be impossible even for a pro)

  1. check that your ftp is correct, if your ftp in zwift is to high you wont be able to do the workouts in ERG more, the workouts is based on your FTP.

  2. pick a gear somewhere in the middle of your range. I use my 48 ring in front and middle of my cassette

  3. You need to speed up a bit before you hit the 400w block. The H3 will give you a a bit of time to up your leg speed. they call it the spiral of death when your trainer increase the resistance and you cant tick the pedals over.

  4. Look at the post from Zwiftinsider and the video from Shane: https://zwiftinsider.com/erg-mode-in-zwift/

Let me know if you need more info. DC rainmaker tested almost all the smart trainers and he found the H3 to be the best for ERG.

1 Like

Hi all,

Is anyone here using their trainer on an ANDROID Device using BLUETOOTH?
The ERG mode is just not working…

My setup:
Trainer: Saris Hammer 3 (Hammer 21887)
Firmware version: 31.062
PnP ID: 02-BB-22-14-00-41-01
Software Version: 37.013 | 009b | 0001
Setup: Trainer connected to ZWIFT , on an ANDROID device using BLUETOOTH .

Problem: the ERG mode doesn’t work . Trainer appears as a “controllable” device and “ERG ON” is on the screen, but trainer behaves like a “stupid trainer”.

I have tried following, and the problem persists:

  • Trying various Android devices (phones, tablets) by various manufacturers
  • Updating firmware on all of my devices
  • Clearing cache, data of Bluetooth application
  • Disabling all possible battery optimizations

I have also tried:

  • Installing different applications on SAME android devices (trainerroad, etc) – ERG works fine
  • Installing Zwift on a PC and using SAME android device as a bridge (Zwift Companion App) – ERG works fine
  • Connecting a different trainer (Tacx NEO) to SAME Android devices and trying ZWIFT – ERG works fine.

I have really tried everything and narrowed it down. It seems that the problem is indeed in the SarisH3-Android-BT-ZWIFT combination.

Could anyone please help?

Cheers.

I am having the same problems as you. Any solution yet?

No, but I have posted this to a “Saris Owners Group” on Facebook and another guy managed to reproduce it (Samsung Android device)
I also went to the local shop that had an H3 demo unit and tried with my phone (Huawei) - same thing.
I even asked the guy working in store to try it with his phone (OnePlus) - same thing.

Seems like a persistent bug… I’ve written to the Saris support as well, let’s see…

@Chris_Cronin_ZZRC @Artyom_Romanov @Jeremy_Andres

Our QA team has been informed, and they are working on it. My Zwift HQ colleagues are all working from home, so we need more time than usual to perform bug testing. We appreciate your patience, and will get back to you as soon as we can.

We have same problem. Definitely happened in the March 27th update. Gonna try Rouvvy and Trainer road to see how we like it because zwift is useless right now.

I have the same issue. There is another post about it.

Continuing the discussion from ERG Mode issues w/ Saris H3:

A new patch was downloaded to my Zwift today. The patch still did not fix my issue with the correct resistance when cycling. With the issue not being resolved with the latest patch I am regretfully cancelling my account at this time. I simply dont want to pay for something that doesnt work to it full potential.

I have only calibrated mine with the Saris app and it seems to be working fine on Zwift. I have given up on trying to get it calibrated on Zwift specifically.

@shooj

Any update? Still not working. Surely this is important enough to get fixed, it is a popular trainer. Works fine via laptop but android gives no resistance (even though it pairs)

1 Like

So you have an android device which is providing proper resistance on zwift?

1 Like

hi,
We have tried multiple android devices and also more than one H3 unit. Android+BLE+Zwift+H3 does not work.
I am currently in contact with Zwift (opened a support ticket).
so far, as per their recommendations, I have:

  • tried calibrating via Rouvy app (still doesn’t work)
  • tried calibrating via Saris app (still doesn’t work)

I am waiting for more responses from their side.

1 Like

This problem started with the 3/27 update. It is for sure a Zwift issue as trainer works properly when using Rouvy or any other app on phone. Only Zwift has the problem.

Hi Frank

@shooj confirmed further up in this thread that they are working on it.

I have done only open riding on Zwift on a Hammer H3 via the Android Zwift App. My experience so far, suggests the watts, cadence, and speed seem to be comparable to a real ride. Good news. However, I find that down shifting is strangely completely unnecessary when climbing. As the incline increases, the speed goes down, but the resistance doesn’t change significantly, so there is no need to down shift. Is this normal? Or have I screwed up a setting?

Edit - Interestingly, this was moved to an ERG thread, and I’ve not used that mode (at least not on purpose) nor referenced it in my post.

Terry, it’s a linked issue. Basically, zwift can’t control the resistance of the trainer whether for ERG reasons or to mimic hills via resistance. It’s a software bug and will hopefully be sorted soon.

2 Likes

Thank you.

Given the current circumstances, I sure hope it is fixed soon.