ERG Mode issues w/ Saris H3

Thank you @shooj for the potential solution. I do have the Garmin Connect on my iPhone, and I wear my Garmin smartwatch while I ride. I don’t attempt to sync the two during workouts, but it’s possible that they’re attempting communication anyway.

I’m reluctant to delete Garmin Connect, as I use it daily to sync workouts from my watch. I’ve been using Zwift less lately in favor of other apps (where I have not encountered any problems), but it’s good to have this solution in mind if the need arises.

I have the same issue, ERG doesn’t work at all. I’m using Zwift on my MacBook Pro 15 inch running on the latest version of Big Sur. I’m using a Garmin Watch to broadcast my heart rate.

I tried to turn off Bluetooth on my iPhone where I’m using the compagnion app but same issue so I don’t think it’s related to Garmin Connect. I still tried to uninstall the Garmin Connect App but nothing changed. I turned off my Garmin watch, turned off every Bluetooth device I have other then the trainer and my laptop. I calibrate the trainer multiple time. Still had the issue. Restarting my laptop seems to improve and reduce the delay.

I can confirm it’s a sync issue, Zwift has a huge delay when it try to change the power.

Running my workout on the Zwift iPhone App seems to be better.

I’m available to diagnostic the issue, I’m in tech so can help debugging if the Zwift team need someone.

The issue is annoying, I just bought this trainer and never had issue before when I was using the Tacx Neo 2. I really think it’s a issue between Zwift and Saris H3.

Also if you try to calibrate the trainer via Zwift, it doesn’t work with the latest Firewire in the trainer.

Willing to help if I can.


1 Like

Please for the love of all that is holy. I’ve been dealing with this since the March 23 update in 2020. I’m fairly tech savvy and nothing has worked. I confirmed tonight this is a Zwift / Saris issue.

I diagnosed the Bluetooth communication and saw a bunch of error payload. I decided to buy a small ANT+ chip to plug in my laptop and did a training. Everything works A1.

I really think it’s a problem with the Bluetooth communication between Saris and Zwift.

Now I’m not sure why some device work some doesn’t, maybe something with Bluetooth chips?

If you have an ANT+ dongle at home try with it.


1 Like

Thank You! I think I am going to try this route. I’m using the ATV and have like the convenience of it, but I do have an old laptop that I am considering making my designated Zwift setup. At this point, I don’t have anything to lose. :slight_smile:

Can you report back on whether this works? I’m close to giving up on Zwift now. My £900 trainer has become a glorified door stopper.

@shooj Let me know if I can do anything else to help your team with the issue. Zwift is even more important during the pandemic and it’s super frustrating to have to deal with this. The ANT+ dongle seems to fix the issue but I’m curious to know if this also fixed the issue for other folks.

So today I turned off BT on my iPhone and started up Zwift on my Mac. Power on ERG mode was still all over the place. After about 5-10 mins I quit Zwift and pulled up the Saris calibration app on my phone. Recalibrated the H3 with the Saris app, turned BT off on the phone (again) and restarted Zwift on the Mac. Everything seemed to be working much better that the last few weeks. Fingers crossed but I may give Alexandre’s ANT+ option a try.

I just got the H3 trainer last week. It has ERG issues in Bluetooth as well as ANT+. I have tried to calibrate it using the app and Zwift. Always after 10 minutes of warmup. Tonight I did the same workout I did last week on my original Kickr and was so frustrated with the ERG mode and power fluctuating I just quit. I do have the Garmin Connect app and watch but I am connecting straight to my windows laptop

So… here is my report out: (I didn’t get to ride until 10 pm last night!)

Here is my (previous) setup that was an issue:

  • ATV
  • Saris H3
  • Companion (ALL 3 trainer connections running through companion. cadence etc)
  • Garmin BT HR monitor (bluetooth connected via companion during setup of workout)
  • Apple Watch (NOT using it for ANY connections during the workout)
  • multiple calibrations via Rouvy and Saris app

What I tried last night:

  • ATV - Connected my 3 Saris connections via bluetooth (NOT companion) to my ATV.
  • Garmin BT HR monitor - connected via Companion AFTER the workout started
  • Apple watch - left it upstairs “just in case” it was doing something in the background I was unaware of.

To no avail. I still had the issues. BUT… I do have good news. Time will tell how long this fix works because others have done the same and it seems the issues come back

  • I deleted the Zoom app from my ATV.
  • I recalibrated my trainer via the Saris app.
  • I reinstalled the Zoom app to my ATV
  • I connected my Saris directly to the ATV via bluetooth.(NOT companion)
  • I did NOT put my Garmin HR monitor back on and did not connect to try to limit connections during this test.

It worked! My trainer had the appropriate reaction to inclines and downhills. I’m going to try again tonight to see if the fix holds and NOT put on my HR monitor at first. After a good 1/2 hour I’m going to put on the HR monitor to see if I notice any issues.

Wish me (all of us, frankly) luck!

Oh… I should add that I am still waiting on my ANT+ to be delivered. If I have issues again (crossing fingers I don’t) my next test will be via ANT and my old super powered laptop.

Update two:

No problems tonight!!! I about fell over. I even wore my heart rate monitor and Apple Watch.

See my previous post on my current setup. It involved removing and reinstalled the Zwift app on my ATV.

Crossing fingers.

I responded on a similar thread about these issues. Sadly…the issue returned last night. Sigh.

My ANT+ was delivered so gave it a go tonight.

And…It worked perfectly. In fact,the ride was better than it has been in months. No crazy sudden changes at all. ie: 0% felt consistently the same at all times the entire hour and 1/2.

ALL connections via ANT+. (Saris and Garmin HR) running Zwift on a PC. Once in game, I opened and used the companion app for ride ons etc.

I have to conclude after exhaustive testing (and reading others’ tests) that the issue is the communication of the BT with ATV. (No matter how you connect). There has to be some code Zwift wrote for the ATV blue tooth that doesn’t quite work for Saris.

Now I wait and hope I’ve found the issue.

I am having the same issue with Zwift and Saris H3, trainer works fine in Rouvy. Going to try RGT app and see if it repeats there. Also, looks like I need to try ANT+ instead of bluetooth. Hmmm

Hi all

I have been having similar problems with my Saris H3 for a while when connected with Bluetooth. Yesterday ERG would increase and decrease the resistance massively and all of a sudden even with me keeping the same cadence and I was in the middle of a 30 mins training block.

The ERG On/Off button was unresponsive on the Companion App and the Desktop application for Mac. Once the workout was finished, the trainer remained stuck in ERG mode.

I would like to know if this an issue that can be solved by switching fully to ANT+ or if there is a known bug being looked at from Zwift regarding this?


I have switched to ANT+ and it is working perfectly. All issues are gone.

I’ve also switched to ANT+ dongle and everything seems working fine after one ride.

I’m so glad I found this forum. I have been using the Saris H3 with Zwift on my iPad for half a year and these ERG issues are SO INSANELY FRUSTRATING!!!

I’m about ready to give up my Zwift membership.

What ANT+ dongle do you recommend? I’m in Canada.

Just purchased a H3 calibrated on app and then calibrated on zwift. The out puts look nothing I used to get on my tacx trainer. No apple TV being used just straight Bluetooth to a Windows laptop, so I need to calibrate it to via another app first. Also which “trainer” should I select? When zwift connects it brings up "Hammer"and the Saris FE its really frustrating having trained hard over the winter I spent cash on a direct drive and I’ve seemingly gone backwards :cry:

Hi Chris, I have been using the same setup as you for more than a year and everything worked perfectly. Last week, I did an update of the iPad and the problems started. After some time in the workout, everything stops working. Zwift says that the H3 is connected but also that there is no signal. Yesterday, I found out that there was an new version of Zwift so I installed it but it didn’t solve anything.This ANT+ dongle, what is it exactly? Something you have to plug in the iPad?

Thanks for reading me :wink: