Companion App - still no mini map

Reported 12 months ago and still not working despite regular followups with your Support team … mini-map doesnt appear unless using a hack (go to exit ride). Keeps disappearing if you swap CA screens during ride (msgs, workout screen, zwifters etc)

Would be really cool if you folks fixed this

Here is my hack: go to “Zwifters”, pick one at random, and give him/her a “Ride On!”.

Go back to the map - it should be there.

Nope. Have to go and exit ride to get it back. But thanks @B_CN

@_Dean
A little more context please:

  • Does the map appear at some point during a ride?
  • Does this happen every single ride, or does it work sometimes?
  • Do you have other weirdness during a ride, such as other avatars appearing out of nowhere, or other avatars right next to you vanishing?

I’m asking because I’m looking at several of your partial log files on our server. What I’m noticing is that a good half of them indicate network errors. That could mean WiFi dropouts at your house, or interruptions upstream with your ISP.

Reliable WiFi is critical for Zwift Companion app to communicate with the computer running the game app.



You can check this for yourself by locating your log files and uploading them one at a time to zwiftalizer.com. Here’s how to locate your log files.

Here are some measures you can take to improve WiFi performance. If you’re a tech savvy type, I’d recommend logging into to your router to change what channel your WiFi signal broadcasts on.

2 Likes

@shooj - thanks!

Full context and details have already been provided to Zwift support several times.

  • Minimap only appears if you go to stop the ride and and bring up the screen to Save/Abandon ride (and then exit that screen - on the CA not the PC).
  • occurs for every ride. Started happening this time last year after an upgrade to the CA and I reported it to Support but had never happened prior in the prior 12 months
  • all other CA functions work fine
  • swapping screens during rides all works and minimap stays visible approx 50% of time
  • no other weirdness apart from a couple of one-offs in past 12 months that havent re-occurred.
  • problem follows the phone, irrespective of what Zwift I computer I use
  • I have used from my work which uses NZ’s fastest research network to access global internet and same problem
  • I have swapped computers, swapped wifi, I have used other people’s computers - the problem still follows the phone
  • logs are clean (or at least not showing anything other than startup congestion)
  • Zwift support acknowledged the problem and said the bug was in the queue to be addressed but couldnt commit to a timeframe - so they know its a bug and not my wifi??
  • others have reported same issue in the past (not many though)

Happy to send a bunch of log files again.

Cheers

I love zwift!
It us incredible but…
use a big tv with my zwift.
I would love if when I click the “Eye “ icon I could toggle between all the perspectives, and also included there a satellite view of all watopia so I can see where I am in the watopia map clearly.
For now I ride completely geographically lost.
The view “ eye “ icon could display more use-full info, also were can I see my average Watts and wats per kilo??

Have you tried using the CA with the cellular turned off on your phone? Sometimes the cellular and WiFi signals compete with each other for the internet connection, and if the phone is not on the same network as you are running Zwift that might be causing your issue.

No SIM card installed @Nigel_Tufnel

Yup, its on the same network.

If you run a cycling computer at the same time you could see this data constantly. If you want it occasionally, click end ride and in the summary page you’ll get average power, there might be a third party app or website that does it too but from zwift itself you can’t see this data continuously while riding.

Here is my rendition of (similar?) issue:

I then go to “Zwifters”, select someone, and then go back to “Map”:

This has been going for a long time now (maybe even years).

No, I don’t have WiFi issues. Everything is fully updated. No OneDrive around. etc. All the usual disclaimers apply.

Just another Zwift bug.

Have you tried to factory reset your phone?

No. Why would I?

I know it is customary to format/reinstall windows/zwfit for every bug… this is beyond ridicules.

We should really stop placing blame on the client’s machine/phone/wifi/whatever, and face reality: this is another one of Zwift’s bugs. Sigh…

2 Likes

@Gerrie_Delport - I have factory reset phone, side-loaded with custom rom to provide clean Android (without manufacturer add-ons etc).

This has been an issue on my now ancient tablet running Android 5.1 (I’ve always assumed this may be the cause). There has been no map visible when I launch the App for the last 2 years, best guess.
Selecting a rider from the Zwifters tab does make the map visible.
The tablet runs on WiFi only.

Note: a modern version of Android and iOS on 2 phones connected to the same network have no issues.

1 Like

My impression likewise this is related to old Android version used. A bug.

1 Like

is there a chance the map just isnt centred on you? have you tried pressing the icon below the +/- symbol - this re-centres the map over you, it shouldn’t be there unless the map has moved off you, which is why it is not there on the pictures where you are on the map

@Chris_Holton The map is not there and hitting that button does nothing until the map is back (via the hacks described above), then it functions as normal.

If you are using a mac or PC then you can use the zwifthacks map https://zwifthacks.com/zwiftmap/

1 Like

Ah, that’s a shame, thought it might be worth a try

1 Like

Is it ONLY THIS phone or have you tried other devices running CA?