Coffee Stop unavailable [1.59] [Jan 2024]

still waiting for update…

I feel I’m still having issue. It happens if I switch route (pacer, registered event) Any route after the original one, no coffee

I just did The Big Spin Stage 1, B route. Coffee stop icon greyed out for the whole ride, even though I saw several people around me using it.

Apple TV 1.60 and Android Companion.

Someone using coffee stop 13 minutes into a group ride this morning

Consider the time constraints for coffee break:
Available at the beginning of your ride (30s Break in the first 5min of your ride) and a 3min break every 30minutes during the rest of the ride.

Does your screenshot not come from roughly 10mins into your ride?

Yes, so I should have had a 3-minute break available at that point. The button was greyed out for the whole ride (I kept checking), and I even tried pressing it when it was grey and others were taking coffee stops, just in case the button was grey but it still worked - it didn’t.

The “every 30 minutes” thing doesn’t mean that you can’t take a stop until after 30 minutes of the ride. It means that once you do take a coffee stop then you have to wait 30 minutes for another one. At least, that’s how it’s supposed to work.

It’s not working properly for everyone after the recent “fix”.

I’ve “fixed” non-available (when they should be) coffee stops by closing and re-opening the Companion App. Always worth a try.

1 Like

I’m pretty sure that it shouldn’t be available during the initial 30 minutes (other than the first 5 minutes where you get the 30 second coffee stop). So you need to wait until after the first 30 minutes before it will be available. Unless something changed from when it was initially rolled out, that is how it was intended to work.

I routinely see it used at around 18 minutes into a ride. I’ve never seen it available myself at that time, but it’s a common thing. I think it’s just a little buggy.

I don’t do a lot of group rides, so not sure how it is supposed to work anymore? I didn’t attempt to use it during the Big Spin ride yesterday, and didn’t see anyone use it in the group I was with, but I assume it should’ve been available as those are group rides and results/place is turned off in the riders nearby list.

There were other people on the ride using it inside the first 30 minutes.

sounds like it is either a bug or they made changes to how it works?

I think it’s a bug and related to how long someone was in the start pen or what they were doing prior to the event start.

If so that would be a regression

Generally when you see it prior to the 30 minute mark it is a case of a rider moving from a free ride or one group ride into another. The time carries over, it has always been this way. It is time in the pen that does not count towards the 30:00.


I should add, I did not have coffee stop available in the first five minutes.

Tested this tonight. I rode 15 minutes with a pace partner and joined the Big Spin ride, 15 minutes into the event the coffee stop was available. Pretty sure it didnt count the 2 minutes I was in the pens.

Seems to be working as designed.

Timer is supposed to start when the event starts per the update from last year. Not carry over a full coffee stop to the start of a ride.

That might be what was published in release notes, I don’t remember? However since the Coffee Break was released it has always brought over the countdown timer from a previous ride as long as you join a group ride from your current ride and do not exit to main screen. If you exit and save a ride then join a group ride countdown timer starts over.

I don’t see anywhere in the release notes or updates from Zwift HQ about the carry over, but that is how coffee stop has worked since release according to @the_guaiwu