Apple TV 4k remote issues


(Jo Jo) #121

Hello All

I might found a solution for the problem. And it make sense, that Zwift has difficulties to find a quick solution.
I think Gleb Chugin indicates the solution I found today. Its about how you move your finger over the touch pad area.
There are two modes:

  1. You flick with your finger over the pad. Means: Touch the pad, flick to the top or button and release the finger again after the movement. This switches the different buttons within Zwift in the menus. Top, down, left, right where ever you want to go. For example from the button at the bottom of the screen into the scrolling list of the workouts. Thats what we do normally.
  2. If you touch with your finger at the top of the touch area and you wait a small time (0,5sec) and than move your finger over the touch area to the bottom of the touch area with light pressure to the touch area and slowly, you will see the cursor is moving from workout session to workout session single by single. If you than press the touch area you choose the selected workout “type” and you can move the cursor again with this technique single by single through the list.

Summary: Two touch modes

  1. Flicking from button to button
  2. “Scrolling” single by single step by touch, hold and move finger over the touch area.

Problem solved.

Please give feedback, if this works for you.

Thanks


(Patrick Hatcher (KinneyMS)) #122

@Jo_Jo you are a genius! I just tried and I can now select 1workout at a time. Well done!


(Gleb Chugin #adoptdontshop) #123

yes, I found that some time ago too, but this is not convenient and lag is huge — problem not solved.

The whole UI should be redesigned for ATV. All other companies did that for ATV versions of their apps. Having a computer oriented UI on a media box is ridiculous in first place. There is no need to play with sensitivity settings or whatever tvOS dev team is doing there atm, instead just fix the root of the problem and that is it.


(Jo Jo) #124

Hello Gleb

Yes, you are right. It’s still not perfect, even not near good. But now you can select a training.
So you can use the full functionality, which was not possible until now.

Bye


(Aaron Huie) #125

Not to pile on, but the Apple TV remote has always worked for me, but requires a lot of patience because has always been VERY poor in terms of response for me - nothing even approaching how it performs in other Apps. DC Rainmaker makes a lot of noise about how awful the remote is in his video on Zwift with AppleTV, but that’s not the remote’s fault so much as the App’s if you ask me.

Also, I just now tried the Apple TV app for iOS and that works BETTER, but still isn’t as seamless as it is in other AppleTV Apps.

I run Zwift on the latest Apple TV 4k with the latest software update.

This may be a separate issue, but I also notice that my Logitech Harmony IR remote, which operates normally otherwise with the Apple TV and its installed apps, doesn’t seem to work at all (at least not in any intuitive way) in the Zwift app. At most the ‘ok’ button might work. Beyond that it’s unusable for navigating within the app. I’m guessing this is more an IR interface issue than anything to do with the Harmony remote itself.

The AppleTV App is amazing otherwise… It just needs the remote functionality refined a tad.


(Barbara Bird) #126

After a couple of frustrating weeks with the AppleTV 4K remote using an older 720p TV, I broke down and bought a cheap Hisense 4K TV. Lo & behold, the remote now behaves as it’s supposed to. And I now have a full screen - on the 720p tv, the outer edges of the screen were cut off. If my Harmony 700 would work with Zwift, I’d only need one remote - it handles every other app I’ve tried on AppleTV but Zwift.


(Eiki Egilz) #127

@Vincent
Now I have a new problem only with the Workout/Plans window …
I simply can’t use it any more !!! Before it was bad, now it’s even worse. I changed to 720p on my 4k Samsung TV, trying to get the remote control in order … didn’t help at all. So now when I’ve changed back to 4k resolution ( both tried 50 and 60 Hz ) and now the Workout/Plan window is inaccessible !!! Both in 4k resolution, and 720p resolution. I even tried uninstalling and re-installing Zwift to fix the issue. Please see the video … I’ve also restarted the AppleTv4k five times, and flipping the resolution back and forth … it always crashes at this same dialog, please see the attached Youtube videos I’ve created

4 videos below clearly show this dialog … please see video #3 which explains the CRASH bug:

This video shows that this is once again, connected to the remote control … and it’s ONLY this Workout/Plans dialog which acts like this, just CRASHES!


(Lee Wilson) #128

Good job. Thank you. I have full, if slow, functionality!


(Eiki Egilz) #129

Hey there @Vincent :slight_smile:

Any more news on the progress of a fix here?

Kind regards,


(Vincent W.) #130

Hey there, the apple TV remote functionality is being worked on and tweaked. Are you still getting those crashes with your workout plan menu?


(Eiki Egilz) #131

Hi @Vincent,

Excellent to hear, that’s the main concern I have like you know … the remote issue on AppleTv4k

Yes, I’m getting the crashes the moment I go “out of bounds” on the workout/plans screen with the “pointer”/selection, not happening on any other screen … and I think it was not like that before the latest update release of the AppleTv4k/iOS update ( 31th of December 2018 )

Please let me know the progress of the remote fix, thanks

Kind regards,


(Vincent W.) #132

Thanks for the heads up, I’ll check in with our Apple TV team!


(Scott Sweeney) #133

The remote works on the training plan/work out screen once every 1000 tries. Pretty frustrating user experience.

Is there a workaround (or a fix) for this?


(Mark Spiteri) #134

Just adding one more voice to this.

Very recently bought an Apple TV 4K 64Gb as a dedicated Zwift device for my garage. Apple TV on latest OS patch level, and Zwift current too.

Finding it very difficult to move from option to option to select anything on any screen - I swipe and swipe and in most cases nothing happens. Yet I have no problems using the remote in any other apps, e.g. Netflix, Prime, Fulgaz, Settings …

Very difficult to start a ride unless you just stick with the defaults and click your way into the ride without changing anything, which is disappointing and challenging.

There must be a straightforward fix somehow … otherwise Plan B, could you add support for moving over the screen with cursor keys, as then I could use my TV’s universal remote which seems to work very well with all other Apple TV apps, but not with Zwift.

Cheers
Mark


(Rune Nielsen) #135

I have the exact same issues. Running Zwift on a brand new Apple TV 4K and the remote is basically useless. It’s hard enough navigating screens with just a few buttons, but choosing a workout is close to impossible. Every other app works just fine.

If fixing the issues with the remote isn’t really a priority, I hope it will at least be possible to select workouts etc. through the companion app instead at some point.


(Barbara Bird) #136

No problem using my Harmony 650 with AppleTV - works with every app save Zwift. The swipe/select is a major design flaw in the Apple remote IMO.


(. Tommo..) #137

i have Apple TV 4th Gen, and its nice to know this just isn’t me! Took me 5 minutes to get to the SAVE button after yesterdays ride! I don’t even bother with changing any kit, or selecting training sessions because I know it will be virtually impossible to select !


(Carl Rozema Pack) #138

For me setting touch surface tracking to slow worked. At least to be able to select a workout, which was impossible before. It is still not perfect, but I can live with it for now.


(Mike Cargal) #139

IF this makes a difference then it’s a serious indication that the developers don’t “get it” when it comes to using the Apple TV remote. I shouldn’t need to find a forum and plow through dozens of messages to understand how the use the UI.

Like just about everyone else in this thread, attempting to navigate the AppleTV UI with the remote drives my blood pressure to unsafe levels. The visual feedback is frequently either wrong or far too subtle, and determining which direction the developers intend us to swipe to navigate is a crap shoot. Add to that the incredible inconsistency of sensitivity to swipe gestures and getting around the UI becomes a “game” in and of itself (and not a fun one at all when you’re just trying to select and begin a workout).

It’s also fairly clear that you’re trying too hard to have a consistent UI with other devices. That UI just doesn’t work for the TV and remote. You can’t just tap on something. The interaction model with a remote is simply not as rich as other interfaces, this has to be taken into account to make it usable.

PLEASE!! Fix the sensitivity issues with the remote ASAP, but consider that a TV interface needs different affordances and revisit the TV UI with that in mind.


(Eiki Egilz) #140

@Eric hey there!

Could you PLEASE have your developers of the AppleTv look into this issue. This thread was created in September 2018, and like you see, there are numerous reports of this issue. I know it has been said “Zwift is looking into this” but as 10% of your users, have the AppleTv … this should be REALLY high in your priority lists of things that need to be fixed. Could you please tell us the status of this issue and how much longer we need to wait for a proper fix on this issue?

Kind regards,
EE.
Iceland