Apple TV 4k remote issues


(Rob Hancill | Rob Rides Emtb) #141

`I am a total noob to Zwift but use it on the Apple TV 4K.

I’m likely to cancel it as the remote experience is far too poor. It took me about 20 minutes to actually start due to the buggy interface / remote performance.

Sorry Zwift but you’re got buggy software here, not worth the monthly premium.


(Martin Haakansson) #142

This is the issue I also experinced.

But disabling the voiceover function solved the issue for me thx


(Andy) #143

cool Martin - to be clear , i was pointing out to Zwift support to actually reproduce the issue :slight_smile:


(T) #144

Can you explain, how did you disable the voiceover function?


(T) #145

Thank you for the great video, showing movement and response!


(T) #146

Thanks for helping Vincent. I have an Apple TV 3G, experiencing the same issues as those with the 4K.


(Dan Resnicow) #147

New ATV user here, first time this morning. I am having the same problems, it is unpredictable which way the highlighted button will move when I swipe on the remote, sometimes nowhere at all, and it is very difficult in some cases to see which button is highlighted (i.e. the arrows to choose between TdZ and the calorie mission). Very hard to get from the ride choice down to the start ride as well. It took way too long to get my ride going this morning. Voiceover is already disabled. Sometimes swiping has no effect, sometimes a swipe will move the highlighted button over several spots. Remote works fine in all other apps on the ATV 4k.

I’d guess that Zwift is well aware of the problem, and the issue comes down to the re-use of a UI that was not designed to work on ATV. Zwift doesn’t currently have the time or manpower to create an entirely new interface for ATV, it is on the list of to-do, but there are too many other platform fires to put out at the moment. We are probably just going to have to wait it out…


(Andy Linquist) #148

Have been using ATV 4K for a week. I only purchased it to use with Zwift. Same remote issues. It’s nearly impossible to select a course to ride on, select gear, or select workouts. I was pretty excited to switch from using an iPad because ATV looks better buts it’s so difficult to use that I’m beginning to regret shelling out the cash for a device Zwift claims to support but, from looking at this thread, has obviously done nothing substantive with for months.


(Steve) #149

Many issues here using ATV 4k, including all the remote issues mentioned above. Our big problem was the app would crash under the following conditions: BT connected milestone footpod, selected running, choose “training” in the top menu to access the workout menu. Upon attempting to scroll from the top level to any of the workouts, the app would crash. I switched to “ride”, connected my Kick’r, saved a short ride, disconnected the Kick’r, reconnected the footpod on the run side and it started working. Time will tell if this actually made a difference, but so far so good.

As for the remote issues - as others have mentioned - the remote sucks with Zwift. So I downloaded the Apple TV Remote app from the Apple store to my iPhone 6s and the app works way better in Zwift than the supplied ATV remote.

Next I’d like to see a custom workout builder for the run side.


(Aaron Huie) #150

For what it’s worth, my remote experience has improved a bit in the last month… It’s still not IDEAL, but it’s much better than it was the last time I chimed in. Now it only takes 2 or 3 attempts to get it to respond to swiping between items and even sometimes works on the first try. Much better than the often 5 or more attempts it took the last time I spoke up.

Now if they’d just allow us to turn off the menu music like you can in other platforms… Been waiting for that fix to come through since they announced it last year… I know the work-around is as simple as hitting mute or turning the volume down until you’re in the game for now, but it’s frustrating that ATV is the only platform where this feature isn’t available yet. Perhaps it will come with the ‘Guest World’ update when they finally roll that out for ATV?


(. Tommo..) #151

After what felt like many frustrated hours trying to navigate the Apple TV remote, I decided to look on the forum to find many other users with the same issue!
I think we are sometimes very quick to complain and not so inclined to thank! I have to say that there has obviously been some work done on this issue as my experience over the last week or 2 has been almost perfect! Chapeau zwift for listening and responding so quickly! Thank you!!


(🚴🏼‍♂️) #152

You beat me to this. I used my ATV on Friday and Saturday for the first time in a while. I found the whole navigation fine. Moving between buttons was easy.

Thank you, and as said above we do not thank enough.

Ride On!


(Lin) #153

While the remote is finicky, it is not the horrible mess one might expect after reading this thread or others on this board. For every complaint, there are probably dozens, hundreds?? of people who have no issue. That is the nature of the internet. Those w/out issues do not go online to say “I have no issues” This is not to discount those who are having problems. Like I said, on occasion I find it a bit finicky. But, the fact that it works fine for so many does make it hard from a developer standpoint to reproduce and/or fix.


(Jose) #154

^Hi,

Apple TV 4K 32GB same problem as you with the remote. :frowning:


(Pasi) #155

No need to repeat in more detail. Just another ATV4k/32 Gb here and using remote sucks. Otherwise, I’m very happy using Zwift on ATV.


(Lee Wilson) #156

Just a quit tip; product of my frustration over not being able to claim bikes I’ve earned! The remote wouldn’t move off the current frame. So, the tip, let the bike come to a complete halt, with riders foot on the ground, before attempting to select a new frame/bike. Worked the first try.


(Andrew) #157

This helped me so much already! I was getting so frustrated but it seems the Apple remote doesn’t work the same with zwift as it does when navigating the home screen.

Still need to spend some time using it on zwift but I was actually able to select things I was trying to!! Life saver!!!

Andrew


(Edwin) #158

When can we expect this issue to be fixed? This was first reported back in September 2018. I didn’t have any issues prior to then and have no issues using the Apple TV remote with any other applications. Seems to me it is an issue with whatever code changes were made to the Zwift app in September.

Quite frankly I don’t feel Zwift customers using Apple TV should have to wait nearly 6 months for a fix to this issue. This is even more of a problem since the recent update with world switching as it adds more complexity to the menu selection.


(Simon) #159

Just to throw some fuel onto the fire…
… I have absolutely no problems using the Apple TV remote on Apple TV 32 GB 4K in Zwift for riding or running, be it training plans, selecting training sessions (even from a list of many), changing settings, joining events, selecting kit, selecting screenshots before saving, saving, you name it, I’ve really no problems at all.


(Petri) #160

I’m experiencing difficulties in moving in the Workout and Pairing menu as well. Sometimes the focus is not moving at all no matter how many times I sweep my finger on the Apple TV pad. It is a bit difficult to exactly describe what the problem is, but I’m sure moving in the menus is not supposed to work like this. It is like the remote randomly works and sometimes not. I have the latest version of Zwift app on Apple TV 4k with the latest firmware.