Apple TV 4k remote issues

Could try the new remote. It’s not cheap. Can’t promise it’ll be any better. But otherwise no, no other input device works with Zwift. Aside from the iPhone control centre thing.

Get the new remote which is about ~60 USD. It is sold separately. Go to an Apple Store and check it out. It’s redesigned and should work better.

1 Like

There is no guarantee

“There’s an app for that” on an iPhone. It’s called Remote, and it’s also built into Control Center.
It let’s you control your AppleTV.

There are some users using ATV, but not an iPhone - it is a little bit expensive to replace a $60 remote with iPhone…

Shocking how badly the Zwift app is designed for Apple Tv - since they don’t even bother to design it for tvOS. Absurd.

Just went to try Fulgaz - this works properly… and obviously means our Logitech harmony remote also works just fine with it - as it does with EVERY other app we have on our Apple Tv as these apps are designed for the Apple TV, and not a pathetic, lazy bodge such as Zwift have made and charge monthly for.

3 Likes

There you have it! Still not working properly for AppleTv4k, using the new remote:

The next piece to know then is whether or not Zwift supports the new remote. Yes, apparently, you have to actually support that remote differently. How do I know this? Because, the new remote joystick doesn’t work in Zwift. It works great outside of Zwift. Super fast and responsive. But in Zwift? Nothing-burger. Literally, it doesn’t respond as noted above, and as shown in the video.

Zwift on New Apple TV 4K (2021 Edition): What’s different? | DC Rainmaker

Have the new ATV 2021 4K. The remote works perfect in everything but Zwift. Can not navigate at all, nothing, totally unresponsive to the point i can even exit the game. Both the directional arrows and touch pad work perfectly outside of Zwift. Have tried reinstalling the app, no change. Hope there is a fix in the pipeline as i purchased ATV due to it being listed on the Zwift site as a compatible device… ATV is literally a brick when running Zwift. Dissapointing is an understatement. Would strongly urge anyone considering ATV for Zwift to steer clear… my iphone 6 provides equally as good a picture. Anyone heard of a fix being worked on at Zwift HQ?

1 Like

Assuming you’re referring specifically to the new 2021 Apple TV 4K then that’s not what @Shane_Miller_GPLama found. He found that the touchpad works the same as on the previous-gen ATV 4K.

See Apple TV 4k remote is freezing - #10 by Shane_Miller_GPLama

Hi Steve, thanks… yes I saw that video also but it seems the severity of the issue varies greatly between users. Zwift support have been really helpful and come back with a few suggested things to try around interference and bluetooth. Hopefully will make a difference. I’ll post the outcome to hopefully help others in the same boat.

I just bought an ATV 4k 2021 model and the remote works flawlessly in all 20 apps I have installed except for the zwift app. It’s erratic and completely unusable. The arrow buttons don’t do anything and the swiping is on the touchpad is a complete russian roulette. You can do the same motion on the touchpad 3 times in a row resulting in: going down 10 steps in a menu, going up 4 steps or just doing nothing at all.
Since I don’t have an iphone to use as a remote I have no clue on how to use zwift of ATV.

1 Like

I have contacted Zwift Support about this.(directional buttons not working). They said I need to mention it here but it looks like you’ve all done that so can’t see how it will help.
Just needs lots more votes I guess to get their dev team to work on it. I also mentioned the poor graphics! Please everyone vote here to get this sorted for all us ATV users

2 Likes

I recently bought the 2021 ATV solely for the purpose of running Zwift on it. I’m disgusted at how poor the remote works. I wasn’t able to navigate at all other than “accept” and “back” until I read some of the “swipe tips” here. Now it’s somewhat better but I’ve no confidence in where I’m going in the interface. It’s just an incredibly poor user experience that should be addressed with some urgency. The remote has worked fine in other apps I’ve tried.

1 Like

There was some comment in Zwift Riders on FB about Zwift not prioritising support for the new AppleTV remote because people were not complaining about it enough.

Here’s a request: Please support navigation using the click wheel on the new Apple TV remote control.

Thank you.

nah… It’s Zwift being Zwift.

1 Like

Votes don’t mean much. Bugs and annoyances have been upvoted for years and nothing done. This Apple TV remote issue while not the same with previous remotes the lack of directional button support has always been and issue and feature request to update it for years.

It’s not :slight_smile: