Apple TV 4k remote issues

Hi there

The UI for AppleTv is severely broken, using the AppleTv remote. That’s a fact and Zwift have acknowledged that for a long time. So let’s not discuss any “tips and tricks” to get it working. It’s broken, and everybody knows it.

Which brings me to the point:
Zwift are releasing a completely new UI at the end of this year for new users on the platform. New users will get the new UI first. In the beginning of next year, everybody else gets this update. This UI will (hopefully) fix the AppleTv remote bug once and for all - it’s a complete rewrite of the code.

Just wanted you guys know since I’ve used this thread to notify people on the progress of this issue which was created 3 years ago and has still not been fixed up to this point.

Have a good evening all

1 Like

Where did you get this information?

I wouldn’t say this is the case, at all. Could the ATV UI be better, and the remote provide better functionality/ease of use? Certainly. Is it ‘severely broken’? Nowhere close. You may not like it, but it still works, even if a bit clunky.


It’s not a complete new UI, it’s just a new front-end section for choosing routes etc (which will hopefully be easier to use with the ATV remote).

The in-ride UI doesn’t appear to be changing at this stage.

From inside Zwift’s own HQ

Yes, I’m talking about the UI when selecting tracks / exercises / sync with your devices etc … basically all the stuff before you actually ride / run in the app.

That’s where the problem lies mostly, when setting up before committing to the exercise itself, e.g. the horrible track / exercise selector and that stuff.

1 Like

in addition trying to change bikes during a ride, is a nightmare using the Apple TV remote !

Post the source please.

1 Like

What apple TV remote are people using?

I have both Apple TV 4k and Apple TV 4K 2021. When I bought the 2021 I hooked it up to zwift but used the original remote. Since Zwift decided to try to support the remote I switched back to the new one. However I have become extremely disheartened by the bugs and lack of complete support for it. I am tempted to switch back to the older remote.

I particularly found it hard to select a pace partner today.

I wonder which remote other people are using?

I haven’t tried the new remote. I use the original 4K “Siri” remote. It’s not the best with Zwift, but I’ve got used to its foibles and don’t really notice it being a pain often. Except if I’m in a race trying to do a quick bike change and then I certainly do notice it when I’m trying to pick the correct bike!


I haven’t used zwift since Christmas since the weather has been so nice. Now I can’t choose routes or workouts using either of my appletv remotes. It’s worked fine for 2 years up until now.

Nothing has changed recently as far as I’m aware. Certainly swiping with the original Siri remote (black) or the new silver one will pick routes and workouts. I have an Apple TV myself.

Check that your remotes are not low on power.

Are you on the latest version? There was a bug like you described, it has been fixed (at least on my AppleTV).

I was so pissed and about to throw the remote thru my tv one day when I finally remembered it was rechargeable :man_facepalming:

Haha, the first time my remote seemed to be running out of power, I spent a while trying to figure out how to open it up to change the battery. I ended up Googling it, only to be amazed to find that it was rechargeable :man_facepalming:

For whomever I can help…

after figuring out some frustrating issues, I can now recommend Apple TV 4K 2021 for running Zwift for Run and Bike.

My issues:

  1. Zwift logon screen stores 2 user’s login info but we could not toggle between these 2 users. Only one user could be selected. This means that if my partner was the last to use the bike or treadmill and I wished to run then I need to re-login to my account. Once finished, my account is now the only one of the two that could be selected. Essentially this means the user has to login each time if they were not the last person to use it. This by itself was not a huge deal but annoying because of having to type out the password on the ATV remote. The functionality is there, why does it not work?
  2. More importantly, we could not switch between ride and run.

The new ATV remote has an outer ring circle for incremental movements. It also has an inner circle which operates as a track pad (swipe thumb) and selection button (push thumb). The Zwift app responds differently to the outer ring clicks and the track pad depending on where in the app you are trying to control. Choosing map routes for example requires the user to use the track pad to scroll through the routes. The user cannot use the ring to click one-by-one through the routes. I believe I’ve read this described as “menus” and “sub-menus” to differentiate. Menus allow the user to use either control method. Sub-menus only respond to the track pad.

On the user selection screen, the user can only use the track pad to select between the 2 available users and it’s very finicky. It’s difficult to get the cursor to change between the 2 users. Intuitively, with only 2 choices, one would think to use the ring to click up or down between the two users and then select by pushing the track pad centre. Using the ring to click up or down will move the selection cursor but not between the 2 users. It moves from the Policy in the upper right corner, to the most recent user, then down to ‘OK’. It skips the second user. If software changes are to be made, this is one area to do so.

On the Run/Ride page, it’s essentially the same issue. Using the outer ring, the user is able to navigate around the screen to highlight the Run/Ride toggle but then the track pad is needed to toggle between ride or run by swiping. Again, it is very finicky so it is not immediately evident that swiping does anything.

After figuring all this out, we are now able to switch between treadmill and bike (both devices on and bluetooth transmitting at the same time) AND switching between users for running on treadmill. Very pleased now. 2 hours ago I was ready to return the ATV.

Hope this info helps someone!


I have an AppleTV 4K 2nd Gen (2021) with silver remote and I was also fighting with UI and finding it borderline unusable wherever I had to swipe to navigate.

Very latest OS update installed as of today.

After some experimenting I discovered 2 things that help a lot with menu navigation issues:

  1. You can set the sensitivity of the track pad in the main AppleTV settings where you set the remote control settings. I found that setting it to Medium gives the best responsivness in Swift by far. Both High and Low are problematic and don’t seem to register touch effectively.

  2. This is very important: I find that if you keep your finger touching the track pad and then slide it up and down WITHOUT letting your finger lose contact with the surface of the trackpad, it seems to behave far more reliably and your control over the scrolling is far better.

All that said, the UI experience is still horrible whenever swipe / touch is involved and Zwift should really just rework all the menus to not require any touch / swipe control at all.

It shouldn’t be necessary to concentrate extra hard and focus carefully on how fast you move your finger to control the scroll and select things. Especially not in 2022 when it’s a forgone conclusion that menu navigation should be smooth, intuitive and 2nd nature in any app, all the time, particularly on an Apple device where good smooth UI is the hallmark of Apple’s offerings.


1 Like

Hey everyone!

Just wanted to let everybody know that Zwift finally released the updated UI for the AppleTv!
You can download it right now

It’s still a work in progress but I can confirm it’s much easier to navigate the new workout screen.

This thread regarding the AppleTv remote was created 4 years ago, hopefully this issue is gone for all the numerous AppleTv users using Zwift :slight_smile:

1 Like