Zwift won't adjust power and terrain after latest Wahoo KICKR firmware v4.21

Just did the latest firmware for my latest version of Wahoo KICKR and after calibrating in the Zwift app and through the Wahoo App on IOS the power and terrain don’t adjust properly. Anyone experiencing the same thing?

Yes. I did a firmware update (4.2.1) yesterday and kickr no longer changes resistance following the zwift profile in a workout.

Anyone knows how to downgrade the firmware to version 4.1.2?

1 Like

same for me.

Sounds like there may be a wider issue but ensure the Kickr isn’t still connected to wahoo app (or any other app) as this can Rob the signal off zwift

Make sure the wahoo kickr is listed as “controllable” on the pairing screen. Sometimes after updates this gets unselected.

Yes I’ve made sure of all of this disconnected everything. Uninstalled the app from Apple TV, from my phone. Made it controllable in both the companion app and stand alone. I’ve done all troubleshooting steps. The issue is either with Zwift or with the Kickr. There nothing more for me to test.

Yes I’ve already made sure of this.

Ensured. Strange thing - the icon to make the spin down appeared again, although the kickr calibrates itself. If you do the spin down and are supposed to go 37kmh then it feels like 37km downhill (no resistance). I opened a support ticket. Due to the fact that the Wahoo App show correct values while cycling the Kickr seems to work well. It’s connected via BT on Windows 10 - worked without problems since the upgrade of the FW to 4.2.1.
Since I am not aware of a possibility to downgrade the Kickr again we need to wait now.

@Tom_Antonucci just connect your Wahoo App and make a test ride. For me the values in the Wahoo App look reasonable and I don’t see a fluctuation in wattage while constant cadence.

I had the same thing with my tacx flux 2, also on the Apple TV (4k). Happened about 1,5 week a go. Don’t know now, because I just switched back to my laptop.

At the direction of Wahoo I did a test series they asked me to do in ERG mode where you go up in watts starting from 100 ride for a minute then go to 150 for a minute and then 200, 250. I sent them the .fit file afterwards for them to analyze. Does seem like a Zwift issue, hopefully both companies are reviewing what the problem is. I’ve shared this forum with both tickets I opened with each company. If you haven’t open one make sure to do so, so they realize this isn’t just a one incident problem.

2 Likes

I did a similar test on my end with the wahoo app and erg mode. Kept increasing power by 10W from 100 to 250W. Then down to 50 in one step. The kickr seemed to respond ok and with very little lag. Then I unplugged the kickr and powered off my phone so the wahoo app would not be a factor. After a few minutes I plugged the kickr back in. Then I connected my Garmin Edge to the kickr and started an interval workout. This is now via ANT+. The kickr changed the power without any issues through several intervals. The latest update (4.2.1) has an update to Bluetooth so I am guessing the issues with Zwift are Bluetooth related because with the ant+ connection the kickr seemed ok. I will be doing a test with zwift and ANT+ next week and see if the ANT+ fixes the issues.

BTW: I have done all of the steps suggested to make sure there are no multiple apps trying to control the kickr.

1 Like

Forgot to mention. I am running zwift on my MacBook Pro. No appleTV.

So I’ve just downloaded Rouvy for a free trial and did a test ride. Used my MAC and iPad and both experiences had the Wahoo Kickr adjust the terrain on the ride perfectly. This leads me to believe that the issue is actually with the communication between the Kickr and Zwift. I hope that Wahoo and Zwift can collaborate to find out what the issues is on the platform.

1 Like

Identical issue following the latest Zwift update on Apple TV and KICKR firmware update.
Terrain on free rides and power targets on structured workouts lag by an increasing amount (30 seconds to start, then a minute, then two minutes behind…) over the course of every ride. I’m able to control power targets on the KICKR manually through the Wahoo app on my phone while leaving it paired as a passive power meter on Zwift for now, but that’s a suboptimal and annoying solution.

1 Like

Today I heard back from Zwift support. They have acknowledged that this is a widespread issue and that their development team is working on a fix. In the meantime they suggested and shared the instructions on performing a downgrade of the Wahoo KICKR firmware. I was able to successfully install the older version and confirmed it fixes the problem. Instructions are below:

  1. Unplug the trainer for 10 seconds
  2. Open the Wahoo app .
  3. Make sure the Wahoo device is powered on.
  4. Click on the Wahoo device when it pops up (Blue Button).
  5. Wait for the Wahoo Device to connect, once connected tap the blue button to connect. At the next screen at the top tap 10 times on the little black icon of the Kickr to bring up the firmware update list. Choose the previous public firmware version.
  6. Allow the update to finish.

Thanks to all who opened tickets and contributed to this forum to raise awareness.

13 Likes

Thank you for the info @Tom_Antonucci!

Downgrading KICKR firmware to v4.1.2 worked perfectly and restored functionality. Thanks for the firmware downgrade trick. What a dumb problem. :neutral_face:

2 Likes

There is no blue button for me in ios. Steps 4/5

Are iOS instructions different ?

@Daniel_Rispoli_3390 … on iOS it’s the symbol of the Kickr on the screen with the metrics.
So first choose your sensor (Kickr) and the next screen should look like this …

… after clicking 10 times on the Kickr symbol the firmware versions appeared as described by @Tom_Antonucci

1 Like