Zwift won't adjust power and terrain after latest Wahoo KICKR firmware v4.21

Hi all - thanks for flagging this up. Zwift and Wahoo have been working together toward a resolution of this specific issue

Problem: The symptom that shows up is that Zwift isn’t controlling the KICKR after updating the Wahoo firmware to v4.21. This occurs when you’ve done the pairing (at least in our testing) through the iOS companion app.

Resolution: Power cycle the KICKR by turning it off, then turning it back on. This has permanently resolved the issue in our testing.

Hi Shuji, appreciate that Zwift and Wahoo have acknowledged this problem and are working on a resolution. However I disagree with your proposed resolution (as have many others stated) The issue is not isolated to pairing with the companion and is not resolved with a power cycle of the KICKR. It was also prevalent with pairing directly with the KICKR, with an Apple TV, and with using a MAC version of your app, as well as IOS version directly. Others have stated the same regardless of setup both on this forum and others. The only way to resolve this issue for now is to follow the steps above to downgrade to the previous version of Wahoo KICKR firmware 4.12. Hopefully what Wahoo and Zwift are working on together is an updated Firmware that resolves the problem once and for all.


Hi @Tom_Antonucci

Appreciate your followup. I would like to ask everyone to check your troubleshooting workflow.

During the troubleshooting process, it’s natural for players to log into Zwift from multiple computers to see if the problem is related to the specific OS platform as you’re describing.

If you leave one session open when you log into the second (or third!) - it confuses the game server as which device you intend to use, and weird symptoms like BLE dropouts, and random-feeling resistance changes will surface.

So - would you try this ?

  1. Save & upload (or trashcan) any open sessions If you want to be sure, power off any computers you don’t intend to use for testing step 6.

  2. On iOS / Android / Apple TV - swiping Zwift into the background does NOT terminate a session. To exit the app completely, you must either save & upload or trashcan your session.

  3. Wait at least 2 minutes after closing all instances of Zwift - this timeout gives the server a chance to determine which device you intend to use.

  4. While you’re waiting those 2 minutes - please manually update to the most recent version of Zwift iOS. Particularly on iOS - if you’ve set your App Store preference to not auto-update, you may be on an outdated build.

  5. Power cycle your KICKR while you’re at it.

  6. Fire up Zwift on your iOS device. Pair the KICKR as a power source first and then as a controllable signal.

Does that clear the issue? We’d especially like to know if it’s resolved if you’re on Wahoo’s v4.21 firmware.

Hi Shuji,

I really appreciate that this issue has Zwift’s attention. I can speak for myself personally, I have done all of the steps either by myself or at the direction of Zwift and or Wahoo through support tickets, and the issue still persisted. I ensured all platforms whether it was iPhone (IOS latest version of OS and app), MacBook (Latest version of software), iPad (Latest version of OS and app), Apple TV (Latest version of OS and app) I ensured all apps were closed out before checking the next including the Wahoo IOS app. The issue still persisted on all platforms. What has convinced me that this is a communication issue between the KICKR and Zwift is that even on the 4.2.1 firmware I was able to use other competitors apps (Rouvy for example) and there was no issue. Only when I took the steps to downgrade the firmware (which Zwift support advised to me to do) to 4.1.2 was I able to get the KICKR and Zwift to perform as expected. I hope this helps and that Wahoo and Zwift can find a resolution and new firmware update that resolves the problem once and for all. Until then I am sticking with firmware 4.1.2

1 Like

If downgrading the firmware worked for you - I would roll with that too if I were in your shoes.

For others reading along who are on Wahoo firmware 4.21 - can you verify that the power cycle step worked for you?

And if power cycling didn’t help - would you confirm that you do not have mutliple instances of Zwift running on several computers?

Many thanks folks - we’d like to build up enough data points to confirm that this is working (or not).

Ive done 3 separate sessions this week since updating and I unplug the kickr each time and still had the issue today.

I only run on one computer so no other platforms this week.

4 ride today seems better. Hopefully stays fix.

Confirming here on PC with the latest Zwift app, and confirmation of proper ERG functionality on Sufferfest, that the wahoo kickr and climb only work on Zwift with a firmware downgrade. The power cycle didn’t change anything, closing the wahoo app didn’t change anything, only the firmware reversal.

Ok it’s back again today. I’ll be doing the firmware rollback later tonight. Very disappointing.

Firmware rollback did the trick.

I use Zwift on my mac and I had issues with 4.2.1, too. My problem was that the connection broke down and I had no Cycling Power, the bike stopped moving. I disconnected the KickrV5 waited some seconds and connected again. Then I was able to go ahead with driving.

I only had one open session and it happened on two events.

After downgrade to 4.1.2 I had no issues, everything is fine now.

I’ve tried rolling back on IOS on both iPhone & iPad separately but can’t move on to the next stage - tapping 10 times + on the image on both devices doesn’t work. The firmware currently installed (v4.2.1) is shown at the bottom of the screen.

I can’t upload screenshots as I’m a new user.

Any ideas?



With the latest firmware version I noticed the ERG/power controlling problems disappeared when I use a Garmin cadence sensor and not the Wahoo Kickr. I therefore believe it is a cadence sensing issue. What a total ck up for a £1000 machine and a £140pa subscription

1 Like

There’s a new Zwift iOS update. I road yesterday without rolling back and everything seemed to work fine.

It’s strange that after updating the KICKR firmware to v4.2.1, I only experienced problems with lagging/random/incorrect gradient changes in New York: particularly on the Sky Loop. And only while free riding, during events in New York everything worked fine. All rides in other worlds have worked fine, thankfully. Just rolled back to v4.1.2 tonight, looking forward to enjoying riding in NY again.

I was getting the issue in Watopia (repeatedly). Cannot recall if I was in France however. I’ve rolled back the firmware and will be testing it later - not sure if the new game version is on Apple TV yet…

It is, and I’ve been using it.

1 Like

Has anyone who found the firmware rollback to work tested upgrading to the current firmware with the latest Zwift release?

Does this firmware rollback also apply to older Kickrs. Eg, ‘17 ??? I have the same phenomena using ATV, companion etc…ERG seemed to work prior to summer 2020 and now rarely works even though there have been no firmware updates since 2018 for this KICKR…which kinda points to it not being a firmware issue…maybe IOS?


I have been experiencing the same connection issues with Kickr V5 and Macbook Pro 2016. Problems started immedately after the 4.2.1 firmware update. I´m not using any other hardware for running Zwift - so no possible double connections etc. Power cycles does NOT solve the problem. Resetting the Bluetooth module, deleting Bluetooth settings files on my Mac, factory resetting the bletooth module etc. etc. does not work, at least not for more than a few days. The latest Zwift game (1.0.63185) didnt do the trick either (with FM 4.2.1). Sometimes the ERG mode works, most times it does not. I ended up buying the Wahoo Direct Connect dongle, and was really looking forward for trouble-free Zwifting - only to find out Zwift has not added support yet. I didnt imagine Zwift wouldnt support it right away…

Other apps do, and the ERG-mode on the Sufferfest is responsive up/down within one second (Zwift, over Bluetooth, before firmware issues was more like 4-5 seconds). May I suggest both a firmware fix and support for Direct Connect please?