Wahoo KickR Resistance Too Low


(Vincent W.) #1

This was a popular topic that sparked a lot of discussion, so we’ve decided to bring it over to our new forums! Any duplicate topics created will be merged with this one. Enjoy the discussion and Ride On.

I’ve searched and found several posts with similar symptoms but none of those posts have come to any resolution.

I’ve been talking with Zwift tech support for months and have made zero progress. It’s like they don’t believe me… I’ve sent a ride log, but I don’t know if anyone even looked at it. I scanned through it myself and I can see the commands from Zwift to change resistance values on the KickR.

Problem:

While in “just ride” mode the flat road resistance through the KickR is much too low. I have to ride in 50-11 at 80+ rpm just to get over 250 watts.

It works fine in a workout. Works fine with ERG mode turned on. Works fine with ERG mode turned off when I can control the incline.

Works fine through the Wahoo app.

Additional info:

  • Spindowns completed through the Wahoo app and through Zwift
  • FW on the KickR is up to date
  • Power cycled the trainer many times
  • Uninstalled and reinstalled Zwift on AppleTV and on a Windows laptop
  • Same behavior with the AppleTV over Bluetooth and with the Windows laptop over ANT+
  • Changing the difficulty setting in Zwift does not alter the flat road resistance, it only changes the resistance felt on hills (up or down)
  • None of the suggestions from Zwift tech support have made any difference.

It is my belief that the commands being sent from Zwift to the trainer are incorrect. It should be commanding a higher resistance setting.

Has anyone else experienced this and actually found a solution for it? Does anyone have any other suggestions beyond the “Did you try turning it off and back on again?” help that I’m getting from Zwift?


(Mark Butler) #2

Hi Vincent, I have recently started using a KickR and Zwift, over the last week. I am having exactly the same issue, i believe.

As the gradient increases i feel very little resistance change but thought it was me.

if i use the wahoo app, the bluetooth light does flash when i increase the ressistance on the app, so wahoo app seems to be able to drive resistacne changes just not Zwift !


(Craig Warner (TIGR C)) #3

I’m not always seeing this same issue, but I have been having a lot of issues with my Kickr and Zwift (bought in 2015).

My biggest frustration is in workout mode, because the weirdness makes it difficult to do the workout. But I’ve seen things such as inverted gradient, i.e. when I ride up one of the mountains, the steeper it gets (on the map) the lower the resistance gets on the kicker. So to get up the steepest gradient I’m in the 50-11 and spinning out. Likewise, going down the descent can barely turn the pedals. It’s intermittent too. Normally a restart sorts it out, but it’s a poor experience.

On a free ride it’s annoying but, short of a complete drop out, I can account for it and Zwift is still as effective and enjoyable as ever.

Workout is a different beast. In ERG mode it can’t seem to hold the required power. For example today, the target was 3 minutes at 190w. Cadence was 87 and solid, but power would hover around 175. In some ways this is better than locking in at 210, say, and making the workout overall too tough, but if following a plan, 3 mins at 175-180w when the goal is 190w isn’t helpful. Should state this is Zwift controlling the kickr, but reading power and cadence from Infocrank power meter. Afer a minute or two of an interval, it does seem to workout what it’s supposed to be doing. Sometimes. :slight_smile:

I tried a group workout in Zwift Academy the other week and it was impossible. Trying to hit 240w and there was no way to get it over 90w. The harder/faster I pedaled to try and increase the power, the resistance just got lower. Very odd. It’s this sort of thing which I think is similar to the original post complaint.


(Vincent W.) #4

Hey Mark and Craig,

Kickr’s have had resistance trouble with Zwift in the past. I’d recommend first troubleshooting with our BLE resistance guide.

You can also send in a support conversation so we can check out your log files. They help us pinpoint exactly where the dropouts are happening. :slight_smile:


(Karissa Minn) #5

I had the same problem recently, and it did seem to mostly happen with Zwift (it’s hard to tell, because I wasn’t doing much indoor riding earlier in the summer). I usually use ANT+ to connect. For a while, the small ring on my bike suddenly was useless, and I’d be close to spinning out if I was doing a hard effort. :confused: And trust me - I don’t put out very much power!

It seemed to get better once I completed an advanced spindown on the Kickr. You do a 10-minute warmup and then go through the spindown protocol twice. Supposedly, if you open the Wahoo Fitness app, go to “Spindown,” and tap on the paragraph explaining the spindown five times, it should pop up the Advanced Spindown screen. I never got this to work on my Android phone, though - in fact, I could not get the advanced spindown to appear in either the Wahoo Fitness or Wahoo Utility apps for Android. One of them prompted me to do it after I completed a normal spindown, but I was not able to access it again.

If you have an iOS device, it’s a lot easier. Open the Wahoo Utility app, connect to your trainer, and there should be an “Advanced Spindown” button right there for you to tap (you might have to go to “Spindown” first and scroll down - I can’t remember exactly).

See if that helps. :slight_smile: If not, maybe it’s a coincidence that mine is working better now, but I think it helped to reset something with my Kickr.


(Craig Warner (TIGR C)) #6

Thanks for the reply Vincent. I only use ant+ and the sensor is right under the kickr (on the central arm). I’ll keep an eye on it now I know this thread is here and if anything off happens I’ll send in the log files.

Cheers


(Nate C) #7

I have had multiple episodes of loss of Kickr (original with latest released firmware) resistance, usually in ERG workout mode over the past few weeks and it really ruins the experience …

I’m using an iPad Air 2 with the current iOS version.

When the kickr stops changing resistance with the workout or grade, it’s nearly impossible to get it to sync back up. Power cycling the trainer usually does not work even if unpowered for 30s.

I found I can bring it back sometimes, if I open up the Wahoo Fitness app, (after disconnecting zwift pairing) and send a few ERG wattage change commands, then quit the app and switch back to Zwift and repair on the setup screen.

It seems like this issue started about a month ago (on the 1.0.28834 version? I updated to 1.029385 tonight but haven’t ridden with it yet.

(I do have my Stages LR dual power meter paired as power source, and the kickr paired as a controllable Bluetooth trainer if that helps narrow down the problem…

Has anyone else seen similar behavior?

Thanks!
Nate


(Craig Warner (TIGR C)) #8

Just to update on the issues I’ve seen - I think I’ve resolved the ‘can’t hit the numbers’ issue in workout mode. By resolved, I mean I now understand how it works…

I ran my Wahoo Bolt alongside my Zwift ride and used different power views. Difference I’m seeing is 3 second power avg, vs. the live power which I’m expecting. I could match the 3s view on zwift to the Bolt exactly. By riding to the immediate power on my Bolt, I could ride the segment more accurately (e.g. more power, earlier to force the adjustment in game) and the 3 second would catch up. Similarly I would see a drop off more quickly. This would also explain why sometimes I think I’m too low vs. target for segment but still

Still doesn’t help with short intervals (anything less than a minute with Kickr feels like a guaranteed fail), but from an true effort perspective I can train accurately.

The sporadic issue with resistance, or lack of, which others have mentioned hasn’t gone away. Will update if I see it happen.


(Vincent W.) #9

Thanks for the reply Craig! We’re still investigating the cause of Kickr resistance issues, but we have heard some workarounds that might help. Can you try to:

  1. Launch Wahoo app and run KICKR in app
  2. Disconnect KICKR
  3. Close Wahoo app
  4. Launch Zwift and pair KICKR

And see if that makes any difference in how you feel?


(Hannah Robinson Z3) #10

I’m having this problem only in group rides. I’ve done all the troubleshooting. It works just fine until I “join” a group then I get no feedback from terrain just keeps changing my cadence and watts and slowing me down. No matter the terrain the resistance won’t change and my watts go down as the game shows increases slope. I’m beyond frustrated trying to do a group ride today and have tried to enter 3 times and failed. 6 hours later I’m going to try again. It’s taken my entire day since I can’t join a ride whenever it’s concienvenent. If you miss the window you wait 2 hours.


(Hannah Robinson Z3) #11

Also, frustrating that it worked just fine until past few weeks. Seems like I updated zwift app and it quit working. Not sure why you say this for sure is kicker problem because it worked fine for a couple years until just recently and lots of people seem to be having same issue. I wasted 4 hours today trying to get stage 5 of tour of Innsbruck. First 2 sessions failed at 2 miles. Most recent one failed after I summoned first climb. (It worked for a while then quit). I pay a lot of $ for this and have been unable to use it properly this month. Is there a way for me to be able to install older version of app when everything seemed to work just fine?


(Mark Dodgson) #12

I too have been having a similar issue.
I have used Zwift for a while now but only on Free Ride. This week I decided to try out a training schedule (Gran Fondo). During the warm up the resistance seems to be incredibly high when starting off but the reduces (too low) when I can finally get the rpm up.
Also, during warmup and the remaining workout I am unable to get my wattage above 134 no matter how much power I put in to it. The screenshot below is whilst I am pedalling hard (I would say around 230W)

Another related issue is that a low cadence workout for example when I have to pedal at 55rpm at 190W. Pedalling at 55rpm the resistance does not change so I cant output the desired wattage.


(Karissa Minn) #13

It seems like there are 4 or 5 different problems listed in this thread, which may or may not be related.

  1. The issue posted in the original post, which Mark Butler and I are describing. This is the overall resistance of the Kickr being low, so much so that it would force us into high gears and can cause “spinning out” at relatively low watts. (It has gotten much better for me after an advanced spindown.)

  2. The first problem Craig Warner described. This is gradients on the Kickr seeming to be inverted - resistance gets lower on hills and higher on descents.

  3. The second problem Craig Warner described, and that Mark Dodgson also has experienced. This is not being able to hold the required power with the Kickr in ERG mode (Craig’s was while reading power from a power meter - not sure about Mark’s).

  4. The issue Nate C is describing. This is sporadic loss of resistance with the Kickr during a ride.

  5. The issue Hannah Robinson is describing. This is losing gradient simulation on the Kickr when joining group rides.

@hannah_robinson_Z3 , are you experiencing #1, #2, #3, or #5? @Nate , how about #1, #2, #3, or #5? @doddi , have you seen #1, #2, #4, or #5 happening? @Craig_Warner , are you experiencing #1, #3, #4, or #5? @mark_butler , have you had trouble with #2, #3, #4, or #5? The only one I’ve had a problem with is #1, though I haven’t used ERG mode recently.


(Mark Butler) #14

Hi, I have had problem with 4 and 5 I believe.


(Nate C) #15

Essentially, when #4 happens for me, then #1, #3, and #5 are also true.

When this happens, it seems to put the kickr in a state that it doesn’t even recover normal operation on unpairing from Zwift and using the wahoo fitness app to connect it and try gradient or Erg mode. At basically any pedaling effort, the kickr will report 100+ watts and start spinning out even though my bike’s power meter will be showing the true output of 40-50w.

It seems like what might be happening with Zwift is that the kickr is reporting higher power numbers, so zwift keeps reducing the requested resistance to try and reduce the power (I. E. Goal power =200w, kickr incorrectly reports 300w effort so it keeps reducing resistance to try and bring you to 200w, and suddenly you’re spinning out despite actual power as measured by an external power meter of well less than 200w.)


(Mark Dodgson) #16

I would say #4 does happen for me.
I have never tried a group ride so cant say if I am affected by #5.

I had a support response yesterday that it might only be an issue when using bluetooth for connection between Zwift and my Kickr. Today I will try connecting with my Ant+ dongle to see if that solves my issue


(Ian Ross Pack) #17

Hi since the recent update my Kickr has lost resistance on climbs yet shows I am putting out 300+ watts. Get to the top of the climb and my power drops, as I would expect but the resistance increases to the point that I can hardly turn the pedals. It is the same on the flat but not as bad. It’s as if everything has been reversed. I use a Kickr2 paired to my Mac by Bluetooth.


(Mark Dodgson) #18

I tried using the Ant dongle instead of bluetooth and it had the same issues.


(Bill Maddrell Wbr(C)) #19

I’ve got all these problems too. Kickr snap, stages powermeter connected to kickr via ant, iPad with newest iOS. All firmware is up to date. It seems to work when free riding, workouts and group rides not so much.


(David Jepson) #20

I too have a similar issue. For the past few months, I have to ride in 53/12 to get any kind of resistance.

What’s interesting is I sometimes I warm up for a few minutes before loading zwift. As soon as the kickr connects to zwift, I can feel all the friction in the kickr release.

I use the apple TV app with a BT connection from my kickr. It worked just fine for over a year, then a few months ago, it went to crap.

I have tried calibrating the kickr, upgrading the firmware, switching to the mobile link etc. Nothing improves the outcome. The kickr works fine when just using their fitness app.

I have tried calling support, but they just drag the issue out and eventually close my case.