Zwift update now freezes on launch

Ok I haven’t logged onto Zwift for a few weeks as have been recovering from an injury.

It automatically downloaded yesterday’s update but once installed the Zwift launcher won’t load and it hangs on a white screen.


I’ve tried uninstalling the whole program and downloading again bit to no avail. Looking back on previous posts Zwift have uprated the minimum hardware requirements which if this is the case there is no way I will be replacing my windows laptop which was perfectly fine before the update!

Any clues please folks?

Hi @Keith_Clothier

What are your laptop specs?

Minimum system requirements will change as Zwift increase features and more roads and detail.

1 Like

Hi thanks @Gerrie_Delport for your reply laptop specs (from ‘about my PC’) are;
Capture
Cheers Keith

1 Like

I find that if you go the folder where zwiftlauncher.exe (PC) is located and right-click and run it as administrator it has fewer issues.

Thanks @Ray_Ruyack I gave that a go but same result i.e. it appears to install but freezes on launch :frowning_face:

Zwift minimum/better requirements (as of Feb 2020)

My laptop should be more than adequate … :thinking:

Re-install…

Tried that too, I also deleted all the Zwift files and re-installed same issue

And it was working before?

Yes perfectly

I have the same issue on my s10e smartphone since the 4/3/20 update. Can’t open the app since then.

Ok, might you have another computer to install it on and try? Does someone know if it is possible to download previous software versions to check something like this?

That’s a good idea … though not sure how it will fix the problem on my own pc? I’ve emailed Zwift but don’t know when I will get a response from them?

I’d be curious if it ran ok on a computer that never had it installed on prior. Just wondering if an uninstall really gets rid of all remnants.

I’ll see if I can install it on my wife’s laptop and report back :slight_smile:

Good programmig should be les power intemsive not more, or at least have the option of runnig at lower spec. You price more than a modern game but thats how games work.

I have the dreadied hang o nupdates zzzzz hrs to download about 30kb by the look of it

Ok … I have managed to install it successfully on my wife’s (much older) laptop. It took ages to load up up seems to run ok. When I uninstalled from my PC I manually deleted all of the remaining Zwift files again without success. Very frustrating!

Launcher log on my PC reads;
[12:44:41 2020-04-06] Launcher: Checking for VerCur Override
[12:44:41 2020-04-06] Launcher: prefs.xml file not found.
[12:44:41 2020-04-06] Launcher: Startup Registry Key Found.
[12:44:41 2020-04-06] Launcher: Auto Startup is Enabled.
[12:44:41 2020-04-06] Launcher: Starting with Admin Privilages
[12:44:41 2020-04-06] Launcher: Launcher Version Number 1.0.50
[12:44:41 2020-04-06] Launcher: Checking for 64-bit OS
[12:44:41 2020-04-06] Launcher: Setting Sleep Callback
[12:44:41 2020-04-06] Launcher: Initializing UI Components
[12:44:41 2020-04-06] Launcher: Setting Browser Events
[12:44:41 2020-04-06] Launcher: Initializing Tray Components
[12:44:41 2020-04-06] Launcher: Initializing Patcher
[12:44:41 2020-04-06] Launcher: Setting Login URL
[12:44:41 2020-04-06] Launcher: prefs.xml file not found.
[12:44:42 2020-04-06] Launcher: Found Launcher URL.
[12:44:42 2020-04-06] Launcher: prefs.xml file not found.
[12:44:42 2020-04-06] Launcher: Navigating to Login URL
[12:44:43 2020-04-06] Launcher: Displaying Main Window.
[12:44:44 2020-04-06] Launcher: Checking for Internet Connection
[12:44:45 2020-04-06] Launcher: Patcher Update Process Check
[12:44:45 2020-04-06] Patcher: Patcher Version Number: “1.2.20”.
[12:44:45 2020-04-06] Patcher: Local download path set to “C:\Users\waveh\Downloads\Zwift”.
[12:44:45 2020-04-06] Patcher: Server URL path set to “http://cdn.zwift.com/gameassets/Zwift_Updates_Root/”.
[12:44:45 2020-04-06] Patcher: Local update path set to “”.
[12:44:45 2020-04-06] Patcher: Kicking download of “Zwift_ver_cur.xml”…
[12:44:45 2020-04-06] Patcher: Kicking download of “Launcher_ver_cur.xml”…
[12:44:46 2020-04-06] Downloader: “Zwift_ver_cur.xml” downloaded successfully (manifest checksum not provided, i.e. -1).
[12:44:46 2020-04-06] Downloader: “Launcher_ver_cur.xml” downloaded successfully (manifest checksum not provided, i.e. -1).
[12:44:46 2020-04-06] Patcher: Completed downloading server XML version files (Game & Launcher).
[12:44:46 2020-04-06] Patcher: Fetching version attribute from file: “Zwift_ver_cur.xml”
[12:44:46 2020-04-06] Patcher: Local version is “0.0.0”.
[12:44:46 2020-04-06] Patcher: Server version is “1.0.48638”.
[12:44:46 2020-04-06] Patcher: Local manifest is “Zwift_0.0.0_manifest.xml”.
[12:44:46 2020-04-06] Patcher: Server manifest is “Zwift_1.0.48638_ed405c41_manifest.xml”.
[12:44:46 2020-04-06] Patcher: Server manifest file checksum is “1991470670”.
[12:44:46 2020-04-06] Patcher: Server ver_cur checksum is “-790865359”.
[12:44:46 2020-04-06] Patcher: Local Launcher version is “0.0.0”.
[12:44:46 2020-04-06] Patcher: Server Launcher version is “0.0.0”.
[12:44:46 2020-04-06] Patcher: Launcher URL for updating self is “www.zwift.com”.
[12:44:46 2020-04-06] Patcher: Update available (0.0.0 != 1.0.48638) false
[12:44:46 2020-04-06] Launcher: Launcher Update Process Check
[12:44:46 2020-04-06] Launcher: Checking for Game Update Availability
[12:44:46 2020-04-06] Launcher: Game Update Found

It appears to hang on the update?

It seems that the uninstall didn’t get rid of everything… Are you familiar with regedit? I see one entry here - Computer\HKEY_CURRENT_USER\Software\Zwift in the registry. Not sure if that a possible issue. Try an uninstall then delete that registry key. BE VERY CAREFUL poking around in the registry… Try renaming the folder in MyDocuments to Zwiftold and let the install make a new folder. You can always copy your activities over later.

@Ray_Ruyack thanks for that. I deleted registry folder for Zwift and I had already deleted the folder in My Documents. Unfortunately the problem persists. :confounded:

So we know your wife’s laptop works…

If you install the program and don’t do the update does it run? Is the install the updated version?