Zwift thinks BLE is off after Win10 reinstall? [SOLVED]

I’ve been using my Dell laptop for years to connect to Zwift with little issue, except for maybe the RunPod. From what I can tell the runpod uses BLE not Ant+. I had trouble getting my Zwift to see my pod and would get dropouts. I was having other issues with the laptop so I decided to reinstall Win10. Downloaded Zwift and tried to run. Nope, can’t connect the pod at all now. Zwift says the BLE is off, it’s not. I actually have my Sony headphones connected via bluetooth right now and it’s working fine. I even tried to update the drivers. All up to date. What is happening?

This might help?

7 Likes

@Roger_Morris_HCC

A clean Win10 install lacks that runtime environment that used be included in Win7. Follow that link that Ben posted. That vc_redistx64.exe file solves this exact problem you’re having.

Would you follow up and let us know if this resolved your issue? We like hearing a conclusive yes.

3 Likes

Totally worked. Why the F doesn’t Zwift tell people this. I was ready to crack open my PC to try and fix or replace the bluetooth radio. Thank you. If anyone from Zwift is listening, inform people of this.

5 Likes

Worked for me too on clean win 10;install. Thanks

Thank you.
I’ve spent weeks looking for an answer to get Bluetooth working in zwift, when it would work fine with every other windows application.

Unfortunately this hasn’t resolved the issue for me, I was hopeful! By any chance do you know your receiver / bluetooth type? Mine is CSR (I think), maybe there are multiple types and some work with the fix and others don’t?

Problem solved by buying this adapter and installing today

Its therefore clearly dependent on what type of Bluetooth adapter you have on your PC. I did have a plug in USB dongle previously which wasn’t working, think it was CSR chip on it so think that’s the issue.

1 Like

Yes it worked for me. I have a Surface pro 3 and I needed to re install Windows 10. After I did I got the Bluetooth not switched on error from the Squirrel. I installed the C++ from this link and it worked immediately. Thank you.

1 Like