Impossible to connect bluetooth devices on windows 10

Hello there!

I have a Dell XPS 13 9360, and I’m having lots of trouble with the bluetooth connection. Until yesterday, it all worked fine, but I had to re-install Windows 10, and I updated everything and installed Zwift, and my surprise is that bluetooth is not working any longer.

I tried the ‘sfc /SCANNOW’ workaround, which I think worked last time I had this issue, I updated the bluetooth fw, even the BIOS of the laptop :smile:

Is there a new Windows (or Zwift) update that is messing this up again? I can’t train right now…

Yes, I know that an ANT+ dongle would help, but 2 days ago it worked in the exact same hardware, I don’t want to pay for a thing I don’t need.


You can use the Zwift Companion App to bridge Bluetooth connections to the PC. Direct connection using Bluetooth is not very stable at the moment.


And the companion app doesn’t add a delay in the information transfer between the trainer and the pc? I mean it uses bluetooth + wifi, against just bluetooth, right?


The Zwift Companion App connects to the Zwift App over your local network. The delay would depend on your local network speed.

I am having exactly the same issues since today with my XPS13… the only working solution was to use an USB ANT+ dongle.

Maybe it was some update, it’s strange…

It works now and I’m not sure that this is the reason, but it started working right after I installed the bkool application (I was thinking about changing platform)… Maybe that other app installs some kind of driver? I don’t know, but finally I can zwift again!

1 Like

running Windows 10, Version 1903 update, with the native BLE in Windows 10 Devices.

Initially found Bluetooth & all sensors paired. Worked flawless for my 2 hour ride, no drop outs, etc.

My wife logged in - same computer bike/trainer, heart rate monitor, zwift app (different login) less than 2 hours later (no upgrades or restarts occurred) & showed displays message that" bluetooth receiver is off"

Tried again with my zwift ID and now I get the same “Bluetooth receiver off”.

Restart does not resolve.

Any ideas/thoughts to resolve that are NOT ant/dongle or companion app related?