Bluetooth devices not seen on Windows 10 [SOLVED]

Hi all,

Appreciate if anyone can help. I have a HP Pavilion laptop connected to my Elite Directo turbo trainer via Ant+ dongle. This has been working well and had no issue.
I have ordered the Sterzo smart and recently found out that Zwift only support Bleetooth connections. The laptop does not have an internal bluetooth. I had an CSR Bluetooth 4.0 adaptor kicking around so have tried that but zwift wont pick this up as the internal Bluetooth. Recently purchased a broadcom BLE adaptor and still the same.
Both work at the windows level and connect to bluetooth devices no issue.

Does anyone know if I can update something so zwift will recognise them?

The Sterzo smart arrives this week so wanted to try and get this sorted in advance if possible.

Kind Regards

I’d chase that down at the OS-to-hardware level. What flavor of Windows is it? If the hardware predates native Bluetooth implementation, its it possible the OS doesn’t support Bluetooth 4.0?

I am running the latest Windows 10 and feature pack.
Sterzo arrived today and managed to get working with companion app. My only concern is that regularly drops during a ride but at least I have got it working. Hopefully Zwift will support on Ant+ soon.

If it’s a clean Win10 install (meaning not upgraded from Win7 or 8), you may be missing some framework files that Microsoft didn’t include on Win10.

Go here
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
and download and installed the file called vc_redist.x64.exe

Would you try that and let us know if it resolved your native BLE issue?

Hi Shuji

Many thanks for the advice. I have installed this and does seem to answer the issue. I’ll do a proper test tonight with the Sterzo and BLE dongle but at least there are recognised.

With the Elite Sterzo Smart, it is a lot of fun to control your avatar! (Please connect it to Repack Ridge)

I had intermittent Bluetooth connection issues out of the box. I was able to figure it out. Here were my troubleshooting steps.

  1. Bluetooth Dongle…Frequent Intermittent Connection
  2. Windows 10, vc_redist.x64.exe updated (was Win7 update to Win10 PC)…Still Frequent Intermittent Connection
  3. Iphone Companion App…Still Frequent Intermittent Connection
  4. Press down on the batteries…Still Frequent Intermittent Connection
  5. Change default Varta batteries to Energizer…Worked Perfectly for over 10 miles!

Hope this helps!

Holy Crap, this actually might work! I will update after my ride today

This worked, I am thrilled! I received my Sterzo Smart over a week ago and haven’t been able to get it to pair. I emailed tech support and didn’t get much of any help, posted on this forum and still couldn’t get Zwfit to pair. I was soooo bummed. And then I saw this post this morning and 5 minutes later it’s working!! Awesome, now I’m back to being excited again as I was when I was able to find and order a Sterzo Smart. Cool!

Zwift , you somehow need to make everyone aware of this who is having trouble!! I only happened to stumble on it.

1 Like