Zwift PC Bluetooth issues

@Leonardo_Palavecino
Thank you for updating your game version.

Would you send us your log.txt file from the latest log in, please? Here’s where to locate the logs.

Please attach that to an email to support@zwift.com. Ask for Shuji in the body of the email and mention this forum thread, and we’ll get to our QA team to look at. Thank you.

1 Like

thanks. i-ll do asap

Same issues here. Bluetooth working and can connect all sorts of other apps and hardware.

Zwift states Bluetooth is turned off.
And unable to connect, Companion is just as bad, connects, then drops out. Avatar keeps running on screen at the last speed recorded…

1 Like

I’m having a similar issue: Zwift thinks the bluetooth is turned off, when it’s on and Windows can recognise the device.
Zwift has just done an update, the BLE dongle and its drivers are brand new
I run the speed/cadence sensor through ANT+, but the HRM is only bluetooth.
So, is the answer to get an ANT+ compatible HRM (yet more spending…), or sack Zwift off and go with Sufferfest/Rouvy?

1 Like

im having the same issue. every other BLE device is connecting just fine to my PC but zwift says my adapter is off. Was looking forward to joining this app/community but guess ill hold off until it’s fixed.

I was getting the error 126 with a new Windows 10 unit I was upgrading to. I opened a ticket with support and they quickly came back saying I was missing the C++ runtime from MS vc_redistx64.exe
I installed the x64 version rebooted and now BLE is working just fine in Zwift. I’m surprised this isn’t mentioned in the installation and troubleshooting guides.

8 Likes

Thanks for the information! I’m willing to try anything at this point!

Anthony M Spencer
Sent from my iPhone

@M.Milner This did not work for me.

The 64 bit C++ redist install worked for me on old PC with Windows 10 2004 and a TP-Link Nano UB400 USB dongle. Thanks for posting that @M.Milner

Cheers
Si

Thanks a lot. Solve my problem on a Lenovo G40 trough our procedure. The bluetooth of PC is ok to pair with powermeter!!

Had the same exact issue!

Windows 10 2004 on a i5 Intel nuc (~5yrs old).
Asus USB BT4 dongle would work just fine in everything except for Zwift pairing, where it would say that my BT is disabled.

Installing vs_redistx64 from the MS website solved the issue instantly.

My Tacx Bushido Smart now pairs up with power, cadence, and controllable.

Thanks champs!

Same problem here, same fix. Drove me crazy until I found the error 126 message in the Zwift log and started poking around BleWin10Lib.dll using Dependency Walker.

It would be nice if Zwift either bundled that with its installer, or popped up a message dring startup when loading the DLL fails to make it obvious why Zwift thinks Bluetooth is turned off.

I had to do a fresh install of Windows (formatted C and started over - dedicated zwift computer) to fix some real buggers that an AMD driver caused. Had the exact same issue - solved it with the referenced 64 bit C++ redist referenced above, thank you!

Hello Shooj
I am experiencing the same issues Jonas was having.
I have ran the Lenovo scan and there were no issues reported relating to Bluetooth.
I have tried updating my Bluetooth drive yet I am being told I am using the most up to date version.
I have checked my zwift folder and there is only 1.
Do you have any other suggestions?

Install this: Visual C++ Redistributable Runtimes All-in-One (Jul 2022) Download | TechPowerUp

Reboot your PC afterwards and try again.

11 Likes

Thanks Dave. Seems to have worked a treat

2 Likes

Much thanks for the reference to the fix. I built a system from scratch with a Plugable USB bluetooth 4.0 adapter running a 2004 updated version of Windows 10 pro. No problem getting Windows to see the bluetooth Coospo heart rate monitor or Wahoo Kickr Core however Zwift didn’t recognize the bluetooth adapter. Installing all the Visual C runtimes fixed Zwift. A not at all obvious solution. Zwift support should document this or fix their installer to include the appropriate runtimes.

This did the trick for me! Many thanks!

For reference I was using a bluetooth 4.0 dongle and after installing the stuff from your link and rebooting zwift picked it up!

This hasn’t solved my Bluetooth issue. Zwift still doesn’t recognise that my Bluetooth is turned on. Windows does.

I found the external usb Bluetooth dongle to be better.

Like the avantree DG40S