Zwift Rides Not Syncing with Garmin Connect [December 2021]

Have you tried doing it from the website on a pc.

Thank you for that. I have successfully linked Garmin via my Profile on the main zwift site.:blush:

1 Like

Happy to help.

Just had the same issue. Synced to strava and training peaks but not Garmin.

Had this a few weeks ago too.

I followed the instructions to download the information but I cannot connect to Garmin from Zwift… the orange cross continues and it does not open the possibility of connection.

any other recomendation to fix it?

Are you doing it from the website and do you have Garmin Connect open and logged it on another tab.

I already did it from the web and from the app, with Garmin connect open and closed. It doesn’t work in any way.

any other recommendation?.. would it be useful to uninstall the app?

@Jose_Antonio_De_Echa My connection has been working forever but thought I would uninstall and reinstall to see if I could help you …

On Android, I deleted the Companion App then reinstalled. The initial connection attempt momentarily bought up a Garmin authorisation screen but it immediately disappeared and no connection made. Now when I go to add Garmin, nothing happens.

From the web, The auth box asks for Garmin credentials, which is prepopulated, I then go through the Garmin username/pwd, accept agreements then get an error

This failure is repeatable if I keep doing the same thing.

Then rather than accepting the pre-populated Garmin credentials, I manually entered them and connection was successful. So hopefully that works for you.

1 Like

thank you, i¨ll try in this way

Very often my activity fails to sync to Garmin Connect but syncs fine with Strava.
If I try to manually import the FIT file to Garmin Connect it fails, but usually, when I run it through the corrupt time fixer tool on, the corrected file imports successfully.

1 Like

I did it several times and it didn’t work

I mean, Dean´s recomendations

Bugga … hopefully its gets sorted for you Jose.

thanks for this advice. had exactly the same issue like you (did not syn to GC but strava works fine). then used the corrupt time fixer and now it works. WTF

An alternate approach if you’re using Strava… download the GPX file from Strava and upload that to Garmin Connect. Works every time.

I suspect something in Zwift is creating a malformed .fit file which Garmin Connect is rejecting - this suspicion is based on having tried to download the original .fit file from Strava and seeing GC reject it every time.

@Zwfit devs - perhaps there is some issue in how you’re writing the .fit file, and Strava is more lenient than Garmin Connect?

It doesn’t happen always, so the process is probably correct, but I think it might be interrupted before it is finished sometimes and that causes a problem. Or there are some time jumps in the file which Connect refuses but Strava just corrects (Strava does some post-processing on the file everytime, but keeps the original file too).

thank you Erik … i’ll try