Zwift Rides Not Syncing with Garmin Connect [December 2021]

In case it helps someone - I got this for the first time the other day; The only thing I did differently to usual was to tab through a couple of steps on a workout, so I can only assume that this messes up the timing when transferring to Garmin Connect.

Running the file through FIT File Tools sorted it so I was able to upload.


These sync issues are really incredible. I did 2 rides today. First a warm-up and then a TT race. The first one synced to Strava, but didn’t sync to Connect (fitfiletools corrupt time fixer helped). The second one didn’t sync to Strava, but synced to Connect. Mind blown. Literally.

Exact same experience today. Usually no problem uploading to Garmin, but after skipping a couple of steps on a workout tonight - no garmin upload. Strava upload went as normal

I have the sync problem from last Thursday, same today, the workout are sync with Strava and Training peaks but not on connect

Still not able to sync to Garmin Connect since December 2021, have to manually down-/upload .fit file. Very annoying to say the last. Location: Switzerland.

I’ve also started to suffer from this issue. My workout correctly sync to Strava and Today’s Plan but not to Garmin Connect since May 28th.

1 Like

I’ve tried to download the .fit files from the Zwift website and import them manually into Garmin Connect. However, it seems the file is corrupted or there is an issue with Garmin Connect’s manual import service.

@shooj should I open a new thread to help debugging the issue?

1 Like

5 posts were merged into an existing topic: Zwift not syncing to Connect